Ask / Submit

Revision history [back]

click to hide/show revision 1
initial version

posted 2019-01-21 11:37:49 +0300

Simple fix is to install connection sharing with connman

pkcon install usb-moded-connection-sharing-android-connman-config

Then you need to fix up the config file as it seems connman now treats the USB connection as an ethernet device and not a gadget device anymore.

Edit /etc/usb-moded/dyn-modes/connection_sharing-android-connman.ini

Change the last line from: connman_tethering = /net/connman/technology/gadget

to

connman_tethering = /net/connman/technology/ethernet

And things should work again.

Simple fix is to install connection sharing with connman

pkcon install usb-moded-connection-sharing-android-connman-config

Then you need to fix up the config file as it seems connman now treats the USB connection as an ethernet device and not a gadget device anymore.

Edit /etc/usb-moded/dyn-modes/connection_sharing-android-connman.ini

Change the last line from: connman_tethering = /net/connman/technology/gadget

to

connman_tethering = /net/connman/technology/ethernet

And things should work again.again. At least it did on my XA2

Simple fix is to install connection sharing with connman

pkcon install usb-moded-connection-sharing-android-connman-config

Then you need to fix up the config file as it seems connman now treats the USB connection as an ethernet device and not a gadget device anymore.

Edit /etc/usb-moded/dyn-modes/connection_sharing-android-connman.ini

Change the last line from: connman_tethering = /net/connman/technology/gadget

to

connman_tethering = /net/connman/technology/ethernet

Also you need to edit the /etc/connman/main.conf and add this line:

TetheringTechnologies = wifi,bluetooth,gadget,ethernet

And things should work again. again (after connman/usb_moded restart / reboot). At least it did on my XA2XA2.

I noticed connman is also compiled with --disable-gadget for some mysterious reason, that might be the actual right fix.

Simple fix is to install connection sharing with connman

pkcon install usb-moded-connection-sharing-android-connman-config

usb-moded-connection-sharing-android-connman-config

Then you need to fix up the config file as it seems connman now treats the USB connection as an ethernet device and not a gadget device anymore.

Edit /etc/usb-moded/dyn-modes/connection_sharing-android-connman.ini

Change the last line from: from:
connman_tethering = /net/connman/technology/gadget

/net/connman/technology/gadget to

to

connman_tethering = /net/connman/technology/ethernet

Also you need to edit the /etc/connman/main.conf /etc/connman/main.conf and add this line:

line:

TetheringTechnologies = wifi,bluetooth,gadget,ethernet

And things should work again (after connman/usb_moded restart / reboot). reboot). At least it did on my XA2.

I noticed connman is also compiled with --disable-gadget for some mysterious reason, that might be the actual right fix.

Simple fix is to install connection sharing with connman

pkcon install usb-moded-connection-sharing-android-connman-config

Then you need to fix up the config file as it seems connman now treats the USB connection as an ethernet device and not a gadget device anymore.

Edit /etc/usb-moded/dyn-modes/connection_sharing-android-connman.ini

Change the last line from:
from: connman_tethering = /net/connman/technology/gadget to connman_tethering = /net/connman/technology/ethernet

Also you need to edit the /etc/connman/main.conf and add this line:
TetheringTechnologies = wifi,bluetooth,gadget,ethernet

And things should work again (after connman/usb_moded restart / reboot). At least it did on my XA2.

I noticed connman is also compiled with --disable-gadget for some mysterious reason, that might be the actual right fix.

Simple fix is to install connection sharing with connman

pkcon install usb-moded-connection-sharing-android-connman-config

Then you need to fix up the config file as it seems connman now treats the USB connection as an ethernet device and not a gadget device anymore.

Edit /etc/usb-moded/dyn-modes/connection_sharing-android-connman.ini

Change the last line from: from:

connman_tethering = /net/connman/technology/gadget
to 

to

connman_tethering = /net/connman/technology/ethernet

/net/connman/technology/ethernet

Also you need to edit the /etc/connman/main.conf and add this line:
line:

TetheringTechnologies = wifi,bluetooth,gadget,ethernet

wifi,bluetooth,gadget,ethernet

And things should work again (after connman/usb_moded restart / reboot). At least it did on my XA2.

I noticed connman is also compiled with --disable-gadget --disable-gadget for some mysterious reason, that might be the actual right fix.