Ask / Submit
1

Manual network selection doesnt work

asked 2015-07-20 16:04:27 +0300

ossi1967 gravatar image

I'm on holidays and desperately trying to get at least some network coverage for voice/SMS. While playing with the settings, I found that it's impossible to manually selecta network. There's a checkbox for automatic selection that's always checked. When I try to unselect it, I'm presented with a list of networks (which I can update, so scanning works kind of... sometimes). However, tapping on any of the entries in this list doesn't do anything. The only reasonable action is to swipe back to the previous page where I find the checkbox for automatic network selection still active.

edit retag flag offensive close delete

Comments

On earlier version (1.0.7): After search, tapping on a network (non-grey) selects the network as it should, and returns to previous screen showing the manually selected Network, and "Select network automatically" unchecked. Could someone reproduce this on 1.1.6 / 1.1.7 to confirm if it's a new bug?

simo ( 2015-07-20 22:09:49 +0300 )edit

During my holiday trip a month ago manual network selection worked just fine on 1.1.6.27, IIRC pretty much just like you described @simo.

zagrimsan ( 2015-07-21 11:48:07 +0300 )edit

@ossi1967 Would it be possible that there was no roaming agreement between your operator and any of the available networks in the location where you tried? (all grey in the list of networks?)

simo ( 2015-07-21 12:28:47 +0300 )edit

@simo no, they're not grey. they work on the other phone which has a SIM card frome the same Austrian carrier. I've been spending my holidays in this very same hotel for more than ten years and it has always worked. plus, I work for my carrier at home, I'd know if their roaming agreements had changed. :)

ossi1967 ( 2015-07-21 21:02:21 +0300 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2015-07-20 22:04:10 +0300

tigeli gravatar image

I'm on holidays now too, so I'm not going to try reproducing the issue. However last time when I was abroad (1 month ago) the manual network selection worked ok (Germany/Italy). Though sometimes the registration into network X can take more time than the specified timeout in the modem firmware for network registration. When this happens the UI can state that the registration has failed but in fact it is still on going from network point of view and the device will suddenly get network connectivity on the selected network.

IIRC.. the timeout is 120sec (but will not check as on holidays) ;).

@ossi1967 So when you select a network no busy signal (spinning icon) or anything shows on the UI?

edit flag offensive delete publish link more

Comments

@tigeli now that you asked: I tried several times during breakfast, thinking that maybe it needed nore time (closer to 120sec). During these tries (20 or so maybe) I got a spinning icon twice. The first time it disappeared so quickly that I thought it was just a reflection, but I got curious. After a few more tries, I got a spinning icon again - this time longer. Too long, it didn't lead anywhere. Interesting that at some point during these experiments, the checkbox for automatic network selection indeed became unchecked and I couldn't get it back on again. It's like something's going on beneath that's not reflected well in the UI, something that blocks certain actions under certain conditions. Again I have to stress that I'm in an area with weak reception. My Nokia 808 picks up signals even indoors, though, while the Jolla sometimes fails even outdoors.

ossi1967 ( 2015-07-21 10:35:34 +0300 )edit
Login/Signup to Answer

Question tools

Follow
3 followers

Stats

Asked: 2015-07-20 16:04:27 +0300

Seen: 294 times

Last updated: Jul 20 '15