Media files on SD no longer indexed.

asked 2015-07-26 22:01:49 +0300

boggins gravatar image

updated 2015-07-26 23:12:36 +0300

I have most of my music on my SD, and up until a couple of days ago had no problems with indexing. But now it only indexes the files on internal storage. I have 1.1.6.27

I also have a lot of old pictures on the SD, and again, these are no longer indexed - I only see the ones in internal storage.

Restarting, and removing/re-inserting the SD card does not help. The SD card is visible through other apps, e.g. File Browser, and I can see that the media files in question are there. I can navigate to a music file using FileBrowser, and it plays OK when I select "Open".

I am aware there are several similar question in tjc, which have been closed or are marked as duplicate, but none of the provided solutions have worked for me.

I have tried various commands from the terminal including:

  • tracker-control -es
  • gsettings set org.freedesktop.Tracker.Miner.Files index-removable-devices true
  • systemctl --user restart tracker-miner-fs.service

and I have tried the utility provided by Jolla under Settings->System->Utilities->"reset media database".

None of the above help.

I can see from tracker-control --list-miners-running that the Extract, Applications, Files, and Userguides trackers are running.

Can anybody help?

edit retag flag offensive close delete

Comments

I had the exact same problem on 1.1.6.27, and was unable to solve it, no matter what I tried. I finally gave up and performed a factory reset, and everything works again. I'm not at all sure about this, but I think it happened after I installed FileCase from Warehous.

I know it takes a couple of hours to get back on track, even if you do have a good backup, but I think trying to solve that mess will take even longer than a factory reset.

eson ( 2015-07-26 22:17:45 +0300 )edit

I'm not aware of anything particular that I did - installation of new software etc - which triggered the problem. It just seemed to be indexed one day, and not indexed the next. I don't have FileCase installed.

boggins ( 2015-07-27 00:56:53 +0300 )edit

Thanks, then I can exclude FileCase as possible cause.

eson ( 2015-07-27 07:05:32 +0300 )edit

Just to check this: Do you have a file with the name .nomedia in the top directory of your SD Card? This file would prevent tracker from tracking everything on the SD card. Check this with ls -la /media/sdcard/[ID of your SD card]/.nomedia. If it says that this file or directory can't be found this case can be excluded.

wanderer ( 2015-07-27 16:40:55 +0300 )edit

No, I do not have such a file (.nomedia) on the SD card.

boggins ( 2015-07-27 18:08:57 +0300 )edit