Bug: cannot play GSM6.10 voice mail wav's sent by email

asked 2014-01-04 21:16:03 +0300

Fuzzillogic gravatar image

updated 2015-09-15 22:43:56 +0300

My SIP VoIP-provider sends voice mail messages by email. (sample file). Unfortunately, Jolla, just like the N9, cannot play these wav-files. I can download them in the mail client, but cannot open them from there. They do not show up in the media player. The File Manager now has the option to play media files directly in the file manager, but trying to play the wav yields nothing (silence).

(Relevant) output of mediainfo:

Audio
Format                                   : GSM 6.10
Codec ID                                 : 31
Codec ID/Hint                            : Microsoft

Output from gstreamer:

[nemo@localhost ~]$ gst-launch-0.10 filesrc location=8kgsm.wav ! decodebin ! pulsesink
Setting pipeline to PAUSED ...
Pipeline is PREROLLING ...
Missing element: MS GSM decoder
ERROR: from element /GstPipeline:pipeline0/GstDecodeBin:decodebin0/GstWavParse:wavparse0: Internal data flow error.
Additional debug info:
gstwavparse.c(2110): gst_wavparse_loop (): /GstPipeline:pipeline0/GstDecodeBin:decodebin0/GstWavParse:wavparse0:
streaming task paused, reason not-linked (-1)
ERROR: pipeline doesn't want to preroll.
Setting pipeline to NULL ...
Freeing pipeline ...

Fwiw, my Kubuntu 13.10 desktop has no problems with these files, using exact same gstreamer command. Both Jolla as Kubuntu report GStreamer 0.10.36.

[edit] Even on SFOS 1.1.9 the player can't play these files. I thought this would be fixed with GStreamer 1.x?

edit retag flag offensive close delete

Comments

I think Jolla can not play WAV files. I tried it with some music files and it didn't work.

Neo ( 2014-01-04 21:33:16 +0300 )edit

@Neo when I convert the sample to a standard 16-bit pcm file using avconv, the file plays just fine on Jolla, using both gstreamer as in the media player.

Fuzzillogic ( 2014-01-04 21:41:36 +0300 )edit
2

We simply need a beefed up gstreamer, for this, this and this ...and many other reasons.

attah ( 2014-01-04 21:53:56 +0300 )edit

Did you try installing qt5-qtmultimedia-plugin-mediaservice-gstaudiodecoder, for more see also https://together.jolla.com/question/53560/qaudiodecoder-support-missing/ This worked for me in playing wav files.

filipb92 ( 2014-08-17 20:55:10 +0300 )edit

That didn't help with my wav files though.

Fuzzillogic ( 2014-08-17 23:08:05 +0300 )edit