Ask / Submit
1

[Bug]QtWebProcess not exit [answered]

asked 2015-08-05 16:26:41 +0300

BirdZhang gravatar image

updated 2015-08-06 11:12:02 +0300

Here is my application source code :https://github.com/9smart/harbour-littlerace

I use python http.server start webserver,when i use pull down to quit application ,QtWebProcess not exit

[root@Jolla nemo]# netstat -tunlp|grep 8000
tcp        0      0 0.0.0.0:8000                0.0.0.0:*                   LISTEN      15710/harbour-littl 
[root@Jolla nemo]# ps -ef|grep 15710
nemo     15710  1057 10 20:56 ?        00:00:26 /usr/bin/harbour-littlerace 
nemo     15817 15710  8 20:58 ?        00:00:11 /usr/lib/qt5/libexec/QtWebProcess 33

When i us Sailfish SDK debug this application,when click this image description

QtWebProcess exit.

I add a button to call Qt.quit() ,this can also left QtWebProcess quit.

So,is this a bug of "pull down to exit " ?

---------------------------2015-08-06 16:10---------------------------

It seems fixed by itself ;) WTF!

edit retag flag offensive reopen delete

The question has been closed for the following reason "the question is answered, an answer was accepted" by BirdZhang
close date 2015-08-06 18:18:57.372361

Comments

Since it fixed itself, you should close this question.

jollailija ( 2015-08-06 14:49:18 +0300 )edit

1 Answer

Sort by » oldest newest most voted
1

answered 2015-08-06 18:18:33 +0300

BirdZhang gravatar image

I think this is the real answer

Replace return SailfishApp::main(argc, argv); to this

int main(int argc, char *argv[])
{
    QGuiApplication* app = SailfishApp::application(argc, argv);
    QQuickView* view = SailfishApp::createView();
    view->setSource(SailfishApp::pathTo("qml/Demo-A.qml"));
    view->show();
    QObject::connect((QObject*)view->engine(), SIGNAL(quit()), app, SLOT(quit()));

    return app->exec();
}
edit flag offensive delete publish link more

Question tools

Follow
1 follower

Stats

Asked: 2015-08-05 16:26:41 +0300

Seen: 156 times

Last updated: Aug 06 '15