Ask / Submit
3

SMTP - problem with logging/certificate [answered]

asked 2013-12-25 13:03:46 +0300

pigletto gravatar image

updated 2014-01-07 15:51:47 +0300

VDVsx gravatar image

I'm using postfix SMTP server configured with SSL and PLAIN password (certificate is not trusted). Every time I'm trying to send email from Email app using this account I get: - "Problem with logging" ("Problem z logowaniem" in Polish) message shown on my Jolla. - SMTP server logs show "SASL LOGIN authentication failed: Invalid authentication mechanism"

Same settings just work with Android devices. I suppose this might be a problem with untrusted certificate as there is no way on jolla to accept these. I'm not sure though. Ideas?

edit retag flag offensive reopen delete

The question has been closed for the following reason "the question is answered, an answer was accepted" by VDVsx
close date 2014-02-03 09:20:33.468875

Comments

1

Try adding your certificates to the device in developer mode. They should be in /etc/ somewhere. There is a related item about being able to add certificates.

tbr ( 2013-12-25 16:07:46 +0300 )edit

1 Answer

Sort by » oldest newest most voted
1

answered 2013-12-25 18:16:49 +0300

VDVsx gravatar image

It's a bug, fixed in next update.

edit flag offensive delete publish link more

Comments

Still same issue after upgrade to 1.0.2.5...

pigletto ( 2013-12-27 23:43:03 +0300 )edit

I've tried setting PLAIN authentication as described in: http://talk.maemo.org/showthread.php?t=92122&page=2 but it doesn't seem to work. I did:

ag-tool update-service 3 email int:smtp/authentication=2

SMTP server logs still shows 'LOGIN' auth method. Setting above to 3 shows CRAM-MD5 though.

pigletto ( 2013-12-29 15:38:13 +0300 )edit

I think VDVsx thinks future update not 1.0.2.5.

Zagothal ( 2014-01-09 17:27:37 +0300 )edit
1

Yes, unfortunately, some fixes had to be pulled from 1.0.2.5, so next update.

VDVsx ( 2014-01-09 20:46:33 +0300 )edit

Still no luck after latest update. Seems that e-mail client can't deal with PLAIN passwords:

> myhost[83.4.189.80]: 220 my.smtp.server.pl ESMTP Postfix (Ubuntu)
< myhost[83.4.189.80]: EHLO [127.0.0.1]
> myhost[83.4.189.80]: 250-my.smtp.server.pl
...
> myhost[83.4.189.80]: 250-AUTH PLAIN LOGIN
> myhost[83.4.189.80]: 250-AUTH=PLAIN LOGIN
...
> myhost[83.4.189.80]: 250 DSN
< myhost[83.4.189.80]: mypassword
match_string: mypassword ~? CONNECT
match_string: mypassword ~? GET
match_string: mypassword ~? POST
match_list_match: mypassword: no match
> myhost[83.4.189.80]: 502 5.5.2 Error: command not recognized
(...)
lost connection after UNKNOWN from myhost[83.4.189.80]
disconnect from myhost[83.4.189.80]

After initial EHLO email client sends my password: 'mypassword' which seem to be invalid command at this point

pigletto ( 2014-02-01 11:21:28 +0300 )edit

Question tools

Follow
2 followers

Stats

Asked: 2013-12-25 13:03:46 +0300

Seen: 429 times

Last updated: Dec 25 '13