We have moved to a new Sailfish OS Forum. Please start new discussions there.
4

Changing TOH while playing music causes Jolla to turn off [not relevant]

asked 2015-08-24 13:32:48 +0300

Spam Hunter gravatar image

updated 2015-08-25 23:21:38 +0300

EDIT* - I have 2 batteries, the original Jolla battery and the Polarcell HTC310 battery. After swapping the batteries back and forth, I can no longer reproduce the problem. Are users with 'only' a Jolla battery also experiencing this bug/problem?

As the title suggests; while Mediaplayer is playing a track, I decided to change my black TOH for the white one. The music stopped and the screen went black - I then realised the phone had switched itself off. I switched it back on, all is working fine. I am able to reproduce this almost every time, even when using Flowplayer for music instead of Mediaplayer.

However, I have also found that the TOH cover can be very gently snapped on without causing the phone to turn off, but snap it on at a normal pace and the device crashes.

To reproduce, simply open Mediaplayer, play a track, remove your current TOH and snap on another TOH - the device should rapidly switch off. (all my TOH's ambiences are already installed).

Can anyone reproduce the same problem?

Regards,

edit retag flag offensive reopen delete

The question has been closed for the following reason "question is not relevant or outdated" by Spam Hunter
close date 2018-11-27 22:34:17.243964

Comments

hi @Markkyboy can you give some more details and try around a bit more? id like to know: when you change TOH is your screen locked? does it also crash when detaching and attaching the same TOH. and does it happen immediately or with a short delay?

misc11 ( 2015-08-24 15:24:36 +0300 )edit

Good points there @misc11

  1. Display was ON when crash occurred.
  2. No, detaching the TOH does not cause the device to turn off.
  3. Yes, reattaching the same TOH still causes the device to turn off.
  4. It happens immediately, phone loses power instantly.
Spam Hunter ( 2015-08-24 15:52:20 +0300 )edit

I wonder if this is related to the battery bug? run MCE Tool and check the battery resistance

r0kk3rz ( 2015-08-24 15:56:00 +0300 )edit

Just tested it and I am unable to reproduce. Do you see the red LED while it is turning off? Are you able to reproduce it by yourself? Maybe you are experiencing a bad battery contact?!

Alex ( 2015-08-24 16:02:10 +0300 )edit

@Markkyboy hmm im not sure but i always thought the NFC has a short delay. and since the physical force seems to play a role there my guess is a harware defect on your device. battery? i dont think so since it only happens when playing music (i guess). so maybe it is the audio stuff on the board (loose connection or sth).

all in all we need someone else who can reproduce. i cant reproduce it but im running v1.1.6.27 (if that even matters)

misc11 ( 2015-08-24 16:06:47 +0300 )edit

1 Answer

Sort by » oldest newest most voted
1

answered 2015-08-24 14:30:59 +0300

JakeTheChangeling gravatar image

Just tried switching between White and LETOH while QuasarMX played, both ambiances not installed and never will (still would like to turn off that notification). Absolutely nothing happened. Same goes for SirenSong and FlowPlayer. Maybe you accidentally pressed the power button while snapping it on? Or it is related to Mediaplayer being installed since I don't have it.

edit flag offensive delete publish link more

Comments

Hi Jake, your 'answer' is not really an answer, it's a comment with questions, please consider changing your response to a comment, thanks.

To answer your points; No, no accidental push of the power button occurred. I have only tried this with Mediaplayer and Flowplayer. Seeing as you don't have the ambiences or Mediaplayer installed on your device, you are not really testing under the same circumstances that I have.

Spam Hunter ( 2015-08-24 14:44:34 +0300 )edit

Oops, wrong button. How do I change it to a comment?

Will install everything for test purposes now. EDIT: now everything installed, in Mediaplayer changing to LETOH did nothing, but back to white changed the track.

JakeTheChangeling ( 2015-08-24 14:49:10 +0300 )edit

'could not reproduce bug' is an answer. Comments are more for clarifying the question.

r0kk3rz ( 2015-08-24 15:54:32 +0300 )edit

No worries, usually at the bottom right of the answer box, (edit # flag offensive # link # more) there is a more option, click that and it should offer you 2 options, 1 being to change answer to comment.

Okay, thanks for your input Jake, much appreciated.

Spam Hunter ( 2015-08-24 15:56:52 +0300 )edit

@r0kk3rz - I guess you're right really, didn't see it that way initially.

Spam Hunter ( 2015-08-24 15:58:29 +0300 )edit

Question tools

Follow
1 follower

Stats

Asked: 2015-08-24 13:32:48 +0300

Seen: 3,501 times

Last updated: Aug 25 '15