Ask / Submit
14

wlan/wifi connection dies and requires restart [not relevant]

asked 2014-01-05 14:20:47 +0200

mja gravatar image

updated 2014-02-12 23:53:46 +0200

Need to restart phone approximately once a day because wifi dies and just shows a star on the signal indicator

edit retag flag offensive reopen delete

The question has been closed for the following reason "question is not relevant or outdated" by JSEHV
close date 2016-02-01 15:09:16.570295

Comments

There are a lot of questions regarding connection issues, see https://together.jolla.com/question/6113/lots-of-connection-errors-while-on-wifi/ and https://together.jolla.com/question/4047/wifi-issues-sometimes-keeps-disconnecting-and-reconnecting/. If you think it is a duplicate, please close.

Neo ( 2014-01-05 16:01:51 +0200 )edit
1

I believe this is a separate issue as I don't get any reconnect - the star on the signal indicator is persistent.

mja ( 2014-01-05 18:30:24 +0200 )edit
1

for my case is show symbol wlan with ! (WiFi true available (other wifi product work well) but don't know why can't connect manually or automatic. just show problem with connection) slow work around, power off /on jolla

redge73 ( 2014-01-05 21:24:54 +0200 )edit

I had that now with both WLAN and MobileData - in my case connman hung itself and even crashed Settings

chemist ( 2014-02-06 12:29:48 +0200 )edit
1

I've seen this problem a couple of times since I upgraded to 1.0.5.19. In my case the symptoms are a bit different: the WLAN icon doesn't show up at all, and if I go to Settings, System, WLAN and do "connect to Internet" it just says "Oops, couldn't find any networks", same for "search again". If I run 'ip addr' in Terminal, it says that interface wlan0 doesn't have an ip address, flags are No-CARRIER, BROADCAST, MULTICAST, UP, LOWER_UP and state is "DORMANT" (whatever that means). Going offline / online (flight mode) doesn't help either. However, doing (in Terminal) devel-su; rmmod wlan; modeprobe wlan helped (before I found that one I had to power-cycle the Jolla).

tingo ( 2014-05-05 23:39:05 +0200 )edit

1 Answer

Sort by » oldest newest most voted
1

answered 2014-02-06 01:21:17 +0200

richhanz gravatar image

I don't need a reboot anymore: made an icon for it

edit flag offensive delete publish link more

Comments

1

I just go to offline mode, and back online

teun ( 2014-02-06 07:43:36 +0200 )edit

Did that this morning and it did not work. It works different: in offline mode the wlan module was still loaded. My reset unloads the wlan module. My reset worked.

richhanz ( 2014-02-06 14:34:11 +0200 )edit

does not work, connman gets in a state where it cannot establish any connection, I don't know if it crashes dbus... last time (an hour ago) I was unable to side-swipe some apps including settings I did not want to close but events-view worked and from there I went back to console to reload the kernel module as I was in the middle of showing the device to someone... nothing helped in the short time so I rebooted.

chemist ( 2014-02-06 21:55:22 +0200 )edit

My script gives the jolla 20 secs to settle after unloading the module, before loading it again. The first times i didn't use the script - did it by hand the load went to 16+ and I saw the WiFi icon change

richhanz ( 2014-02-06 22:05:18 +0200 )edit

Tried (manually) devel-su; rmmod wlan; modproble wlan tonight. It worked - thanks!

tingo ( 2014-05-05 23:40:13 +0200 )edit

Question tools

Follow
4 followers

Stats

Asked: 2014-01-05 14:20:47 +0200

Seen: 740 times

Last updated: Feb 12 '14