[bug] Double low battery notification

asked 2015-09-07 11:15:47 +0300

nthn gravatar image

updated 2015-09-07 17:28:05 +0300

When my battery hits 10%, I get a low battery notification, but immediately afterwards I get another one (even though it's still at 10%) (and then another one for power saving mode turning on, but that's expected). Anyone know how to solve this?

edit retag flag offensive close delete

Comments

2

I noticed the same.

ejjoman ( 2015-09-07 11:32:10 +0300 )edit
1

Oh, I thought I just messed with some system file. Maybe it's actually a bug, then.

nthn ( 2015-09-07 13:18:44 +0300 )edit

I also have seen this behaviour always thought it is because of 10% and then 9% but last time I checked it happened so fast there was no time for the percentage to go lower. So I also think this might be a "bug".

PatsJolla ( 2015-09-07 15:05:41 +0300 )edit

The charge status of the battery can only be estimated by the phone based on the voltage. but this is not completely accurate: the voltage varies based on the load. So it's perfectly possible that the 10% threshold is crossed twice within short time. Example: the voltage goes below threshhold, your get the notification, power saving mode kicks in which reduces load on battery, voltage increases (just enough to go over the 10% threshhold) and shortly after that decreases to said threshhold again, triggering the second notification.

Only way to reduce this effect i can think of would be to increase the hysteresis for switching threshhold.

casanunda ( 2015-09-08 11:42:19 +0300 )edit

I have noticed this too, but it doesn't bother me.

MJolla ( 2015-09-08 13:30:03 +0300 )edit