Ask / Submit

[bug] sailfishOS 2.0 mounts SD-Card too late for Android Support! [released]

asked 2015-09-07 12:02:09 +0300

jolladiho gravatar image

updated 2015-11-02 11:36:52 +0300

jovirkku gravatar image

I did a very early install of 1.1.9-28 and recognised, that Android Support starts before the SD-Card is mounted. Symptom: the SD is not chrooted to the /opt/android folder and not visible for Android Support.

I have to stop Android Support and start it again after reboot and every thing is ok.

after reboot (Android Support running)
/dev/mmcblk1p1 on /media/sdcard/1234-ABCD type vfat ...

after Android Support restart
/dev/mmcblk1p1 on /media/sdcard/1234-ABCD type vfat ...
/dev/mmcblk1p1 on /opt/alien/media/sdcard/1234-ABCD type vfat ...

I know it's not out and the answer ist not "the update is not official" and it is still no bug. But it is a question. ;-)

edit 150909: Ok, 1.1.9-28 early access is out: now it is a bug.

edit 150914: a restart of the "aliendalvik.service" does not work. You have to stop the service and than start it again. But wait about 1 minute after entering your lock/PIN code, the mount of the sd card comes very late.

edit retag flag offensive reopen delete

The question has been closed for the following reason "released in a software update" by jolladiho
close date 2016-03-24 22:26:39.020114



I think it should be possible to make the Android service start after the sdcard mounting service has run by modifying its unit file.

Well provided it does not cause a deadlock or some other issues -> use at own risk! :)

MartinK ( 2015-09-07 14:41:01 +0300 )edit

Thanks for the info that a simple restart of Alien Dalvik fixes it! I was about to manually bind-mount the sd card again.

Note: if I try to restart it using the "Restart Alien Dalvik" from Sailfish Utilities, it doesn't work. I have to stop it completely and start it again. Does somebody know why?

Sthocs ( 2015-09-14 11:41:20 +0300 )edit

@Sthocs the option "Restart Alien Dalvik" is not available in the Utilities since 1.1.9 update for me. I just tried to test it, but I do not have this option. May be you were to quick, the mount for the sd-card comes very late. You have to wait about 1 minute after entering your lock and/or PIN code.

But I can confirm, that a

devel-su systemctl restart aliendalvik.service

does not work too. But a

devel-su systemctl stop aliendalvik.service; sleep 5; devel-su systemctl start aliendalvik.service

did it.

A nice tool for handling it is from coderus. You can use "Add to favorites" in Settings and have it on the settings start page.

jolladiho ( 2015-09-14 16:58:52 +0300 )edit

@MartinK I think you are right, it should be possible to solve it.

jolladiho ( 2015-09-14 17:14:09 +0300 )edit

@jolladiho, in there is already an Android settings under settings > system > android support, with buttons to stop and start dalvik, no need for extra app anymore.

r0kk3rz ( 2015-09-14 17:15:52 +0300 )edit

1 Answer

Sort by » oldest newest most voted

answered 2016-03-23 15:21:36 +0300

Asmodeus gravatar image

updated 2016-03-23 15:39:16 +0300

[release notes]ärvi [Early Access] Android Support:

  • Fixed an issue where Android applications (such as file managers) could not access path /media/sdcard

I tested for this fix with Jolla Tablet and OS version Taalojärvi and indeed the "behaviour" has been fixed. Now you can access external SDCard within Android app(s) without any gimmicks and user-made patents.

Be sure to test the fix that it also works with Jolla phone either opting for Early access or waiting for the official release of Taalojärvi.

Also: no need for shutting down and restarting Android support between OS restarts anymore.

edit flag offensive delete publish link more



Also: no need for shutting down and restarting Android support between OS restarts anymore.

This is precisely what this fix is about ;)

Sthocs ( 2016-03-23 17:05:44 +0300 )edit

ok, I can confirm, that the sdcard is mounted in a way, it is accessible from Android without restarting alien dalvik. But you still should not try to access the sdcard in the first minutes (on Jollaphone) right after a startup/reboot, because its mounted many seconds later than the alien dalvik service is started (if you have enabled starting alien dalvik automaticaly at startup).

You can check it by yourself, if you open a ssh connection right after reboot and type "mount" and press enter. Wait 2 minutes execute mount again and compare the output. The sdcard mountpoint is missing in the first list.

but the bug is fixed. I can close this ticket.

jolladiho ( 2016-03-24 22:24:20 +0300 )edit

Question tools



Asked: 2015-09-07 12:02:09 +0300

Seen: 1,285 times

Last updated: Mar 23 '16