Ask / Submit

[Bug] no mkv with h264?

asked 2015-09-09 23:11:08 +0200

cy8aer gravatar image

I tried to play a mkv with h264/faac which worked with SFOS1. Are there codecs/container-stuff missing with SFOS2/gstreamer1.0?

edit retag flag offensive close delete

2 Answers

Sort by » oldest newest most voted

answered 2015-09-09 23:43:10 +0200

vasavr gravatar image

H.264 video and AAC audio in a MKV work fine for me.

But I cant play AC3 audio anymore as this decoder doesnt seem to work with 1.1.9. Cannot play stream of type: <unknown></unknown>

edit flag offensive delete publish link more

answered 2015-09-10 04:55:12 +0200

MSameer gravatar image

Do you have a link to the non-working video?

edit flag offensive delete publish link more



ahem no. You need to render something by your own, sorry. Created with Debian testing's handbrake-cli and following settings:

HandBrakeCLI -i infile.somevideotype -o outfile.mkv -q 20 -e x264 --preset "veryslow" --x264-tune "film" --loose-anamorphic -a 1,... -B 256,... -E faac,... -6 5point1,... -m -s 1,...

,... are additional audio tracks or subtitles (-s). For me infile is an SD video. And my file has two audio tracks (ouch this information is missing in the question. very sorry). There is another problem of course, with the old SFOS versions you got the second audio track played - the movie player has no option for selecting the track (bug? missing feature? not really needed? So not mentioned in TJC yet)

cy8aer ( 2015-09-10 08:43:54 +0200 )edit

... problem still there with - but do not be afraid: I expected that this is low prio.

cy8aer ( 2015-10-27 11:16:00 +0200 )edit

Of course it has not been fixed because I don't have a video that reproduces it ;-)

MSameer ( 2015-10-27 14:27:27 +0200 )edit
Login/Signup to Answer

Question tools



Asked: 2015-09-09 23:11:08 +0200

Seen: 300 times

Last updated: Sep 10 '15