Ask / Submit
8

[bug][1.1.9.28] tracker-miner-fs stuck in a loop

asked 2015-09-11 11:54:48 +0200

MartinK gravatar image

The tracker-miner-fs appears to be stuck in a loop:

  • has been running for hours
  • consumes 50% of system RAM
  • has high CPU usage
  • the device is quite hot and the UI is unresponsive
  • journal is flooded of:

    Sep 11 10:30:40 Jolla tracker-miner-fs[1361]: GLIB CRITICAL ** Tracker - Could not execute sparql: GDBus.Error:org.freedesktop.Tracker1.SparqlError.Internal: UNIQUE constraint failed: nie:DataObject.nie:url (strerror of errno (not necessarily related): Resource temporarily unavailable)

So it kinda looks like its database died or is otherwise unavailable but it still tries to connect to it again and again.

edit retag flag offensive close delete

Comments

Was about to file a report here, because I'm hit by this, too. Reboot doesn't help, killing tacker doesn't help. After 3 hours uptime the battery is only 54%.

Btw, it only started today or yesterday evening, before it all worked normally. Yesterday evening I started to let FlowPlayer index files and download covers. Possible connection of these two?

This is a real showstopper, as I can't take my Jolla with me for more than a half day :(

dalas.revo ( 2015-09-11 12:09:31 +0200 )edit

@dalas.revo: Reboot seems to have worked in my case, at least a bit - tracker is still running after reboot, still consumes 100% CPU (50% miner, 50% store) but does not use all the memory as before and does not flood the log with the Resource temporarily unavailable messages. But it could be that it will only get stuck later.

MartinK ( 2015-09-11 13:11:35 +0200 )edit

Do you also have FlowPlayer? Does it interfere with tracker in any way?

dalas.revo ( 2015-09-11 13:14:10 +0200 )edit

@dalas.revo: I also have it but I don't think I have started it recently ad it IIRC does not have any daemon component.

As for whats happening now:

  • I have disconnected my Jolla from the USB cable and went out
  • the device is usable and has not run out of battery power after a few hours outside
  • still when I run top I can still see the tracker-miner-fs consuming 50% of CPU time and tracker-store consuming also 50%! (we have two cores so that should mean tracker is maxing on of them to 100%)
  • thankfully they together consume just ~4% of RAM, not the ~50% as during the loop before

Still, this is something I would expect to happen on AC power, not when running from battery. I think the only reason my Jolla has not run out of battery due to maxed-out CPU just yet is the hard suspend Jolla does when the screen is off. Otherwise I'm pretty sure the battery would be empty. I would kinda think tracker would be more constrained for on-battery operation.

Another think I have noticed - tracker-miner-fs has a nice of 19 while tracker-store has the default value (0). This is kinda weird as due to the similarly high memory usage they appear to be basically feeding each other, so different nice value looks weird.

MartinK ( 2015-09-12 01:41:05 +0200 )edit

Sorry for not answering for so long, had visitors over the weekend. I didn't think about a daemon but more about a corrupted database, but I do know too little about the way tracker works. Anyway, what I am experiencing now is this: My device is nearly unusable, because

  • battery drains very fast, lasts only for half a day
  • top/Lighthouse show 100% usage of CPU, top 40...50% for each tracker-store and tracker-miner
  • 40...45% memory used by tracker-store
  • after night (on charger): absolutely unusable, as every app closes right away (OOM-killer?). no possibility to check via terminal nor via top (had no opportunity to connect via ssh)

If till this evening no one from Jolla steps in and helps or I don't find any other way to stop this, I have to reset my device :( I need it and can't charge it every 5 hours.

dalas.revo ( 2015-09-14 10:22:22 +0200 )edit

1 Answer

Sort by » oldest newest most voted
2

answered 2016-08-04 23:46:55 +0200

blublub gravatar image

updated 2016-08-06 14:34:16 +0200

I got the same problem on my Jolla-C with version 2.0.2.43 (I have not realy installed anything and the filesystem should be more or less empty (Edit: not empty enough it seems ;))...)

A workaround seems to be to pause the tracker-miner-fs process with tracker-control:

tracker-control --miner=org.freedesktop.Tracker1.Miner.Files --pause="kaputt"

Edit:

I searched some more for the cause of this hangs. To do this I traced the tracker-miner-fs process with strace:

strace -p $PID

And there was a file that caused a lot of errors so I deleted it and restartet tracker (this will cause it to delete all it's databases and rescan everything):

tracker-control -r

(In my case it did not seem to like the META-INF/com/android/otacert file I extacted while installing the google apps...)

edit flag offensive delete publish link more
Login/Signup to Answer

Question tools

Follow
3 followers

Stats

Asked: 2015-09-11 11:54:48 +0200

Seen: 1,577 times

Last updated: Aug 06 '16