Ask / Submit
13

Bug: E-mail account password update [released]

asked 2014-01-06 00:36:42 +0300

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

updated 2014-01-21 21:43:36 +0300

Kari gravatar image

Our MS Exchange server is configured to logon using Windows logon and thus changing the Windows password I need to update the Mail account password in the Exchange client on Jolla as well when it happens.

I just realized that since the Windows password update on Friday I haven't received any e-mail from our Exchange server due to the password update.

  1. Should Jolla Exchange client inform automatically that password is not valid and request user to enter new valid password?

I have now tried to get the account working and despite my many attempts to change the password in Server settings via pulley menu, the new password doesn't seem to work.

  1. Has anybody else noticed that change of password on mail client would have similar issue than I have?

  2. What I can do now to get my password changed and accepted by the Exchange client?

EDIT by Veksu

if phone has wrong password, activesync client does not say anything about that, its refresh email like normal but nothing happen.

edit retag flag offensive reopen delete

The question has been closed for the following reason "released in a software update" by VDVsx
close date 2014-06-09 21:11:10.465279

Comments

I had similar experience today - due to company policy had to change domain/Exchange password. I changed to new password in Jolla and noticed that account is not synced for hours. I tried several times,entering carefully new password with no avail. Than suddenly after 7 hours it just synced...

zlatko ( 2014-01-07 18:24:40 +0300 )edit

I also had problems updating the password on my exchange account. I ended up just removing and adding the account again.

Kuus2 ( 2014-01-27 21:36:25 +0300 )edit

3 Answers

Sort by » oldest newest most voted
2

answered 2014-01-06 07:44:44 +0300

Veksu gravatar image

updated 2014-01-06 07:50:19 +0300

You can change your password like this,

settings > accounts > your exchange account - pulldown menu - change server settings (or something like that, my phone language is now finninsh not know sure what there reading.)

there you can modify acoount details.

Actually i test if phone has wrong password, activesync client does not say anything about that, its refresh email like normal but nothing happen.

Only what i get is email update status is not right now. try update there shows updating.. and then come back X minutes ago. usually its says right now.(juuri nyt in finnish)

edit flag offensive delete publish link more

Comments

Thanks @Veksu for the answer, however this is the way I did it already yesterday without luck.

The current problem is that how to get new password activated on existing Activesync client?

Is the actual problem related to the saving of the new password or if the client otherwise fails to process the new password and thus it doesn't become active?

I tried numerous ways such as closing the e-mail app and then updating the password.

I also deactivated the Activesync account before changing the password. and then re-activating it again. Unfortunately none of the ways that I tried worked until now.

Is the only way at the moment to delete the Activesync acount and re-create it?

In Symbian S^3 the Activesync client indicates that password is not correct and provides for user possibility to enter valid password => In my opinion the Jolla's Activesync client should do the same and thus avoid the situation we have now.

As in my case the Windows logon and active sync are using the same authentication I am now waiting to see, if the failed attempts will eventually lock my windows account due to too many failed attempts with wrong password.

Kari ( 2014-01-06 11:56:19 +0300 )edit

I just noticed that my Activesync client had made scheduled refresh and IT HAD WORKED???

Now also manual refresh from cover and directly from mail app client pulley menus are working - Is it just due to "stupid" user or **is Jolla phone handling the passwords with delay or is the scheduled sync/refresh working differently compared to manual sync/refresh?

Any good comments/explanations for this issue?

Kari ( 2014-01-06 14:26:25 +0300 )edit

I try wrong password case, i change password on Jolla and mail didn't sync, of course. 6 huors later i change original password - the right password back to jolla, and seocnds later when i go to email app its sync emails to me. But email app never say wrong password, only shows when update is made, but that its look a like too when no new emails coming in normal use.

Veksu ( 2014-01-06 14:44:37 +0300 )edit
1

answered 2014-02-01 11:16:24 +0300

VDVsx gravatar image

Fixed in 1.0.3.8, Naamankajärvi. You should see the error now in the email UI when password is changed, Please comment here if you still see some problems.

edit flag offensive delete publish link more

Comments

@VDVsx here are some first experiences after the installation of 1.0.3.8 update.

  • Change of password at Exchange client yesterday did not have any affect first I was able to send and receive e-mails normally with incorrect client password.
  • The mail app app cover didn't indicate anything about incorrect password.
  • This morning the app cover indicated about logon problem, but when you have multiple accounts it doesn't indicate what account has the password issue.
  • At mail app combined inbox page there is no indicator that password check would have failed
  • Individual account folder pages i.e. inbox don't also indicate that password check would have failed
  • Changed the password on Exchange client back to correct changed the notification on cover app to synchronization problems, but this is only visible on app cover.
  • Change of client password again incorrect, will keep the synchronization problem notification on app cover.
  • I'll change the client password now back to correct and keep monitoring when the synchronization problem notification is hopefully cleared.

From user point of view the delays when changing the account password on client or server side are not good approach. The change of passwords should be applied immediately without delay.

Hopefully I don't need to delete and re-create the Exchange client to solve the current synchronization problem notification.

Kari ( 2014-02-02 09:14:08 +0300 )edit
3

after fours of waiting no progress, but I finally figure out how to get new client password activated immediately.

  1. disable the active exchange account and save
  2. access server settings from pulley menu and change the password and accept it. Save the settings without activating the Exchange account
  3. re-enter account setting page and re-activate the Exchange account and save.
  4. Try refresh the emails, which should work, if the entered password is correct.

In principle this approach feels at least to me bit complicated and change of password i.e. client or server password should be activated with out disabling the account as dedcribed above.

Kari ( 2014-02-02 14:18:13 +0300 )edit

If the app still syncs fine after password change in the server is because the server allows that, probably password is behind some LDAP that takes time to propagate the changes, nothing can be done about that. Error reporting needs a lot of improvements, our current UI lacks proper enablers :(

VDVsx ( 2014-02-03 09:27:35 +0300 )edit
2

@Kari I was forced to change my password on the exchange server because it expired, and then I also experienced that the Jolla was not able to sync anymore (error description on cover of email-app). After doing as you described (deactivate account, change password, then activate again) it works! So there is definately a bug.

chrila ( 2014-02-04 10:46:39 +0300 )edit

@Kari I had the same problem, but this workaround didn't help in my case. I ended up re-creating account, that worked at the end. Though I'm not sure whether disabling provisioning would have helped, account re-creation didn't not succeed either before it disabled it.

JiiHoo ( 2014-02-06 00:50:44 +0300 )edit
0

answered 2014-06-09 21:08:06 +0300

VDVsx gravatar image

Improved in Sailfish 1.0.7.16, Saapunki, if you still have issues please comment here.

edit flag offensive delete publish link more

Comments

After upgrading, for some reason I wasn't able to change the server settings (trying to open that item from the pulley menu did nothing). I deleted the account and re-added it. Then, I was able to open the server settings normally.

reinouts ( 2014-06-10 12:17:24 +0300 )edit

was the account disabled ? if so those settings are not accessible until you save the acct.

VDVsx ( 2014-06-10 13:17:41 +0300 )edit

No, the account was not disabled.

reinouts ( 2014-06-10 17:15:06 +0300 )edit

My activesync account stopped working after I changed password (for ms AD account which is used by exchange), recreating account on jolla phone fixed issue. phone firmware is saapunki. My guess is that saving new password on jolla/activesync account failed.

juhak ( 2014-07-01 01:18:55 +0300 )edit

I had the problem yesterday with 1.0.8.19. I changed my password to the new exchange password and nothing happened. My solution was to set the password to null tried a resync and set the password to a correct value. Unfortunately I'm not able to reproduce this behaviour due to the situation that I'm only allowed to change the password once in 24h (company rule). Am I the only one who had this problem?

thargor ( 2014-07-17 16:36:27 +0300 )edit

Question tools

Follow
5 followers

Stats

Asked: 2014-01-06 00:36:42 +0300

Seen: 1,152 times

Last updated: Jun 09 '14