Ask / Submit
29

Can't add Microsoft Exchange account since 1.1.9.28 update

asked 2015-09-14 11:35:53 +0200

daywalker gravatar image

updated 2015-09-18 10:50:20 +0200

Hi fellow sailors,

today i noticed that my company email account did not sync for 5 days. 5 days ago i was updating to 1.1.9.28... It worked flawlessly before.

So i tried to re-enter the password -> did not help Tried to disable and re-enable the account -> did not help

i ended up deleting the account and i am now trying to add the account but it doesn't work. It says checking of account data failed (translated from german).

I am online, the account data is 100% right and the mail server is online and reachable. And it worked before the update with the exact same data.

What does

"Credentials check FAILED! error == 5

mean?

We do not have activated any restrictions for mobile devices. I already read some threads where someone has activated PIN or lock device after 8 false attempts nad then it worked. Not applicable here

I am not a pro in analyzing logs but it seems something is not right with "signond" service...

Sep 14 10:03:36 Jolla dbus-daemon[919]: Activating service name='org.nemomobile.calendardataservice'
Sep 14 10:03:36 Jolla dbus-daemon[919]: Successfully activated service 'org.nemomobile.calendardataservice'
Sep 14 10:03:36 Jolla kernel: dbus-daemon(919) send signal 9 to dbus-daemon(8262)
Sep 14 10:03:36 Jolla calendardataservice[8263]: [W] mKCal::SqliteStorage::open:179 - sqlitestorage.cpp: 179 - database "/home/nemo/.local/share/system/privileged/Calendar/mkcal/db" opened 
Sep 14 10:03:37 Jolla estart[1290]: [D] Accounts::Account::Private::account_store_cb:626 - account.cpp: 626 account_store_cb Saved accunt ID: 29 
Sep 14 10:03:37 Jolla estart[1290]: [D] SignOn::ConnectionManager::setupSocketConnection:106 - connection-manager.cpp 106 setupSocketConnection p2p error: QDBusError("org.freedesktop.DBus.Error.FileNotFound", "Failed to connect to socket /run/user/100000/signond/socket: Datei oder Verzeichnis nicht gefunden") 1 
Sep 14 10:03:37 Jolla estart[1290]: [D] SignOn::ConnectionManager::init:132 - connection-manager.cpp 132 init Peer connection unavailable, activating service 
Sep 14 10:03:37 Jolla dbus-daemon[919]: Activating service name='com.google.code.AccountsSSO.SingleSignOn'
Sep 14 10:03:37 Jolla estart[1290]: [D] SignOn::IdentityImpl::updateState:96 - identityimpl.cpp 96 updateState Updating state:  "PendingRegistration" SignOn::IdentityImpl(0x4f059a70) 
Sep 14 10:03:37 Jolla estart[1290]: [D] SignOn::IdentityImpl::storeCredentials:172 - identityimpl.cpp 172 storeCredentials Storing credentials 
Sep 14 10:03:37 Jolla [6153]: signondaemon.cpp 388 init Failed to SUID root. Secure storage will not be available.
Sep 14 10:03:37 Jolla dbus-daemon[919]: Successfully activated service 'com.google.code.AccountsSSO.SingleSignOn'
Sep 14 10:03:37 Jolla estart[1290]: [D] SignOn::ConnectionManager::init:150 - connection-manager.cpp 150 init Connected to "libsignon-qt12" 
Sep 14 10:03:37 Jolla kernel: dbus-daemon(919) send signal 9 to dbus-daemon(8272)
Sep 14 10:03:37 Jolla estart[1290]: [D] SignOn::IdentityImpl::updateState:96 - identityimpl.cpp 96 updateState Updating state:  "Ready" SignOn::IdentityImpl(0x4f059a70) 
Sep 14 10:03:37 Jolla estart[1290]: [D] SignOn::IdentityImpl::updateState:96 - identityimpl.cpp 96 updateState Updating state:  "NeedsUpdate" SignOn::IdentityImpl(0x4f059a70) 
Sep 14 10:03:37 Jolla estart[1290]: [D] SignOn::IdentityImpl::updateState:96 - identityimpl.cpp 96 updateState Updating state:  "PendingUpdate" SignOn::IdentityImpl(0x4f059a70) 
Sep 14 10:03:37 Jolla estart[1290]: [D] SignOn::IdentityImpl::infoUpdated:442 - identityimpl.cpp 442 infoUpdated SERVER INFO UPDATED. NeedsUpdate " 0 " 
Sep 14 10:03:37 Jolla estart[1290]: [D] SignOn::IdentityImpl::storeCredentialsReply:345 - identityimpl.cpp 345 storeCredentialsReply stored id: 32 old id: 0 
Sep 14 10:03:37 Jolla estart[1290]: [D] SignOn::AuthSessionImpl::initInterface:94 - authsessionimpl.cpp 94 initInterface 
Sep 14 10:03:37 Jolla estart[1290]: [D] SignOn::AuthSessionImpl::initInterface:94 - authsessionimpl.cpp 94 initInterface 
Sep 14 10:03:37 Jolla estart[1290]: [D] SignOn::IdentityImpl::getInfoReply:381 - identityimpl.cpp 381 getInfoReply QMap(("ACL", QVariant(QStringList, () ) ) ( "AuthMethods" ,  QVariant(QDBusArgument, ) ) ( "Caption" ,  QVariant(QString, "Jolla") ) ( "Id" ,  QVariant(uint, 32) ) ( "Owner" ,  QVariant(QStringList, () ) ) ( "Realms" ,  QVariant(QStringList, () ) ) ( "RefCount" ,  QVariant(int, 0) ) ( "StoreSecret" ,  QVariant(bool, true) ) ( "Type" ,  QVariant(int, 0) ) ( "UserName" ,  QVariant(QString, "*CLEARED FOR SECURITY*") ) ( "UserNameSecret" ,  QVariant(bool, false) ) ( "Validated" ,  QVariant(bool, false) ) )  
Sep 14 10:03:37 Jolla estart[1290]: [D] SignOn::IdentityImpl::updateState:96 - identityimpl.cpp 96 updateState Updating state:  "Ready" SignOn::IdentityImpl(0x4f059a70) 
Sep 14 10:03:37 Jolla estart[1290]: [D] SignOn::IdentityImpl::updateState:96 - identityimpl.cpp 96 updateState Updating state:  "NeedsUpdate" SignOn::IdentityImpl(0x4f059a70) 
Sep 14 10:03:37 Jolla estart[1290]: [D] SignOn::IdentityImpl::updateState:96 - identityimpl.cpp 96 updateState Updating state:  "PendingUpdate" SignOn::IdentityImpl(0x4f059a70) 
Sep 14 10:03:37 Jolla estart[1290]: [D] SignOn::IdentityImpl::infoUpdated:442 - identityimpl.cpp 442 infoUpdated SERVER INFO UPDATED. NeedsUpdate " 32 " 
Sep 14 10:03:37 Jolla estart[1290]: [D] Accounts::Account::Private::account_store_cb:626 - account.cpp: 626 account_store_cb Saved accunt ID: 29 
Sep 14 10:03:37 Jolla estart[1290]: [D] SignOn::IdentityImpl::getInfoReply:381 - identityimpl.cpp 381 getInfoReply QMap(("ACL", QVariant(QStringList, () ) ) ( "AuthMethods" ,  QVariant(QDBusArgument, ) ) ( "Caption" ,  QVariant(QString, "Jolla") ) ( "Id" ,  QVariant(uint, 32) ) ( "Owner" ,  QVariant(QStringList, () ) ) ( "Realms" ,  QVariant(QStringList, () ) ) ( "RefCount" ,  QVariant(int, 0) ) ( "StoreSecret" ,  QVariant(bool, true) ) ( "Type" ,  QVariant(int, 0) ) ( "UserName" ,  QVariant(QString, "*CLEARED FOR SECURITY*") ) ( "UserNameSecret" ,  QVariant(bool, false) ) ( "Validated" ,  QVariant(bool, true) ) )  
Sep 14 10:03:37 Jolla estart[1290]: [D] SignOn::IdentityImpl::updateState:96 - identityimpl.cpp 96 updateState Updating state:  "Ready" SignOn::IdentityImpl(0x4f059a70) 
Sep 14 10:03:44 Jolla estart[1290]: [D] onCheckCredentialsFailed:234 - [jsa-eas] Credentials check FAILED!
                                     error == 5
Sep 14 10:03:45 Jolla [1205]: [W] {anonymous}::SyncAdapter::syncPrivilegedToNonprivileged:684 - CDExport: exporting changes: 0 17 0 
Sep 14 10:03:46 Jolla estart[1290]: [D] SignOn::IdentityImpl::updateState:96 - identityimpl.cpp 96 updateState Updating state:  "PendingRegistration" SignOn::IdentityImpl(0x4d1237d8) 
Sep 14 10:03:46 Jolla estart[1290]: [D] SignOn::IdentityImpl::signOut:285 - identityimpl.cpp 285 signOut Signing out. 
Sep 14 10:03:46 Jolla estart[1290]: [D] SignOn::IdentityImpl::remove:199 - identityimpl.cpp 199 remove Removing credentials. 
Sep 14 10:03:46 Jolla estart[1290]: [D] Accounts::Account::Private::on_deleted:184 - account.cpp: 184 on_deleted 
Sep 14 10:03:46 Jolla estart[1290]: [D] Accounts::Account::Private::on_deleted:184 - account.cpp: 184 on_deleted 
Sep 14 10:03:46 Jolla estart[1290]: [D] Accounts::Account::Private::on_deleted:184 - account.cpp: 184 on_deleted 
Sep 14 10:03:46 Jolla [968]: [D] Accounts::Account::Private::on_deleted:184 - account.cpp: 184 on_deleted 
Sep 14 10:03:46 Jolla [968]: [W] Buteo::ProfileManagerPrivate::parseFile:1117 - Profile file not found: "/home/nemo/.cache/msyncd/sync/activesync-email.xml" 
Sep 14 10:03:46 Jolla [968]: [W] Buteo::ProfileManagerPrivate::load:152 - Failed to load profile: "activesync-email" 
Sep 14 10:03:46 Jolla [968]: [W] Buteo::ProfileManagerPrivate::parseFile:1117 - Profile file not found: "/home/nemo/.cache/msyncd/sync/.xml" 
Sep 14 10:03:46 Jolla [968]: [W] Buteo::ProfileManagerPrivate::load:152 - Failed to load profile: "" 
Sep 14 10:03:46 Jolla estart[1290]: [D] Accounts::Account::Private::account_store_cb:626 - account.cpp: 626 account_store_cb Saved accunt ID: 29 
Sep 14 10:03:46 Jolla estart[1290]: [D] Accounts::Account::Private::account_store_cb:626 - account.cpp: 626 account_store_cb Saved accunt ID: 30 
Sep 14 10:03:46 Jolla estart[1290]: [D] SignOn::IdentityImpl::updateState:96 - identityimpl.cpp 96 updateState Updating state:  "Ready" SignOn::IdentityImpl(0x4d1237d8) 
Sep 14 10:03:46 Jolla estart[1290]: [D] SignOn::IdentityImpl::infoUpdated:442 - identityimpl.cpp 442 infoUpdated SERVER INFO UPDATED. SignedOut " 32 " 
Sep 14 10:03:46 Jolla estart[1290]: [D] SignOn::IdentityImpl::infoUpdated:442 - identityimpl.cpp 442 infoUpdated SERVER INFO UPDATED. SignedOut " 32 " 
Sep 14 10:03:46 Jolla estart[1290]: [D] SignOn::IdentityImpl::updateState:96 - identityimpl.cpp 96 updateState Updating state:  "Removed" SignOn::IdentityImpl(0x4d1237d8) 
Sep 14 10:03:46 Jolla estart[1290]: [D] SignOn::IdentityImpl::infoUpdated:442 - identityimpl.cpp 442 infoUpdated SERVER INFO UPDATED. Removed " 32 " 
Sep 14 10:03:46 Jolla estart[1290]: [D] SignOn::IdentityImpl::updateState:96 - identityimpl.cpp 96 updateState Updating state:  "Removed" SignOn::IdentityImpl(0x4f059a70) 
Sep 14 10:03:46 Jolla estart[1290]: [D] SignOn::IdentityImpl::infoUpdated:442 - identityimpl.cpp 442 infoUpdated SERVER INFO UPDATED. Removed " 32 " 
Sep 14 10:03:46 Jolla estart[1290]: [D] SignOn::IdentityImpl::updateState:96 - identityimpl.cpp 96 updateState Updating state:  "Removed" SignOn::IdentityImpl(0x4d1237d8) 
Sep 14 10:03:47 Jolla dbus-daemon[919]: invoker: Invoking execution: '/usr/bin/signond'
edit retag flag offensive close delete

Comments

3

Hi I have the same issue and I have reported this to Jolla., also commented here under another related thread. Hopefully we have a fix soon.

shertell ( 2015-09-14 12:28:59 +0200 )edit

Mine stopped syncing the calendar and email syncs only over 3G/4G so I guess it is a related problem :/ Don't know how contacts are syncing yet.

Wizah ( 2015-09-14 23:48:20 +0200 )edit

Thanks for the report.

Is this the error log reported when you attempt to create the new Exchange account, via Settings/Accounts?

Can you give any information about the version of the remote exchange server?

Thanks, Chris.

chris.adams ( 2015-09-18 04:25:25 +0200 )edit

I have the same issue. In my case the exchange server is 2003.

shertell ( 2015-09-18 07:19:09 +0200 )edit

Yes @chris.adams this is the error log created while trying to add an account, which always fails with an alleged credentials problem... we run M$ Exchange Server 2007 on Windows Server 2003 SE (x64) I tried to analyze the logs on the machine but don't know where to start :( i could not find any entrys in the standard logs as if jolla never tried to connect...maybe i have to enable some extended logs but im not that into it..

daywalker ( 2015-09-18 10:02:43 +0200 )edit

5 Answers

Sort by » oldest newest most voted
5

answered 2015-10-12 16:28:12 +0200

rudi10 gravatar image

updated 2015-10-12 16:31:51 +0200

This is an issue with unsecure Exchange Server. You can check your server by trying openssl s_client -connect my-exchange.here.com:443. Try with options -ssl3, tls1, -tls1_1 and tls1_2. If only ssl3 and tls1 work, contact your Exchange admin to urgently. In my opinion only thing Jolla can do is to add an option "use unsecure ssl version" to Exchange account creation UI. SailfishOS 1.1.9.28 updated to openssl 1.0.2d which seems to disable those vulnerable protocol version by default.

edit flag offensive delete publish link more

Comments

So is there a workaround, until the possible "allow unsecure SSL version" configuration UI option is added or the offending exchange servers IIS is updated from it's out-dated defaults?

SlOrbA ( 2015-10-13 10:37:02 +0200 )edit

I also face the problem that I can't create my exchange account on the jolla tablet, whereas the previously created exchange account on my jolla phone on 1.1.9.28 works flawless. I tested the exchange server with the above mentioned "openssl s_client..." command. I'm not familiar with the whole ssl-thing, but according to the result of this command, the exchange server which I use supports ssl1.2. Still I can't create a new account...So maybe there are other problems as well?

nelbrog ( 2015-10-13 11:44:26 +0200 )edit

@SlOrbA The correct fix would be allowing the secure protocols to be used on the Exchange servers.

@rudi10 Only SSLv3 is not allowed anymore by default with 1.1.9, the TLSv1 and better should still work (with a correct ciphersuite).

@nelbrog Sure there can be other issues not related to the SSL-protocol selection.

tigeli ( 2015-10-13 11:55:21 +0200 )edit

@nelbrog: the Jolla Tablet uses a new (rewritten) Exchange Active Sync stack. If you have issues with exchange on tablet, please provide any information you can (including logs etc) to me, via email if possible: chris dot adams at jolla dot com and I will investigate.

To get logs, if you have developer mode enabled, you can run the settings app from an ssh terminal via devel-su -p jolla-settings when you create an exchange account. Also, logs from the journal could be useful. There is a config file under /home/nemo/.config/ related to Sailfish Exchange ActiveSync which allows more logging output to be produced (enabling different logging categories). After modifying it, will need to reboot device. Also, /etc/systemd/journald.conf needs RateLimitBurst=5000 and RateLimitInterval=10s and again, reboot device if you needed to change it. Then, you can ssh back into the device, do devel-su journalctl -af to collect logs while trying to create the Exchange account. Again, redact any personal information and then email those to chris dot adams at jolla dot com and I will investigate.

Thanks, Chris.

chris.adams ( 2015-10-13 14:33:18 +0200 )edit

Our server supports TLS 1.0 and it doesn't work. However i just talked back to my colleagues and good news :D They are in the process of migrating our Exchange Server so TLS 1.2 will be supported in 3-4 weeks.

You can scan your server here: https://www.ssllabs.com/ssltest/index.html

daywalker ( 2015-10-14 10:00:57 +0200 )edit
2

answered 2015-10-01 14:21:54 +0200

SlOrbA gravatar image

Like some other comentators I'm having this issue and I'm looking for solution.

edit flag offensive delete publish link more

Comments

1

As far as I know, at the moment there is no solution for this. I have been in contact with Jolla Care about this and they told me that they are investigating. I reported this to Jolla care on the same day the pre-release was published so they had time to investigate it before they published 1.1.9.28. But no fix was released. When I asked about it, they said that there are only few that are having this issue so they decided to publish even they had no fix for this. Unfortunately to me it sounds that the priority for this is quite low because it's a problem for only few. This could mean that we have to wait longer than we would expect. In my csse this issue is the reason I had to change to a another phone since I need my work calendar every day.

I suggest that everyone who is experiencing this issue would contact Jolla Care just to make sure this would not get buried under all the other issues. We need to get the priority up for this. Otherwise it is possible that the wait will be long.

shertell ( 2015-10-01 15:23:34 +0200 )edit

@chris.adams Is there any progerss regarding this issue? Anything at all?

shertell ( 2015-10-07 11:32:36 +0200 )edit

Very little progress, unfortunately, as I have been unable to personally reproduce this issue with either of the two exchange servers I have access to, and then I was sick for more than a week so progress stalled.

Our sailors in Care asked several people who raised this ticket which version of Exchange server they were running, and results are inconsistent (some are using Exchange 2003, others with newer versions with newer protocol versions, and so on). Clearly this issue only affects some particular subset of Exchange servers, and probably due to some protocol version requirement which we broke in 1.1.9.28, but at this point we haven't figured out what.

To that end, currently, one other developer and I are looking carefully at the delta between 1.1.7.26 and 1.1.9.28 to try to figure out what might have caused the problem.

Can you please do the following:

 devel-su -p pkcon get-details qmf-eas-plugin

I expect the version to be 0.0.14 in 1.1.9.28 and to be 0.0.6 in 1.1.7.28. We have inspected the commits in between those versions, but haven't been able to find anything obviously wrong, yet.

chris.adams ( 2015-10-08 05:48:52 +0200 )edit

@chris.adams thanks for the status update on this issue. I ran the command above and it outputed the following: Command failed: This tool could not find all the packages: could not find qmf-eas-plugin I guess not the result we were waiting for? Any advice?

shertell ( 2015-10-08 08:20:07 +0200 )edit

same for me... (german)

Enjoy your privileges.
Ausführung des Befehls fehlgeschlagen: Dieses Werkzeug konnte nicht alle Pakete finden: could not find qmf-eas-plugin

looks like the package is not available in the repos

[nemo@Jolla ~]$ pkcon search name qmf
Suche nach Name
Warten in Warteschlange

Starten
Software-Liste wird aktualisiert
Abfragen
Installiert libqmfclient1-qt5-4.0.4+git57-1.21.5.armv7hl Qt Messaging Framework (QMF) client library
Verfügbar libqmfclient1-qt5-debuginfo-4.0.4+git57-1.21.5.armv7hl Debug information for package libqmfclient1-qt5
Installiert libqmfmessageserver1-qt5-4.0.4+git57-1.21.5.armv7hl Qt Messaging Framework (QMF) message server support library
Verfügbar libqmfmessageserver1-qt5-debuginfo-4.0.4+git57-1.21.5.armv7hl Debug information for package libqmfmessageserver1-qt5
Installiert qmf-activesync-plugin-0.1.59-10.27.32.jolla.armv7hl ActiveSync plugin for QMF
Verfügbar qmf-activesync-plugin-all-translations-0.0.2-10.1.286.jolla.noarch Metapackage for all qmf-activesync-plugin translations
Installiert qmf-activesync-plugin-all-translations-pack-0.0.2-10.1.286.jolla.noarch Collection of all qmf-activesync-plugin translations in one binary rpm
Installiert qmf-notifications-plugin-0.1.6-10.21.1.jolla.armv7hl Notifications plugin for Qt Messaging Framework (QMF)
Verfügbar qmf-notifications-plugin-all-translations-0.0.1-10.1.7.jolla.noarch Metapackage for all qmf-notifications-plugin translations
Installiert qmf-notifications-plugin-all-translations-pack-0.0.1-10.1.7.jolla.noarch Collection of all qmf-notifications-plugin translations in one binary rpm
Verfügbar qmf-notifications-plugin-debuginfo-0.1.6-10.21.1.jolla.armv7hlDebug information for package qmf-notifications-plugin
Verfügbar qmf-notifications-plugin-debugsource-0.1.6-10.21.1.jolla.armv7hl Debug sources for package qmf-notifications-plugin
Verfügbar qmf-notifications-plugin-ts-devel-0.1.6-10.21.1.jolla.armv7hl Translation source for qmf-notifications-plugin
Installiert qmf-oauth2-plugin-0.0.8-10.5.3.jolla.armv7hl OAuth2 plugin for QMF
Verfügbar qmf-qt5-4.0.4+git57-1.21.5.source Qt Messaging Framework (QMF) Qt5
Verfügbar qmf-qt5-debugsource-4.0.4+git57-1.21.5.armv7hl Debug sources for package qmf-qt5
Verfügbar qmf-qt5-devel-4.0.4+git57-1.21.5.armv7hl Qt Messaging Framework (QMF) Qt5 - development files
Verfügbar qmf-qt5-doc-4.0.4+git57-1.21.5.noarch Qt Messaging Framework (QMF) - documentation
Verfügbar qmf-qt5-tests-4.0.4+git57-1.21.5.armv7hl Qt Messaging Framework (QMF) tests
Verfügbar qmf-qt5-tests-debuginfo-4.0.4+git57-1.21.5.armv7hl Debug information for package qmf-qt5-tests

daywalker ( 2015-10-08 09:38:39 +0200 )edit
2

answered 2015-10-12 17:10:26 +0200

Jonas gravatar image

I also have the same problem on my Jolla Tablet. My "old" account still works on the ph one, but with same settings on the tablet nothing happens.

edit flag offensive delete publish link more
1

answered 2016-02-22 17:36:57 +0200

Nirkus gravatar image

updated 2016-02-23 15:02:17 +0200

Hey,

have the same error #5 with a specific Exchange server on my Jolla phone. :-/

Sailfish OS 2.0.1.7

Trying to add the Exchange account using

devel-su -p jolla-settings
:

[..]
[D] Accounts::Account::Private::account_store_cb:626 - account.cpp: 626 account_store_cb Saved accunt ID: 34 
[D] SignOn::ConnectionManager::setupSocketConnection:106 - connection-manager.cpp 106 setupSocketConnection p2p error: QDBusError("org.freedesktop.DBus.Error.FileNotFound", "Failed to connect to socket /run/user/100000/signond/socket: No such file or directory") 1 
[D] SignOn::ConnectionManager::init:132 - connection-manager.cpp 132 init Peer connection unavailable, activating service 
[D] SignOn::IdentityImpl::updateState:96 - identityimpl.cpp 96 updateState Updating state:  "PendingRegistration" SignOn::IdentityImpl(0x46dda5a0) 
[D] SignOn::IdentityImpl::storeCredentials:172 - identityimpl.cpp 172 storeCredentials Storing credentials 
[D] SignOn::ConnectionManager::init:150 - connection-manager.cpp 150 init Connected to "libsignon-qt1" 
[D] SignOn::IdentityImpl::updateState:96 - identityimpl.cpp 96 updateState Updating state:  "Ready" SignOn::IdentityImpl(0x46dda5a0) 
[D] SignOn::IdentityImpl::updateState:96 - identityimpl.cpp 96 updateState Updating state:  "NeedsUpdate" SignOn::IdentityImpl(0x46dda5a0) 
[D] SignOn::IdentityImpl::updateState:96 - identityimpl.cpp 96 updateState Updating state:  "PendingUpdate" SignOn::IdentityImpl(0x46dda5a0) 
[D] SignOn::IdentityImpl::infoUpdated:442 - identityimpl.cpp 442 infoUpdated SERVER INFO UPDATED. NeedsUpdate " 0 " 
[D] SignOn::IdentityImpl::storeCredentialsReply:345 - identityimpl.cpp 345 storeCredentialsReply stored id: 26 old id: 0 
[D] SignOn::AuthSessionImpl::initInterface:94 - authsessionimpl.cpp 94 initInterface 
[D] SignOn::AuthSessionImpl::initInterface:94 - authsessionimpl.cpp 94 initInterface 
[D] SignOn::IdentityImpl::getInfoReply:381 - identityimpl.cpp 381 getInfoReply QMap(("ACL", QVariant(QStringList, () ) ) ( "AuthMethods" ,  QVariant(QDBusArgument, ) ) ( "Caption" ,  QVariant(QString, "Jolla") ) ( "Id" ,  QVariant(uint, 26) ) ( "Owner" ,  QVariant(QStringList, () ) ) ( "Realms" ,  QVariant(QStringList, () ) ) ( "RefCount" ,  QVariant(int, 0) ) ( "StoreSecret" ,  QVariant(bool, true) ) ( "Type" ,  QVariant(int, 0) ) ( "UserName" ,  QVariant(QString, "l*****@*****") ) ( "UserNameSecret" ,  QVariant(bool, false) ) ( "Validated" ,  QVariant(bool, false) ) )  
[D] SignOn::IdentityImpl::updateState:96 - identityimpl.cpp 96 updateState Updating state:  "Ready" SignOn::IdentityImpl(0x46dda5a0) 
[D] SignOn::IdentityImpl::updateState:96 - identityimpl.cpp 96 updateState Updating state:  "NeedsUpdate" SignOn::IdentityImpl(0x46dda5a0) 
[D] SignOn::IdentityImpl::updateState:96 - identityimpl.cpp 96 updateState Updating state:  "PendingUpdate" SignOn::IdentityImpl(0x46dda5a0) 
[D] SignOn::IdentityImpl::infoUpdated:442 - identityimpl.cpp 442 infoUpdated SERVER INFO UPDATED. NeedsUpdate " 26 " 
[D] Accounts::Account::Private::account_store_cb:626 - account.cpp: 626 account_store_cb Saved accunt ID: 34 
[D] SignOn::IdentityImpl::getInfoReply:381 - identityimpl.cpp 381 getInfoReply QMap(("ACL", QVariant(QStringList, () ) ) ( "AuthMethods" ,  QVariant(QDBusArgument, ) ) ( "Caption" ,  QVariant(QString, "Jolla") ) ( "Id" ,  QVariant(uint, 26) ) ( "Owner" ,  QVariant(QStringList, () ) ) ( "Realms" ,  QVariant(QStringList, () ) ) ( "RefCount" ,  QVariant(int, 0) ) ( "StoreSecret" ,  QVariant(bool, true) ) ( "Type" ,  QVariant(int, 0) ) ( "UserName" ,  QVariant(QString, "l*****@*****") ) ( "UserNameSecret" ,  QVariant(bool, false) ) ( "Validated" ,  QVariant(bool, true) ) )  
[D] SignOn::IdentityImpl::updateState:96 - identityimpl.cpp 96 updateState Updating state:  "Ready" SignOn::IdentityImpl(0x46dda5a0) 
[D] onCheckCredentialsFailed:234 - [jsa-eas] Credentials check FAILED!
 error == 5

Activated logging in

~/.config/Nokia/activesync.conf
, but trying to add that account does not produce any activesync logging.

Ah, and btw ... meh!:

root@Jolla nemo]# find / \( -iname openssl -o -iname gnutls-cli -o -iname telnet -o -iname nc -o -iname strace \) -a \( -type f -o -type l \)
find: /proc/*****: No such file or directory
[root@Jolla nemo]#

Opening Exchange OWA running on the same server (address and port) in the Sailfish browser works (HTTPS and authentication).

How can we debug this and could we have some context on:

[D] onCheckCredentialsFailed:234 - [jsa-eas] Credentials check FAILED!
 error == 5

Output when successfully configuring an Exchange account:

[..]
[D] SignOn::IdentityImpl::updateState:96 - identityimpl.cpp 96 updateState Updating state:  "Ready" SignOn::IdentityImpl(0x49ada858) 
[D] onCheckCredentialsDone:227 - [jsa-eas] Credentials OK!
[W] unknown:38 - file:///usr/lib/qt5/qml/Sailfish/Silica/private/Util.js:38: TypeError: Cannot read property 'parent' of null
[..]

Update on 2016-02-23:

  • The Exchange 2010 account is working with my Jolla phone.
  • The Exchange 2016 account is not working with my Jolla phone.

Besides the Exchange release, these are obvious differences:

  • Exchange 2016 DNS record has A & AAAA records (phone has working IPv6 connectivity)
  • Both exchanges use different certificates and chains
  • Minor TLS/HTTPS session differences for OpenSSL 1.0.2 according to ssllabs:
# Exchange 2010
TLS 1.2, TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384, ECDH secp256r1, session caching & tickets
# Exchange 2016
TLS 1.2, TLS_ECDHE_RSA_WITH_AES_128_GCM_SHA256, ECDH secp256r1, session caching, HSTS

Gruß, Linus

edit flag offensive delete publish link more

Comments

My understanding is that this error will be hit if the server only supports SSLv3 (and not later TLS protocols) OR if the exchange server is running on Windows Server 2003 (which doesn't handle more than the first 64 ciphers reported by the client).

The second issue should be fixable in our activesync plugin, however the "old" plugin is not under development any more. We need to transition existing Jolla devices over to the "new" activesync plugin, which may (should) already resolve this issue. Unfortunately, due to resource constraints, I can't give a solid ETA for this task.

chris.adams ( 2016-02-23 09:02:08 +0200 )edit

have apparently the same problem, using the 'new' plugin on the tablet (the old plugin on the phone continue to sync on the same server , but I was not brave enough to try to delete and re create the Exchange account)

The Exchange server is using TLS 1.0 (as per nmap -p 443 --script ssl-enum-ciphers) Exchange server appears to be 2007 (as per OWA)

Let us know if we can help testing ...

mm7540 ( 2016-02-23 12:54:02 +0200 )edit

Well, I think we need to debug this - finding the actual issue by testing different server configurations will take forever.

I updates my "answer" with some details on those two Exchange services.

IMHO, we need to know the meaning of that error:

[D] onCheckCredentialsFailed:234 - [jsa-eas] Credentials check FAILED!
 error == 5

As SailfishOs seems to sail without the most basic debugging tools aboard, how about:

  • the source code of jolla-settings and or the codebase checking credentials?
  • debuging options for jolla-settings, the credentials/ signon codebase, used libraries?
  • ... other information to find the actual cause / context of the error?
Nirkus ( 2016-02-23 14:57:08 +0200 )edit

@daywalker - thank you for the pointer!

@chris.adams: does this still apply to SailfishOS 2.0.1.7?

Is the SailfishOS ActiveSync protocol handshake up to that point (error) hard to reconstruct with a little scripting or code?

Nirkus ( 2016-02-23 15:54:26 +0200 )edit
0

answered 2015-10-02 10:30:13 +0200

tvicol gravatar image

This worked for me: Go to Settings -> Device lock and change "Automatic locking" to 5 minutes. Than change number of tries to 5. Security code must have at least 6 numbers.

edit flag offensive delete publish link more

Comments

didn't work for me though. we don't have any server side restrictions...

daywalker ( 2015-10-02 10:43:17 +0200 )edit

Didn't work for me either. Last update from today from Jolla Care is that their devs have nothing new regarding this. This sucks big time.

shertell ( 2015-10-02 11:27:42 +0200 )edit
1

My (existing) account continues to work in 1.1.9.28 - so it seems to only affect new set ups, or?

zappAtom ( 2015-10-02 15:03:27 +0200 )edit
1

please read my initial post. my account stopped syncing after update. and adding a new account doesn't work since then.

daywalker ( 2015-10-02 15:10:56 +0200 )edit

Ok, I just made some checks and for me synching with my existing account still works! Also with the new update! There are some remarks & bugs I still have for activeSync (see this thread: https://together.jolla.com/question/106656/active-sync-status-in-11728/?comment=112522#comment-112522)

zappAtom ( 2015-10-02 16:22:20 +0200 )edit
Login/Signup to Answer

Question tools

Follow
14 followers

Stats

Asked: 2015-09-14 11:35:53 +0200

Seen: 2,178 times

Last updated: Feb 23 '16