Ask / Submit
17

Most audio files: title missing, file name shown instead [released]

asked 2014-01-06 14:36:33 +0300

ossi1967 gravatar image

updated 2014-07-24 10:48:37 +0300

jiit gravatar image

For most of my audio files (MP3 and OGG alike), the Media Player does not show the title, although it's there in the file's metadata. Instead, I see the file name. Album, artist and cover art seem to be retrieved correctly for all files as far as I can tell. (I'm not 100% sure about cover art, as most of my audio files lack that so I wouldn't notice it missing...)

It's even more strange as the behaviour isn't even consistent with files that were ripped from one CD at the same time with the same application on my PC.

Any ideas?

edit retag flag offensive reopen delete

The question has been closed for the following reason "released in a software update" by ossi1967
close date 2014-09-02 15:05:44.558972

Comments

1

I have no idea but the same problem. On other devices everything is working correctly with the same files.

Zandi ( 2014-01-06 20:30:52 +0300 )edit

@Zandi: I too checked the files where the title doesn't show on other devices - everything's fine. Strange. Does anyone know where the music player reads this info from? Is it cached somewhere (tracker?) and maybe corrupted there?

ossi1967 ( 2014-01-06 21:07:48 +0300 )edit
1

GStreamer extracts the corrrect title tag. (gst-launch-0.10 -t filesrc location=/home/nemo/Music/Trackshittaz/Guuugarutz.mp3 ! id3demux ! fakesink) Tracker's got it all wrong. The "'http://purl.org/dc/elements/1.1/title'" property is 'Guuugarutz.mp3' instead of 'Guuugarutz' (tracker-info filename)

ossi1967 ( 2014-01-06 21:19:31 +0300 )edit

What format are the tags in? For ID3 there's at least 5 different variants in use. Maybe tracker doesn't support them all.

pycage ( 2014-01-07 22:51:17 +0300 )edit

@pycage: The MP3 file are ID3 version 2.3.0, according to the file command. I have yet to find an MP3 that work. Most of my music is ogg vorbis. With ogg vorbis, few files work, most don't. As I said, even those I ripped from 1 CD in 1 batch behave differently.

ossi1967 ( 2014-01-08 21:44:34 +0300 )edit

2 Answers

Sort by » oldest newest most voted
4

answered 2014-02-19 18:07:04 +0300

xhaakon gravatar image

The problem should be resolved in buteo-mtp 0.3.0. You can expect to receive the fix in some of the upcoming Sailfish OS updates.

edit flag offensive delete publish link more

Comments

1

It's 2016 and I still experience the same bug on 2.0.2.48 (Aurajoki). Is it a regression?

Cigydd ( 2016-08-26 08:43:13 +0300 )edit
0

answered 2014-01-19 23:39:29 +0300

Milo gravatar image

Sometimes when transferring files over MTP, the Tracker seems to not bother indexing the files properly, which leads to files being shown by their filename, rather than tag files. I haven't been able to produce this behaviour when transfering files over ssh (using scp).

I figured out two ways of forcing the tracker to re-index files already on the filesystem. First one is to manually move the files from ~/Music to somewhere else, and then back to ~/Music. (If you are doing this over MTP, consider doing it in smaller batches).

The second one requires accessing command line and running the command: tracker-sd-indexing.sh which internally executes this: systemctl --user restart tracker-miner-fs.service, but it also makes sure that the tracker looks for SD-card, if you have one attached.

And you can verify the results by running: tracker-search -m which should list all of your music files, if they are tracked by the tracker.

edit flag offensive delete publish link more

Comments

Running tracker-sd-indexing.sh didn't work for me but moving the files around did. I actually moved the files to a temporary location, ran tracker-sd-indexing.sh and moved the files back.

Files were originally transferred to the phone from Gnome using mtp so I assume that issue mentioned in xhaakons answer was the reason titles weren't extracted correctly.

hetas ( 2014-02-19 19:51:11 +0300 )edit

I couldn't find the tracker-sd-indexing.sh script on my device. Maybe it was removed since then. The command tracker-control -r (reset) should do the same. For me, it doesn't work. Moving the files to /tmp, running tracker-control -r, and moving the files back, with another tracker-control -r, also doesn't work. My tracker is choosy about what to index.

Cigydd ( 2016-08-26 09:16:50 +0300 )edit

Just for the record: tracker-control -r is now tracker reset -r, then restart with tracker daemon -s and look for music files with tracker search -m.

marsch ( 2017-11-22 22:34:52 +0300 )edit

Question tools

Follow
7 followers

Stats

Asked: 2014-01-06 14:36:33 +0300

Seen: 1,066 times

Last updated: Feb 19 '14