Ask / Submit
0

lpm screen doesn't work when charging

asked 2015-09-21 23:44:29 +0200

Mohjive gravatar image

When I charge my phone the "wave over phone to show time" doesn't work. The phone does not wake up to show the glance screen. It does work if I pull out the charger cable.

edit retag flag offensive close delete

1 Answer

Sort by » oldest newest most voted
2

answered 2015-09-22 10:42:14 +0200

spiiroin gravatar image

Weird. Whether the device is charging or not should play no role in lpm triggering. Are you sure you've actually enabled the "hover-over" triggering?

You should get

mcetool | grep -e 'low power' -e LPM
Use low power mode:                  enabled
LPM UI triggering:                   from-pocket,hover-over

And if you do not, use:

mcetool --set-low-power-mode=enabled --set-lpmui-triggering=from-pocket,hover-over
edit flag offensive delete publish link more

Comments

It seems that it's an interrupt issue. The LPM mode is doesn't work for periods of time and it was more a coincidence that it happened every try with the charger plugged in the other night. Either close this or I could change it to LPM mode not working every time. I could supply dmesg logs, if that would help.

Mohjive ( 2015-09-23 14:47:29 +0200 )edit

@Mohive: The only difference between "charging" and "not charging" that I can recall is: in late suspend the proximity sensor is put to a less power hungry mode and "charging" blocks the device from entering late suspend. So, if anything, it should work better with charger attached.

But compared to the "from-pocket", the so called "hover-over" triggering is a bit difficult to explain and getting it to trigger reliably takes some practice - which is why it is not enabled by default. Basically you need to start from "proximity not covered for > 3 seconds", then "cover and uncover the sensor in < 1.5 seconds". The covering needs to be long enough that sensor actually reacts. Something like 1. cover 2. say "hundred-one" 3. uncover.

If you still want to check if there is something wrong, or just for fun, running mce in verbose mode from root shell like this should show the lpm related triggering information:

systemctl stop mce
mce -T -qqqq -l*:tklock_lpmui_probe -l*:tklock_datapipe_proximity_sensor_cb -l*:mdy_display_state_enter

And back to normal operation via:

ctrl-c
systemctl start mce
spiiroin ( 2015-09-24 08:21:56 +0200 )edit

I have made sure t cover the sensor more than just a short trigger, about 1-2 s. In dmesg I can see "entering sleepmode 0/1" (can't remember exact wording right now). The test sequences were more than 5 s apart. I'll try running mce in verbose mode tonight.

Mohjive ( 2015-09-24 09:55:05 +0200 )edit
Login/Signup to Answer

Question tools

Follow
3 followers

Stats

Asked: 2015-09-21 23:44:29 +0200

Seen: 216 times

Last updated: Sep 22 '15