Ask / Submit
3

Persistant SSH password

asked 2015-09-25 13:27:57 +0300

Hummer12007 gravatar image

updated 2015-09-25 17:35:31 +0300

I frequently use SCP to transfer files between my laptop and Jolla, but for the sake of safety, I enable SSH only when I need it. This is where the problem occurs: it's really nice, when you have a memorable, but hard-to-guess password, which is safe enough for not changing it; as a consequence of current implementation, I have to set my password each time I want to copy something over. It's really inconvenient. Is there a way to keep the password persistant (after/with pressing the save button)?

P.S. I know about SSH keys, and use them frequently, but I'd prefer not to use them now.

edit retag flag offensive close delete

Comments

1

the other way round it, is to change from using devel-su to just 'su' with a set password of your choice, thus negating the need to add a password into the developer mode window. I use this always.

See this post here on TJC on how to set 'su'; https://together.jolla.com/question/30565/howto-using-su-instead-of-devel-su/

Edz ( 2015-09-25 13:34:46 +0300 )edit

@Markkyboy: I've already done that a long time ago, but it is only useful for local access. Besides, the server does not launch (refuses connection), until you set a password in the settings, so logging in as the root user would not solve the problem in any way.

Hummer12007 ( 2015-09-25 17:34:56 +0300 )edit

1 Answer

Sort by » oldest newest most voted
3

answered 2015-09-25 13:33:35 +0300

Philippe De Swert gravatar image

Go to settings->developer mode

There is a line where you password shows. Type in the one you want and press save. After that it will stay the same as the one you gave on that line.

edit flag offensive delete publish link more

Comments

So the password will be saved even if one disables developer mode and then activates it again?

raketti ( 2015-09-25 13:43:17 +0300 )edit
1

@raketti: I have not tried that, so I don't know... Also why activate and deactivate developer mode all the time, you can just start/stop the ssh server from the developer mode settings...

Philippe De Swert ( 2015-09-25 13:44:52 +0300 )edit

Don't know if anyone else does that, but I don't opt-in in all the early access releases, so I only activate the dev-mode when I opt-in, that's my reason. :) But I guess I could leave the dev-mode on and just start/stop the ssh server as you said, when needed.. Thanks for the tip! :)

raketti ( 2015-09-25 13:49:19 +0300 )edit

If you untick "Remote connection" the devel-su also stops working. There is no separate SSH server setting in Developer mode screen of 1.1.9.28.

penpen ( 2015-09-25 15:17:45 +0300 )edit

@penpen: Sounds like a bug if the behaviour is not in line with the text.

Philippe De Swert ( 2015-09-25 16:09:24 +0300 )edit
Login/Signup to Answer

Question tools

Follow
2 followers

Stats

Asked: 2015-09-25 13:27:57 +0300

Seen: 248 times

Last updated: Sep 25 '15