Internet connection dialogue popup in navigation app [released]

asked 2015-09-29 10:38:51 +0200

daywalker gravatar image

updated 2016-08-17 10:56:41 +0200

jiit gravatar image


i've read some similar questions but i think they did not hit the core problem... but let me describe the problem first.

I am using google maps with online connection for live traffic information. Outside of cities there's no problem but when i drive into a village or city i keep getting the internet connection dialogue which covers the whole navi app. I think this is not only annoying but dangerous! You have to keep your eyes on the traffic and don't want to look to your mobile phone and keep away the dialogue every time... Additionally interacting with your mobile phone while driving is prohibited by the law in Germany, dunno about other countries...

I think the reason why is i have saved some wifi connections in my device. So when it detects a wifi with the same name as a saved connection it tries to log into the wifi but the password is incorrect, of course and it wants me to enter the password.

Would it be possible to take the mac address of the wifi into account. So the device should only try to connect to a saved wifi connection if the mac address of the target wifi is the same as the saved connection.

I know that taking the mac address into account would exclude corporation wifi networks where a bunch of routers have the same wifi name/password but different macs. I have seen the roadmap of sfos 2.0 and better handling of corporate wifi is planned, maybe this would bring the solution. I would think of a switch or checkbox to mark a company wifi where the device should exclusively connect to wifis with the same name but different macs but not with other wifis in general.

This is a general thing but especially with an navigation app this is very annoying... The only solution would be to disable wifi during street navigation but let's be honest... who does really think about this every time?

The second possibility would be to completely disable the enter password prompt for already saved wifi. Only connect to a saved wifi when the password is correct. If the password is incorrect, don't bother me! Only manual wifi selection here.

edit retag flag offensive reopen delete

The question has been closed for the following reason "released in a software update" by daywalker
close date 2019-01-18 09:27:18.655312


I'm using "here" navigation (the former nokia navigation) and experienced the same problem. I would prefer your last suggestion. It is simple and intuitive. So far I reduced the problem for me, by renaming the names of the wlans, I'm using, from the standard name to an individual name. But of course this is only possible for the wlans, you have admin access to (or where you know anybody, who have admin access).

triessner ( 2015-11-02 11:15:18 +0200 )edit