Ask / Submit
16

Tablet: Connecting to a wifi network on 13 or 14 channel

asked 2015-10-10 00:34:10 +0200

miqu gravatar image

updated 2016-08-17 10:51:30 +0200

jiit gravatar image

I dont seem to find a way to connect to my wifi network which is hidden on the tablet. So I just shared my 3g from Jolla phone over wifi for now to get online. The same network is usable and I have added it earlier to my Jolla phone and my work laptop.

As comments state its a wifi channel problem that comes from regulatory orders for world wide distribution of tablets. Suggest we need a way to change the regulatory area easily or even automatically.

edit retag flag offensive close delete

Comments

On which channel is your wifi on?

tigeli ( 2015-10-10 01:23:12 +0200 )edit

If I remember correctly I set it up as so that it can pick it automatically. And its an old B/G 56mbit router. Dont think this matters though.

miqu ( 2015-10-10 02:21:20 +0200 )edit
4

It does matter as the tablet currently defaults to channels available on the US. Meaning that the channels 12 and 13 are not available to be used by default.

tigeli ( 2015-10-10 02:24:31 +0200 )edit

I'm also having trouble connecting to my home wifi. Can find it, but the neighbours networks fine. Mine is not hidden btw.

esmBOS ( 2015-10-10 08:22:59 +0200 )edit
1

I use channel 13 here in the UK. Not being able to use that would make it useless for me. It should surely ask your location on initial start, or be reset-able.

DaveRo ( 2015-10-10 09:54:30 +0200 )edit

2 Answers

Sort by » oldest newest most voted
5

answered 2015-10-21 00:11:58 +0200

miqu gravatar image

updated 2016-03-27 15:54:19 +0200

Answering my own question: @tigeli made a small fix for it as an package and it works so that proves that this is not locked in eeprom etc. The fix changes the region so that you can use all frequencies. Just needs a restart after install. Its also available from OpenRepos.net.

Waiting on Jolla's official fix now.

edit flag offensive delete publish link more

Comments

"For some hardware, regulatory permissions are programmed into the EEPROM..." - from here: https://wireless.wiki.kernel.org/en/developers/Regulatory

DaveRo ( 2015-10-21 00:57:09 +0200 )edit

Yeah, it is starting to look so that indeed I will need to make another go at configuring my really old Cisco again. It has only console access working and its been a while since I have done my Cisco CCNA classes. :)

miqu ( 2015-10-21 01:00:18 +0200 )edit
4

@miqu That won't work without modifying the wlan-driver code. If I have time tomorrow I will either provide rpm which will do the job changing the regulation-domain from US to "world" or short instructions how to do it. However, this rpm or the instructions are not provided by Jolla but personally by me.

tigeli ( 2015-10-21 01:10:14 +0200 )edit

@tigeli Thanks. I just needed to know it was doable by the time I got my tablet.

I see this was tagged as a bug, but not marked 'tracked by jolla' which, from another answer I got, meant it's on Jolla's bug system. And it's now tagged 'feature request' too. This is a copper-bottomed bug surely.

DaveRo ( 2015-10-21 09:36:46 +0200 )edit
1

answered 2017-02-21 16:30:29 +0200

MeegoUser gravatar image

updated 2017-02-21 17:22:13 +0200

@tigeli Thank you so much for the rpm-package you made, to make channel 12 and 13 accessible. Works great now after I installed it!

For anyone who looks for the download link:

https://openrepos.net/content/tigeli/harbour-wlan-region

edit flag offensive delete publish link more
Login/Signup to Answer

Question tools

Follow
3 followers

Stats

Asked: 2015-10-10 00:34:10 +0200

Seen: 1,387 times

Last updated: Feb 21