Ask / Submit
6

short battery life time [answered]

asked 2015-10-11 18:31:43 +0200

thesix gravatar image

Hi,

Currently I do not get a lot more thean 24 hours (or less) of battery life time on my almost brand new jolla phone (received the device a month ago). Right now the phone is at 77% battery level and battery monitor says it will last for another 18 hours. I finished charging it about three hours ago and did some twitter business since then, that's it. Wifi is usually switched off and I have stable 3G connectiviy. I do calendar and phone book sync once per hour.

At first I thought it might be some apps (e.g. Telegram) that do frequent updates via the network so I turned them off but nothing changed.

I am running sailfish 1.1.9.28 (Eineheminlampi) since it was released to the greater public and I have the impression that the battery performed better before that (but I cannot back this up with real data).

I read most of the relevant articles and tried the pushing of the pins which did not change anything. CSD tool shows battery as:

Minimum: 3.40V
Maximum: 4.35V
Value: 3.9V
Pass

Minimum: 0.00Wh
Maximum: 7.71Wh
Design minimum: 0.00Wh
Design maximum: 7.98Wh
Value: 5.01Wh
Capacity: 96.68%
Pass

Health:  Good
Temperature: 29.3degC
Pass

I use the Battery Monitor App and notice that the graph that shows battery drainage is the same when the device is on compared to when it is on standby.

The only processes that lighthouse shows frequently that are using more CPU are lighthouse itself, lipstick, sensord, mce and mpdecision.

What I don't understand is that the CSD tool test for smart cover fails. I thought TOH (I have the standard white cover) is the smart cover, wrong? Anyhow, the test reads:

Smart card detected: Pass
Smart card interrupt: Fail
Enable 3.3V Pass
I2C device ID: Fail
Enable 5V charge: Fail
Test failed!

Don't know if this is related ...

Hope anyone has a clue about what's going on here.

Regards, Thesix

edit retag flag offensive reopen delete

The question has been closed for the following reason "the question is answered, an answer was accepted" by thesix
close date 2015-10-13 17:09:41.519281

Comments

It could be the btrfs balancing job that starts once a week and if there is some issue with btrfs, it may hang on the same block for ever, it will drain battery and lag your phone. You can check if the balance is active with the following command as root (enable devel in settings): btrfs balance status /

I do recommend you disable the balance: systemctl disable btrfs-balancer.timer

If you change your mind, you can always enable it again: systemctl enable btrfs-balancer.timer

If you want the current balance to finish, then you can try to reboot your phone a few time, or mount it in rescue mode with the --skip-balance option.

Trizt ( 2015-10-11 21:19:31 +0200 )edit

Thanks, tried that. Result of the command: No balance found on '/'

thesix ( 2015-10-11 22:24:06 +0200 )edit

cause its called btrfs-balancer

pawel ( 2015-10-13 20:24:01 +0200 )edit

No, it's not:

btrfs help
(...)
    btrfs [filesystem] balance start [options] <path>
        Balance chunks across the devices
    btrfs [filesystem] balance pause <path>
        Pause running balance
    btrfs [filesystem] balance cancel <path>
        Cancel running or paused balance
    btrfs [filesystem] balance resume <path>
        Resume interrupted balance
    btrfs [filesystem] balance status [-v] <path>
        Show status of running or paused balance
(...)

Would you issue a command that does not exist (like balancer), the result would be the output of the help command prepended by the line

: unknown token 'balancer'
thesix ( 2015-10-14 12:37:10 +0200 )edit

there are two options. you can start btrfs directly or using btrfs-balancer balance

pawel ( 2015-10-20 23:56:35 +0200 )edit

1 Answer

Sort by » oldest newest most voted
7

answered 2015-10-13 17:09:04 +0200

thesix gravatar image

OMG, the answer is really easy! For whatever reason I had my phone set to network mode 4G preferred. Without having a 4G contract the phone was constantly trying to find a 4G connection in vain. Changing that to 3G preferred gave me way improved battery life. I started to look into that after I had the phone in airplane mode over night and noticed that energy consumption dropped significantly. So it had to be related to the network ...

Now the problem is solved for me but I fear that anyone having a 4G contract and entering a location without 4G coverage will experience a rather rapid battery drain. Therefore I ask the devs to have a look at that and try to find a solution that consumes far less energy.

Regards, Thesix.

edit flag offensive delete publish link more

Comments

I have the same issue, but.. I don't have 4G connection on.. I have set it on 3G, but the issue happens however... Does anyone have any suggestion?

palikao ( 2016-01-27 00:13:23 +0200 )edit

Try to find out what/which process is using the energy. And also maybe open a new topic since this one is closed already.

Cheers, T.

thesix ( 2016-01-27 19:49:29 +0200 )edit

Uhm.. It's hard, because there's no clear information.. I can't read clearly..

palikao ( 2016-01-28 20:23:09 +0200 )edit

Question tools

Follow
2 followers

Stats

Asked: 2015-10-11 18:31:43 +0200

Seen: 960 times

Last updated: Oct 13 '15