Ask / Submit
3

Keeps using ringtone volume instead of system volume

asked 2015-10-17 00:28:05 +0300

luisjoly gravatar image

Hy guys. Don't know if this has already been posted, if so didn't find.

It's happening since I last updated to Sailfish "almost" 2.0 that sometimes I'm in an Android app (like Waze) and when I try to change the volume, the phone is on the ringtone volume, not the system volume. This is very annoying, as I the have to go to settings to actually change the volume....

Any similar case or solution?

edit retag flag offensive close delete

Comments

There is a workaround coming for making it possible to have the volume keys only change the system volume. No idea yet if it will make the ui. Guess depends on how many people dislike it ;)

Philippe De Swert ( 2015-10-17 13:20:56 +0300 )edit

2 Answers

Sort by » oldest newest most voted
0

answered 2015-11-05 18:28:28 +0300

tomtom gravatar image

Hi,

I just experienced a similar very strange behaviour.

I was on 1.1.9.28 and I watched a movie on the 30.10.2015 during my travel. I was able to adjust the volume normally with the hard keys. Upon arrival, I entered into roaming. On the 03.11.2015, I tried to listen to music as a noticed that no sound was coming out of the loudspeaker. I found out that it is some contact problems and pushing on the case solved it somehow. Anyway, I decided to plug PC speakers in the headphone jack that I use for years now on various mobile devices including my Jolla. After a half an hour, the music suddenly stopped. No sound were coming out, neither from the loudspeaker nor from the jack. However, by turning the volume to the maximum, noise was audible from the jack. I restarted the phone.

After the phone rebooted, pushing the hard keys set the ringtone volume only. I tried several things, like other apps, change the ambiance, restart the pulseaudio.service. Nothing helped except to set the volume in the terminal with pactl (pactl set-sink-volume 1 100%), so at least I was able to listen to music again on my travel back.

Today, 05.11.2015, in my home mobile network, I updated to 1.1.9.30, and, miracle, everything went back to normal ?!?

edit flag offensive delete publish link more

Comments

After I updated to 2.0, it now works fine, normally changing system volume when using hard keys instead of the ringtone volume.

luisjoly ( 2015-11-05 20:26:12 +0300 )edit
0

answered 2015-11-09 19:02:47 +0300

luisjoly gravatar image

This matter is apparently solved with 2.0 OS. It now behaves as expected. :-)

edit flag offensive delete publish link more
Login/Signup to Answer

Question tools

Follow
1 follower

Stats

Asked: 2015-10-17 00:28:05 +0300

Seen: 243 times

Last updated: Nov 09 '15