Ask / Submit
18

Support iCloud in Accounts explicitly

asked 2014-01-07 15:27:11 +0300

aegis gravatar image

updated 2014-01-07 15:28:34 +0300

Apple's iCloud service uses IMAP for mail, CalDAV for calendar and CardDAV for contacts.

Since they're standards based services, it should be relatively easy to add these to a Jolla provided it supports those protocols (IMAP is there already, CalDAV and CardDAV coming soon hopefully).

In the past I've successfully used iCloud's IMAP and CalDAV services on my N9 by configuring each manually. The process of configuring these is not for the faint of heart.

For an example, here's how it's done on BB10 - link

This could be a whole lot easier with one signon account in the Accounts Settings similar to how you've one account setup for a Google account rather than making non-technical people type in lots of server addresses.

edit retag flag offensive close delete

Comments

2

FWIW, you can configure iCloud email on your Jolla using the settings provided by Apple here

Apple KB ht4864 - iCloud: Mail server settings for email clients

With a username of format [name]@icloud.com, I found the IMAP settings for incoming mail worked just fine (imap.mail.me.com / SSL / 993) but the SMTP settings for outgoing mail kept giving sync errors until I switched from SSL to TLS (working settings are smtp.mail.me.com / TLS / 587 / Authentication: Password)

But of course it would be much easier if we could get iCloud to be a first-class citizen in the Accounts section alongside Google, Facebook etc.

CB ( 2014-01-08 23:05:02 +0300 )edit
1

'General CalDAV' support is now there in the 1.0.7.16 update and it logs in to iCloud's CalDAV server but so far it either retrieves no calendars or you get calendars with blank names and no calendar events.

Maybe I'm just entering the wrong strings into the settings but frustratingly you can't edit the account info after you've set it. You have to delete the account and start again each time.

I'm using

Username : my AppleID email address

Password: my AppleID password

Server address: https://pNN-caldav.icloud.com:443

Server path: /nnnnnnnn/principal/

the NN and nnnnnnnn numbers are obtained using http://blog.muehlbachler.org/2011/08/how-to-icloud-calendars-with-third-party-software/ or looking at the ~/Library/Calendars/hex-string/Info.plist files.

I think it might just be a matter of working out what the right Server address and path are but I've tried quite a few combinations with limited luck.

aegis ( 2014-06-10 01:33:16 +0300 )edit

Got the same problem. No calendars show up. I tried if I can connect icloud calendars in Evolution on Mint Linux, there I can at least fetch a list of Calendars in my account, but whenever trying to open, it asks for a password again, and with my correct AppleID password it keeps telling me "wrong password"

tried https://caldav.icloud.com as well, which shows same behavior as the pNN-caldav ones

skubo ( 2014-07-03 12:07:50 +0300 )edit

Just wondering if this might be the problem: https://groups.google.com/forum/#!topic/mozilla.support.calendar/ISvf4jRHrmo is the Sailfish Calendar advertising itself as "lightning" user agent?

skubo ( 2014-07-03 14:16:43 +0300 )edit

Dito on having the same issue. Either no calendars show up or a bunch of empty ones. I have tried several different combinations always with the same result. I am wondering why this issue is not more common around here.

cma ( 2014-08-26 19:12:56 +0300 )edit

1 Answer

Sort by » oldest newest most voted
2

answered 2016-10-27 06:51:07 +0300

DarkTuring gravatar image

updated 2016-11-01 04:38:44 +0300

I found the solution aegis based primarily on your help:

I am using 2.0.4.14 and it perfectly synchronized with my Apple Mac OX calendar, SIERRA OSXp

  1. in accounts add caldav,
  2. username use icloud email,
  3. password use icloud password, Note: make sure icloud and cloud calendar are enabled in OSX,
  4. server address is https://pNN-caldav.icloud.com:443
  5. Select CalDav and unselect CardDav,
  6. Leave optional calendar path empty,
  7. Thats it accept it and your now are synching with icloud calendar.

Repeat process and open another account for CardDav iCloud contacts using:

http://pNN-contacts.icloud.com:443 and unselect calendar on this account. For some reason https will not work and gives error stating account needs to be updated. Using Card... instead resolves the error of requiring account update but doesnt then synchronize.

Note: for NN number simply open Calendar app on desktop and go to icloud calendars, select the broadcast sign and make calendar public, then look at URL and the two.digit number.

Step 4 how to get "NN" number

edit flag offensive delete publish link more

Comments

Please stop marking your own answers as "correct", unless it was you who asked the original question.

ScumCoder ( 2016-10-28 18:48:55 +0300 )edit

@ScumCoder i figured its ok to select your owm answer since the process allows it but i can stop.

DarkTuring ( 2016-11-01 03:53:18 +0300 )edit

I have the same problem as described above: the account seems to go down well by using the instructions, but only one calendar entry appears in the Sailfish device. Using AquaFish 2.0.4.14. Any suggestions?

MarkoU ( 2017-01-13 11:27:22 +0300 )edit

It works with iCloud and your account is setup.

But the problem is, that there is only ONE iCloud calendar entry synced, the other entries were not synced. So there is still a problem with syncing of iCloud caldav and sailfish os.

I have read a long time ago, that this is a problem of the used mer code (or something similar).

jogi9990 ( 2017-01-20 17:41:37 +0300 )edit

I was hoping the Iijoki update would improve the sync with icloud calendar, but it is as before (acc seems fine, but only one entry appears). This is really the only functionality that Sailfish is short of when compared to N9.

MarkoU ( 2017-04-17 19:04:48 +0300 )edit
Login/Signup to Answer

Question tools

Follow
9 followers

Stats

Asked: 2014-01-07 15:27:11 +0300

Seen: 3,904 times

Last updated: Nov 01 '16