Ask / Submit
10

[bug] Jolla ringtones disappeared from sound list after upgrading to 2.0.0.10

asked 2015-10-23 07:07:50 +0200

AliN gravatar image

updated 2015-10-25 20:52:25 +0200

After upgrading to 2.0.0.10, I have my TOH ringtones on sounds list when selecting ringtone, but none of Jolla default ringtones are available to select. They're still present at /usr/share/sounds/jolla-ringtones/stereo but not indexed.

The same happened for other sound files I had copied there to keep safe for ringtones. Making index file didn't help either.

Worst of all, all actions of ambiences were lost except few actions in 2-3 ambiences. This is a strange and inconsistent behavior.

Edit: I created an index file (i.e. sounds.index) and copied the ringtones into a default ambience (say Origami) in a sounds folder. Then I restart ambience daemon with devel-su systemctl --user restart ambienced.service. The default ringtones got doubled. So I removed the recently created files and it was solved.

So please anyone could try, I guess, restarting the ambience daemon may solve the problem. I myself didn't notice before creating the index file.

edit retag flag offensive close delete

Comments

Same here.

Manatus ( 2015-10-23 08:32:45 +0200 )edit

Can confirm.

fishegg ( 2015-10-24 04:48:01 +0200 )edit

Cannot confirm, still finding all jolla ring tones to be chosen from when editing ambiences in settings menu.

lakutalo ( 2015-10-25 21:09:22 +0200 )edit

Restarting ambienced.service didn't fix the problem for me. I can get the sounds visible under a chosen ambience by copying them in under an ambience (/usr/share/ambience/[ambience_name]) as you described, but the sounds are visible only under that ambience, and not in normal settings.

It may be noteworthy that all the mp3 sounds under /usr/share/sounds/jolla-ringtones/stereo directory have been visible for me, while Jolla-* files are wavs and not visible.

I have copied extra ringtones from other ambiences and from my old phones to Jolla over a year ago, so this problem may be self inflicted. Those files of course are not in the stereo.index file. Maybe the system didn't expect them and skipped the wavs.

Manatus ( 2015-10-25 23:55:23 +0200 )edit

Ok, at least in my case the problem was that I had mp3 files anywhere under /usr/share/sounds/jolla-ringtones. I moved them away and run systemctl --user restart ambienced.service. After that the original sounds reappeared in the sound selection list.

Manatus ( 2015-10-26 00:16:14 +0200 )edit

1 Answer

Sort by » oldest newest most voted
3

answered 2015-11-01 13:37:42 +0200

Yo gravatar image

updated 2015-11-01 13:41:44 +0200

It seems some people were hit by this bug, including me.

In the (duplicate) question(by me, sorry) @schturman posted a script to create a new stereo.index file. I enhanced that script to take file names with spaces and dots into account: http://pastebin.com/Q56bKfYT

You have to run it as root, so devel-su it.

edit flag offensive delete publish link more

Comments

1

Thanks a lot for contributing!

lakutalo ( 2015-11-01 14:45:22 +0200 )edit
Login/Signup to Answer

Question tools

Follow
5 followers

Stats

Asked: 2015-10-23 07:07:50 +0200

Seen: 483 times

Last updated: Nov 01 '15