Ask / Submit
2

no virtual keyboard

asked 2015-10-25 11:28:46 +0300

ilievdh gravatar image

updated 2016-08-17 16:35:36 +0300

jiit gravatar image

After updating to 2.0.0.10 there is no virtual keyboard anymore. I can use only my hardware keyboard. How can I force the virtual keyboard to shown? I have tohkbd (the first version not tohkbd2) with the 1st design ot the keyboard (with the flat cable, not with the magnets).

edit retag flag offensive close delete

Comments

same for me. updated yesterday, experienced this today when I wanted to write a note and no keyboard was showing up, then starting messages app and same there, rebooted and still no keyboard. It does work in the terminal app!

Affects: native Browser, messages,notes,contacts, mail, Andorid Firefox ...

Does not affect: Terminal

Update: installed Sailfish utilities to restart the virtual keyboard, it doesn't fix this problem, still no vKeyboard

mobile ( 2015-11-04 18:49:33 +0300 )edit

3 Answers

Sort by » oldest newest most voted
1

answered 2015-11-04 20:50:02 +0300

mobile gravatar image

Update2: it seems to be an incompatibility with the TOHKBD-Service, I have the old service still running.

I did this in terminal:

  • devel-su
  • systemctl stop tohkbd

virtual keyboard is working again

edit flag offensive delete publish link more

Comments

I have the same Problem, after each restart of Sailfish, no virtual Keyboard any more. . "devel-su" and "systemctl stop tohkbd". Unfortunately my harware keyborad DIY Version never worked (product by Dirk van Leersum). After 2 years of Jolla and Maemo before, I am still appreciating the hard work and the excellent product (with occaional drawbacks). Hope to keepup my Spirit until a new Hardware release ;-)

robinfoot ( 2015-11-26 17:15:20 +0300 )edit

You should ask Dirk to compile updated version with a fix for 2.0 if you planning to use it.

coderus ( 2015-12-06 07:30:06 +0300 )edit
0

answered 2015-12-05 10:35:17 +0300

Hello all, I am facing with the same problem after installing the patch manager and the disable lock screen animation patch. I have tried everything (uninstalling both the PM and the patch reboot, etc.) but I still do not have keyboard anywhere. My Jolla runs 2.0.0.10 Sainmaa. I would not like to reimage the whole phone, if possible. Any help would be highly appericiated!

edit flag offensive delete publish link more
0

answered 2015-12-05 13:03:08 +0300

It might be helpful for someone else: the problem was unrelated to the PM, but was related to this package: https://openrepos.net/content/penguin/hungarian-keyboard

I have installed that in the past, but it had not had any effects. I have forgotten to reboot my device then, what I did now, so the keyboard disappeared. Swithching back to English layout it works again.

edit flag offensive delete publish link more
Login/Signup to Answer

Question tools

Follow
1 follower

Stats

Asked: 2015-10-25 11:28:46 +0300

Seen: 680 times

Last updated: Dec 05 '15