[bug] securefishnet not really working with

asked 2015-10-26 16:06:43 +0300

cy8aer gravatar image

Securefishnet does not what expected: After starting an openvpn tunnel the gui shows everything is ok but no tun0 interface and no (default) routes into tunnel.

edit retag flag offensive close delete


For me it is working, but yes the name of the interface is not 'tunX' but 'p2pX'. I never looked up what the interface name was before the last updates.

xllndr ( 2015-10-26 16:22:28 +0300 )edit

Right that is the interface though no routes (packages go beside the tunnel). When starting via

devel-su openvpn --config mysettings.conf

everything works fine. Probably permission settings in the app itself.

cy8aer ( 2015-10-26 19:12:25 +0300 )edit

Okay, I just checked with iptables. You are right, the vpn can not be used as default gateway, to send all traffic through the tunnel. I tried uninstalling, rebooting and installing again, but no success either. As stated for one of the prior versions. The route is there but it lacks, like all other routes, the metric setting. Maybe setting this is the solution. The developer of the app should be contacted directly. Maybe you got an OpenRepos account?

xllndr ( 2015-10-27 12:18:07 +0300 )edit