We have moved to a new Sailfish OS Forum. Please start new discussions there.
39

FingerTerm terminal does not use system clipboard

asked 2014-01-07 20:04:05 +0300

tauko gravatar image

The contents of the system clipboard cannot be pasted into FingerTerm. The paste button in FingerTerm remains grayed out, even though system clipboard contains text.

The same is true also in the other direction: Selecting text in FingerTerm does not add it to the system clipboard, although copying and pasting inside FingerTerm works fine.

edit retag flag offensive close delete

2 Answers

Sort by » oldest newest most voted
5

answered 2014-01-26 01:05:06 +0300

tauko gravatar image

The other half :) of this problem, pasting from Sailfish apps to Fingerterm, is solved by a patch in https://github.com/tpikonen/fingerterm/commit/c234213d4c0307c1289021fc2157c22fe01bf1d4

Still no idea on why copying from Fingerterm to other apps does not work.

edit flag offensive delete publish link more

Comments

what about sending a pull request with this patch to the official repo? ;)

do it together is the slogan, right? :)

faenil ( 2014-01-26 19:23:10 +0300 )edit

The patch in question is probably not going to go in, because it just removes the checks which should work correctly according to Qt docs. There is probably something wrong with Sailfish's clipboard plugin.

In any case, a pull request was made to notify fingerterm developers about this.

tauko ( 2014-01-26 21:52:16 +0300 )edit

I added that null-check (and the "please don't remove it") myself, check git blame ;) Don't be afraid, the code will be reviewed ;)

faenil ( 2014-01-26 21:56:55 +0300 )edit

Can someone explain me please, how to apply this changes to fingerterm ? Where this two files located ( terminal.cpp and util.cpp), I can't find them... Thanks

Schturman ( 2014-02-11 15:51:22 +0300 )edit

IS there anyone over here who can do "How to" on applying this patch and having copy/past in FingerTerm please?

m2 ( 2014-05-03 12:49:25 +0300 )edit
0

answered 2014-01-26 15:35:48 +0300

Hess gravatar image

There is a lack of system-wide clipboard: https://together.jolla.com/question/832/system-wide-clipboard-copy-paste-capability/

edit flag offensive delete publish link more
Login/Signup to Answer

Question tools

Follow
9 followers

Stats

Asked: 2014-01-07 20:04:05 +0300

Seen: 764 times

Last updated: Jan 26 '14