Ask / Submit
15

why wifi don't work on android apps?

asked 2014-01-08 00:28:25 +0300

baba89 gravatar image

updated 2016-08-17 11:04:04 +0300

jiit gravatar image

firfox.....yandex store.....amozone store....opera....no one of that work on my wifi network. i try 2 different kind of wifi but nothing.....they work only via 2G o 3G connection..... i try this comand too but nothing change:

systemctl stop aliendalvik.service

and than..

systemctl start aliendalvik.service

edit retag flag offensive close delete

Comments

Same problem that baba89. I have to turn off the wi-fi to get internet on most of the android apps I get.

I have carefully read the 3 links you proposed (Xowap and jgr) but didn't find any answer for this particular problem...

lunatix ( 2014-01-09 12:07:38 +0300 )edit

This thread also deals with the issue: https://together.jolla.com/question/4150/android-apps-fail-to-connect-to-internet-after-system-update/. So far nothing has fixed this for me either :(

martti ( 2014-01-09 20:46:38 +0300 )edit
3

I can confirm that issue and experienced the same. Recently I reset my device and since then it seems to work fine (also on WiFi) - but I don't really know how it all the sudden works. You get my vote on that issue because once Jolla becomes a mature products, such bugs need to be fixed.

molan ( 2014-01-10 11:49:54 +0300 )edit

3 Answers

Sort by » oldest newest most voted
2

answered 2014-01-10 10:48:35 +0300

lunatix gravatar image

updated 2014-01-10 10:48:59 +0300

As suggested by MCFox in this thread (https://together.jolla.com/question/4150/android-apps-fail-to-connect-to-internet-after-system-update/), I have uninstalled Android support from the Jolla store, reboot the phone and re-install Android support. I tried all the Androids apps I have and they work just fine with Wi-fi turned on.

The last question is: "will it still be OK after a new reboot?" can't tell...

edit flag offensive delete publish link more

Comments

Can you tell us now (26 hours later)? ;-) In my case this approach didn't solve a thing, by the way.

martti ( 2014-01-11 12:51:38 +0300 )edit

Yes, I can telll. I turned off the phone all night long and this morning it still works, for all of the android apps I have.

lunatix ( 2014-01-11 13:10:10 +0300 )edit

This worked for me, but be aware that you will lose all data and settings from android apps.

Neo ( 2014-03-18 20:11:06 +0300 )edit

worked for me too

olpe ( 2014-03-18 22:46:08 +0300 )edit
1

answered 2015-01-08 20:21:08 +0300

Upp15 gravatar image

I was shocked a week ago, when I discovered similar symptoms as @baba89. Some android apps couldn't get access to network, if wifi was in use. Wifi itself was working fine, since Sailfish apps were alright with net connections. And what was strange, some Android apps still worked (at least WA, K-9), while most of them didn't. I could swear all of them worked fine with wifi previously. When I turned wifi off, all of them got connected again.

I tried to restart alien-dalvik, network, phone - tried even "hard boot" (battery off), nothing seemed to help. Then I started to think, if I had done something unusual with the phone lately. No system updates, only a few application updates (none of them was the ones with connection problem).

Then I remembered, that I had recently used an Android utility "OpenSignal" for testing mobile network performance. It has a switch on its front page, that you can use to turn wifi on/off. And - for some reason - I had turned it "off".

I have no idea, what the switch actually does, but boy I was relieved and happy, when after turning it "on" again, everything worked fine also with Android apps !

:D

edit flag offensive delete publish link more

Comments

I guess, it's something like
https://together.jolla.com/question/51695/bug-android-apps-connection-problems-with-wlan/?answer=53791#post-id-53791
I had to use the script again a few weeks ago, when android apps couldn't access wifi again (have been working before, with 1.1.1.27)

rudi ( 2015-01-08 20:48:13 +0300 )edit
0

answered 2014-10-04 00:04:18 +0300

Neo gravatar image

The answer from @lunatix works for me, but I can't still understand why this is happening, and I think that this problem should be adressed by Jolla.

It happens to me approx. every two months. When this happens, android apps can't connect to any wifi. I uninstall Android support from Jolla store, reboot the phone and re-install Android support, and connection to wifi works.

edit flag offensive delete publish link more
Login/Signup to Answer

Question tools

Follow
3 followers

Stats

Asked: 2014-01-08 00:28:25 +0300

Seen: 3,092 times

Last updated: Jan 08 '15