We have moved to a new Sailfish OS Forum. Please start new discussions there.
1

Touching the screen when dimming, temporarily raises display timeout to the higher level [answered]

asked 2015-11-10 15:39:59 +0200

AliN gravatar image

updated 2015-11-10 19:34:52 +0200

I'm not sure if this is a bug or a feature. Does anybody know any thing about this?

To reproduce more easily:

  1. Go to Display settings and select 15 secs for Sleep after.

  2. Open the Clock app and start the stopwatch to look after the time.

  3. Don't touch the screen until it's starting to dim around 15 secs.

  4. Keep the screen up with a single tap and again don't touch it until the next dimming. You should see the next timeout occurs around 45 secs (30 secs later).

  5. Keep the screen up again with a single tap. The next timeout will be on 1 min later.

If you continue this way you will get the next timeout on 2 mins and then all on 10 mins, just the same as options for display sleep.

I consider this as a bug, because I expect the display to turn off every n secs, even if I keep it on when it's going to dim.

edit retag flag offensive reopen delete

The question has been closed for the following reason "the question is answered, an answer was accepted" by raketti
close date 2015-11-11 20:59:45.033224

Comments

does it have a time limit? or raise further on never-ending?

cemoi71 ( 2015-11-10 18:03:56 +0200 )edit

@cemoi71, this is a really boring experiment, but I'll do it. I expect the next iterations will be 2 min and 10 min and no more, the same as options for display sleep.

AliN ( 2015-11-10 18:22:10 +0200 )edit

hmm yes indeed boring experiment... but why do you think that it would be 2 mins and 10 after it?
it don't do it with 10sec at start?
i'll give a look on it tomorrow, if i remember of it. i'm curious

cemoi71 ( 2015-11-11 00:53:43 +0200 )edit

@cemoi71, they're just the same as options available on Display settings for sleep timeout; and after all, I did a 24-minute test and saw the display keeps up untouched for 10 minutes before going to dim. And I waited for the next 10 minutes to make sure.

AliN ( 2015-11-11 02:23:26 +0200 )edit

2 Answers

Sort by » oldest newest most voted
10

answered 2015-11-11 18:37:00 +0200

spiiroin gravatar image

This is the "adaptive dimming mode" feature of mce.

When the display is dimmed and then brought back to "on" state due to user activity (e.g. tap on screen) a longer delay is used for the next dimming.This can be useful when doing something that does not warrant constant interaction with the device (e.g. reading a long text). The default delay gets restored whenever display is turned off.

If you wish, you can disable it via:

mcetool --set-adaptive-dimming-mode=disabled

By default the steps used are: 15, 30, 60, 120 and 600 seconds. This too can be changed with mcetool - for example:

mcetool --set-dim-timeouts=30,60,90,120,150

The delay is not extended beyond the largest value specified on this list.

edit flag offensive delete publish link more
4

answered 2015-11-10 16:42:36 +0200

Kim gravatar image

For me this has always been a feature.

I have used this a lot, especially in the early days before the 'Keep display on while charging' was introduced, when I was driving and using Here to navigate (that is: following the line on the map), or when I have been mapping for OSM.

Lately I haven't been using it very much, as I just let the phone charge if I need it to not dim the display.

edit flag offensive delete publish link more

Comments

I've been using this as a feature as well. If you expect your screen to turn off, while prevent it from doing so? I find it useful from time to time when I have the need to d that.

Mr.Pancake ( 2015-11-10 21:46:31 +0200 )edit

Question tools

Follow
2 followers

Stats

Asked: 2015-11-10 15:39:59 +0200

Seen: 297 times

Last updated: Nov 11 '15