email app - cannot send attachements with # in filename

asked 2015-11-15 18:17:28 +0300

s_mario gravatar image

updated 2016-10-17 10:45:21 +0300

jiit gravatar image

I tried to send an gpx trackfile from modrana (20151114#09-25-53.gpx). When creating the mail everything looked good, but in the recieved mail the attachement was missing. I found only the following message in the log.

   Nov 15 14:56:05 Jolla creen[1960]: [W] attachments::addAttachmentsToMultipart:1562 - void 
attachments::addAttachmentsToMultipart(QMailMessagePartContainer*, const QStringList&) : 
"/home/nemo/Documents/20151114%2309-25-53.gpx" is not regular file. Cannot attach.

At first i played around with changing the extension (to .txt, .log) , but without success. After that i compressed the file, but again no succes.

Then I remembered that I have read here in the forum about a problem with the # character in the filename. (I'm sorry but I can no longer find the post.) But after removing the # from filename Jolla-mail could sent the email with attachement.

Would be nice if this could be corrected in the next release. SFOS should not care about the characters in file name (when they are allowed in filesystem) or there could be an errormessage when adding the file.

edit retag flag offensive close delete


This is something that should not be corrected... Instead, application developers and users should learn to use only "safe characters" in filenames. # can and will cause problems in systems. For more info about characters to avoid ( <- note here one typical system use for the # character...).

mvuori ( 2015-11-15 19:05:45 +0300 )edit

@mvuori So silently leaving out an attachment is expected behaviour and shouldn't be corrected?

ln ( 2015-11-15 19:21:24 +0300 )edit