Ask / Submit
6

caldav broken again?

asked 2015-11-18 03:36:10 +0200

lazart gravatar image

I've been so happy that within the update before the last one, I had correct times in calendar entries (caldav, owncloud), not shifted anymore. After the last update, I noticed that entries won't sync anymore, they are just stored local. I've spend over two hours trying to fix it.. now it seems the caldav account is working, but the calendar app just doesn't show me the caldav calendars at all :~( what could help? Calendar is one of my important apps.

edit retag flag offensive close delete

Comments

1

Did you enable the calendar entries from the "Manage calendars" in the calendar App?

tortoisedoc ( 2015-11-18 08:06:06 +0200 )edit

For me (SFOS 2.0.0.10 & OC 8.1.3) CalDAV still works correctly.

thessy ( 2015-11-18 11:37:55 +0200 )edit

I face the same problem since I updated my owncloud to 8.1.4: My calendars (I have three of them on my owncloud) don't sync anymore. I recreated the caldav-accounts, and I get to the point where I can select the calendars to sync, but after that nothing happenes. The calenders don't show up in "Manage calendars" either. Before I updated from owncloud 8.1.3 to 8.1.4 the sync to my Jolla calendar worked very reliable. My workaround: I use the google calendar app together with CalDav-Sync from Marten Gajda - both installed from play store. This works, and together with "Enhanced Email" I can even include my corporate exchange account into the google calender-app. But to be honest, it kind of sucks that I have to rely so heavily on androind apps. Especially since it did work with the Jolla apps before. I just found out that owncloud 8.2 is available - I will probably install it in the next days and give a feedback...

nelbrog ( 2015-11-18 14:20:59 +0200 )edit

for owncloud 8, this issue may depend on owncloud: https://together.jolla.com/question/99029/caldav-calendars-not-found-in-calendar-app-after-update-to-117/

but I'm using SF 2.0 and owncloud 7. I did't update owncloud back then just because of that.

I can't enable the calendars because they're just not visible there after setting up the account - in the caldav account "default calendar" and "birthdays" is shown, not in manage calendars.

lazart ( 2015-11-18 14:45:43 +0200 )edit

I don't think that the problem is the one lazart points to ("bad timing" in OC8). I had the "bad timing" issue when I updated to OC8, but I could always sync at least the main calendar, but the other calendars didn't work. Furthermore I applied the fix Miguel suggested, and after that everything was fine. Now it seems to be a new issue. I can't sync any calendar since OC 8.1.4

nelbrog ( 2015-11-18 19:12:27 +0200 )edit

6 Answers

Sort by » oldest newest most voted
2

answered 2015-11-21 17:49:15 +0200

nelbrog gravatar image

Ok, my guess above was wrong. I got sync working again by applying the patch by @Miguel. I had to change the following file /var/www/owncloud/3rdparty/sabre/vobject/lib/Component/VEvent.php acc in my owncloud installation according to this. (Edit as root, and it might be a good idea to make a backup of the original file, just in case...). After that, sync worked. I did this before, but apparently the last update replaced the adapted VEvent.php with the original one. So I guess one has to change check this file after an owncloud-update.

edit flag offensive delete publish link more
1

answered 2015-12-04 23:43:00 +0200

Andy Branson gravatar image

updated 2015-12-05 08:31:36 +0200

I find that the best thing to do when calendar sync misbehaves is to delete the database so it gets rebuilt. This will reset your phone calendars to the remote, so if you have any unsynced local changes then they'll be lost. But most of the time it gets the sync running again.

https://together.jolla.com/question/67034/howto-reset-user-databases/

edit flag offensive delete publish link more

Comments

I found several sql databases, which are those that I can safely delete, while loosing nothing more than the accounts?

lazart ( 2015-12-05 00:13:10 +0200 )edit

Added a link to the db deleting guide I wrote a while ago. I noticed that the Calendars dir has been merged into the main Calendar db since 2.0, so I'll have to update it. Last time I reset I also deleted the Sync/msociald db.

Andy Branson ( 2015-12-05 08:35:49 +0200 )edit

I moved /home/nemo/.local/share/system/privileged/Calendar/mkcal to a "trash" directory and rebootet. That did delete my local calendar, but not the caldav account. I found the caldav database using grep command in .config/libaccounts-glib/accounts.db... and deleted all 3 database file, rebootet again. This time my caldav accounts (so jolla account and email) are gone. I've set up the caldav account again, still no calendar visible...

lazart ( 2015-12-08 23:58:02 +0200 )edit
0

answered 2015-11-18 18:26:44 +0200

Moo-Crumpus gravatar image

Caldav is just fine for me. I use it with posteo.de. It might be a owncloud issue?

edit flag offensive delete publish link more
0

answered 2015-11-19 01:42:32 +0200

lazart gravatar image

updated 2015-11-19 01:43:10 +0200

I thought a working calendar might be worth a set to factory settings. It took a long time to get through all Jolla upgrades. I restored all that was possible from my backup. Still the same: no caldav calendar visible. As soon as I can upgrade owncloud 7 to 8, I'll try my calendars again, and tell you what happened. There are various caldav/owncloud troubles in different threads here..

edit flag offensive delete publish link more
0

answered 2015-11-20 00:57:38 +0200

lazart gravatar image

updated 2015-11-20 00:58:47 +0200

now I got owncloud 8.0.0, calendar working in thunderbird-lightning with the url https://my-server-url.com/owncloud/remote.php/calendar/calendars/username/defaultcalendar

with same url or without the last part "defaultcalendar" in Jolla, configuration seems to be successful, the calendars are shown in the settings, sync seems to work too, but still no calendar is showing up in the calendar app...

set up like described here: https://together.jolla.com/question/534/experimental-release-in-10716-support-for-caldav-based-calendars-eg-google-calendar/?answer=45133#post-id-45133

edit flag offensive delete publish link more
0

answered 2015-12-02 00:53:06 +0200

lazart gravatar image

meanwhile I've updated to Owncloud 8.2.1 (working in web-frontend and in Thunderbird-Lightning) in the hope it was a bug that's fixed now.. No success.

If I'm trying to sync, /var/log/nginx/access.log gives me this:

[01/Dec/2015:23:46:30 +0100] "REPORT /owncloud/remote.php/calendar/calendars/myusernamehere/defaultcalendar/ HTTP/1.1" 401 303 "-" "Mozilla/5.0"

and after a while:

[01/Dec/2015:23:47:30 +0100] "REPORT /owncloud/remote.php/calendar/calendars/myusernamehere/defaultcalendar/ HTTP/1.1" 504 182 "-" "Mozilla/5.0

first http error means "unauthorized", second one "gateway timeout".. Any ideas?

edit flag offensive delete publish link more

Comments

1

I see several 401 Unauthorized errors in my daily logwatch report from the server. They affect both caldav and carddav. But both are working on my jolla. So I would recommend you to focus on the 504 errors

Salzi ( 2015-12-02 12:19:09 +0200 )edit
Login/Signup to Answer

Question tools

Follow
3 followers

Stats

Asked: 2015-11-18 03:36:10 +0200

Seen: 1,321 times

Last updated: Dec 05 '15