Ask / Submit
2

Blank settings menu after upgrade to 2.0.0.10 [answered]

asked 2015-11-20 21:48:08 +0300

molly gravatar image

updated 2016-02-18 19:07:23 +0300

After upgrade I can't use browser and settings apps. I start "settings" -> new menu style "look and feel", "connectivity" etc -> then click on any menu item and nothing! just blank page and the same behaviour for entire menu. Browser starts with blank page and "program is not responding", camera app also doesn't work stable. I don't have any additional repos, top shows me just 10% cpu and minor memory usage. The others apps are working reasonably normal: phone, mail, messages, androids apps, notification screen.

Can I reinstall last update or downgrade to a previous one? Is reset the answer, if so how I can do backup and download it (menu isn't working)?

https://together.jolla.com/question/54160/items-in-settings-are-lost/ didn't work for me

edit retag flag offensive reopen delete

The question has been closed for the following reason "the question is answered, an answer was accepted" by nthn
close date 2016-02-19 19:40:22.895759

1 Answer

Sort by » oldest newest most voted
2

answered 2016-02-18 18:19:53 +0300

molly gravatar image

updated 2016-02-18 19:11:14 +0300

Just in case anyone has the same problem.

Official support only advised me to perform factory reset. What wasn't a great idea though. I tried other options before reseting. I downgraded successfully to 1.1.9.30 through ssu re/version --dup. All my files/apps were in place and I got back phone functionality.

Once 2.0.1.7 was announced I turned on early updates and got OTA. Meantime shortly after download started I received GUI error "cannot determine download size", next was pkcon refresh with "Error: Authentication failed (is SSU set up correctly?)". Some googling and here it was: https://together.jolla.com/question/120017/cant-update-to-20010-fatal-error-authentication-failed-is-ssu-set-up-correctly/ Once you disable repository and after that switch to a new release you need to disable it again. Now 2.0.1.7 is up and running, pkcon refresh also works.

edit flag offensive delete publish link more

Question tools

Follow
2 followers

Stats

Asked: 2015-11-20 21:48:08 +0300

Seen: 242 times

Last updated: Feb 18 '16