Ask / Submit
2

android app - no icon

Tracked by Jolla (In release)

asked 2015-12-09 17:52:53 +0300

richardsvk gravatar image

updated 2016-08-18 11:53:57 +0300

jiit gravatar image

Hello everyone, I am having an issue and have already reported it to jolla but because of the situation they are in they have not been able to confirm when it will get fixed (i am affraid it will take too long and i really need this particular app). I still hope there is a way to fix it manually by altering some files on the device itself. It's just that I am not an expert in this field and have not been able to figure out how. Now I hope someone can help.

What happened is that I installed the SmartBanking app : https://apkpure.com/smartbanking-sk/com.zentity.sbank.csobsk Installation proceeds as usually and app gets installed and can even be run from the installer without any issues. It even shows up under apps in the Aptoide store. But what is missing is the app icon and therfore it is not possible to run the app at all. This is what I would like to get fixed.

Anyone any ideas or suggestions? Thank you in advance! Richard

edit retag flag offensive close delete

4 Answers

Sort by » oldest newest most voted
3

answered 2015-12-09 18:55:57 +0300

tyler gravatar image

updated 2016-09-09 17:17:33 +0300

EDIT 3 / Update

Auto detect/fix way

Try this script (may not work though):

devel-su python -c "$(curl -fsSL https://raw.githubusercontent.com/TylerTemp/fix-jolla-desktop/master/fix.py)" smartbanking

This will generate an icon on desktop.

If the generated icon does not work actually, remove the icon by

devel-su rm /usr/share/applications/apkd_launcher_fix_smartbanking.desktop

I don't have a Jolla C device so I can't re-produce this issue. The reason might be the location or name changing of the apk file. This script will try to find the new apk file if the old one does not exist.

Also, everytime the device gets reboot it will clean the generated icon. If it happens, run the script again.

Manual way

If the script above do not work, try this:

cd /usr/share/applications
ls | grep bank

If it print filename which looks like smartbank:

apkd_launcher_com_zentity_sbank_csobsk-com_csobsk_smartbankingv2_activity_SplashActivity.desktop

then edit it by:

nano apkd_launcher_com_zentity_sbank_csobsk-com_csobsk_smartbankingv2_activity_SplashActivity.desktop

In my case it looks like this:

[Desktop Entry]
Exec=apkd-launcher /data/app/com.zentity.sbank.csobsk-1.apk com.zentity.sbank.csobsk/com.csobsk.smartbankingv2.activity.SplashActivity
Icon=/var/lib/apkd/apkd_launcher_com_zentity_sbank_csobsk-com_csobsk_smartbankingv2_activity_SplashActivity.png
Name=Smart
Banking
Type=Application
Version=1.0
X-Nemo-Application-Type=no-invoker
X-Nemo-Single-Instance=no
X-apkd-apkfile=/data/app/com.zentity.sbank.csobsk-1.apk
X-apkd-packageName=com.zentity.sbank.csobsk
MimeType=text/html;x-maemo-urischeme/http;x-maemo-urischeme/https;
X-Maemo-Service=org.coderus.aliendalvikcontrol
X-Maemo-Object-Path=/
X-Maemo-Method=com.zentity.sbank.csobsk.com_2Ecsobsk_2Esmartbankingv2_2Eactivity_2ESplashActivity

The issue here is

Name=Smart
Banking

Change it to Name=Smart Banking, then keyboard ctrl+x -> y -> Enter, it should be fixed.

Plz also update/comment here if this command does not work.


Original Anwser:

OK I found out the reason.

I'll explain in details since you're not an expert :D

  1. Enable the developer mode (You can easily Google it out)
  2. Download this file: https://tomorrow.comes.today/static/upload/TylerTemp/file/apkd_launcher_com_zentity_sbank_csobsk-com_csobsk_smartbankingv2_SplashActivity.desktop
  3. Upload this file to your Jolla phone, put it under your Downloads folder (you can use File Browser)
  4. Open the Terminal app (It's auto-installed after you active the developer mode)
  5. Input devel-su, hit enter
  6. When screen display Password:, input the password you filled when you active the developer mode in step 1. The screen should display [root@jolla nemo]# (Note it will not display "*" when you enter the password)
  7. Input cp /home/nemo/Downloads/apkd_launcher_com_zentity_sbank_csobsk-com_csobsk_smartbankingv2_SplashActivity.desktop /usr/share/applications/, hit enter.
  8. If it ask for override, input yes and hit enter.
  9. If the icon still not appear, input chmod 777 /usr/share/applications/apkd_launcher_com_zentity_sbank_csobsk-com_csobsk_smartbankingv2_SplashActivity.desktop, if still not appears, try rebooting your phone.

It works on my phone: Sailfish OS 1.0.0.11, SmartBanking: 4.2, Android support: 0.17.27

finished


EDIT

This also happens on the new TaoBao app (android app). Hope Jolla can fix it.

NOTE: Every time you update this app, you need to do step 2-9 again.


EDIT 2

How to enable developer mode:

  1. Go to settings-developer mode
  2. light up the Developer mode, light up the Remote connection, input your password in the Set password for SSH and root ac..., hit save

    enable-dev

  3. Open terminal, input devel-su, hit the enter. After Password: shows up, input your password you filled in step 2, hit enter. Your screen should looks like this:

    terminal

That's all.

edit flag offensive delete publish link more

Comments

1

Hi, Thank you for your response. Much appreciated!

I tried to follow your steps but can't get past the password in terminal. I use the latest Jolla sw and when enabbling the developer mode it only asks for the security code. I tried it several times but it did not work. I also tied my jolla account password as well an empty password but none of these worked. Do you know what do to in this case?

Thanks a lot again! Richard

richardsvk ( 2015-12-09 19:25:42 +0300 )edit
1

below developer mode, is remote connection, and below that is a textfield where you can define the passwort

the same u use after devel-su

pawel ( 2015-12-09 19:30:44 +0300 )edit
1

Updated the anwser :D

tyler ( 2015-12-09 19:36:54 +0300 )edit

Hi again, I can only post once every 60min as I am new to this forum. I have realized that thing regarding developer mode right after I hit send. Sorry my bad :)

I managed to get the icon on the screen. It does work but only until reboot. When I switch the phone off/on the icon is gone again. I am not sure if there is any solution to this. But if you have any idea I am of course more than happy to try it.

In any case thank you very much for your help and time! Richard

richardsvk ( 2015-12-09 20:28:32 +0300 )edit
1

The process handling the android application launchers is probably over writing the desktop file with an invalid entry. You can try placing the file under some different name, for example

/usr/share/applications/my_smartbanking.desktop

(PS. I converted your earlier answers to comments. Prefer using comments, unless you are actually providing some form of answer to the original question :)

Keto ( 2015-12-10 00:43:53 +0300 )edit
0

answered 2016-08-05 08:40:36 +0300

richardsvk gravatar image

Hello again,

I just got my Jolla C and are having the same issue with Smartbanking again. I tied to follow instructions on this page but for some reason it still does not work. Tyler can you maybe help again? Or someone else? Apk is now available here: http://www.apkmonk.com/app/com.zentity.sbank.csobsk/

Thank you once again!! Richard

edit flag offensive delete publish link more
0

answered 2016-08-17 15:59:28 +0300

meckuwan gravatar image

updated 2016-11-15 17:19:50 +0300

I am also having the same issue regarding the Smartbanking app, anyone can resolve this issue as i already have installed smartbanking app but its not working properly http://www.apkadsense.com/com.zentity.sbank.csobsk

edit flag offensive delete publish link more
0

answered 2017-05-13 02:06:07 +0300

TaoBao still does not have any icon

edit flag offensive delete publish link more
Login/Signup to Answer

Question tools

Follow
1 follower

Stats

Asked: 2015-12-09 17:52:53 +0300

Seen: 1,058 times

Last updated: May 13