Ask / Submit
4

Is it possible to have a custom keyboard layout for external bluetooth keyboard?

asked 2016-01-02 19:15:47 +0300

Yo gravatar image

Hi there.

I am using an alternative keyboard layout, a German variant of Dvorak's layout. More information (also how to get it to work in different ways on Linux) here.

I can type on a querty thumb keyboard but when it comes to touch typing I NEED the Dvorak layout. Some time ago I got a BT keyboard that worked seemlessly with my Jolla phone but I am unable to use it to type better/faster because of the wrong (normal) layout.

What do you think is the best way to accomplish the goal of being able to use a custom keyboard layout for an external keyboard?

Thanks for your help!

edit retag flag offensive close delete

2 Answers

Sort by » oldest newest most voted
3

answered 2016-01-03 20:11:26 +0300

kimmoli gravatar image

updated 2016-01-04 16:38:02 +0300

Yo gravatar image

Change physical keyboard layout to Deutsch (German), and apply following from console

dconf write /desktop/lipstick-jolla-home/variant '"dvorak"'
edit flag offensive delete publish link more

Comments

According to this (and I tested it : it WORKS): I apply the same concept for my bluetooth swiss-french keyboard.

[root@Jolla ~]# dconf write /desktop/lipstick-jolla-home/layout '"ch"'
[root@Jolla ~]# dconf write /desktop/lipstick-jolla-home/variant '"fr"'

Thanks kimmoli!

Thoric ( 2016-01-03 22:39:04 +0300 )edit
1

np. You can use dconf as nemo

kimmoli ( 2016-01-03 22:42:56 +0300 )edit

Thanks again, off course it's way better as "nemo". It rests me only one thing : dead character. Is there a way to activate them. You know for instance "^" followed by "o" produces a "ô" here (from my PC) but not on the Jolla. Not so important but would be great!

Thoric ( 2016-01-03 23:18:45 +0300 )edit
1

Compose is not working afaiu. And to get the ^ working even as plain key, you'll need also set variant nodeadkeys

kimmoli ( 2016-01-03 23:20:41 +0300 )edit

@kimmoli Thank you very very very much. This is awesome. You are my personal hero (again - as before regarding TOHKBD2). Of course you are the one knowing all about keyboards on Jolla ;)

Yo ( 2016-01-04 16:39:56 +0300 )edit
1

answered 2016-01-02 20:49:54 +0300

leszek gravatar image

The layout support is only implemented rudimentary currently. As for example you can switch to a qwertz layout but I was unable to get special characters like üäöß on my TOHKBD. So I guess this needs some upstream fixes first.

edit flag offensive delete publish link more

Comments

eh. this should be fixed ages ago (at least on latest SFOS 2.0.0.10), at least TOHKBD2 supports qwertz and special chars (except £)

kimmoli ( 2016-01-03 20:02:35 +0300 )edit

Guessing is not knowing. This is not an answer. Special characters and keyboard layout switching for external (BT) keyboard is working fine.

Yo ( 2016-01-04 16:41:08 +0300 )edit
Login/Signup to Answer

Question tools

Follow
4 followers

Stats

Asked: 2016-01-02 19:15:47 +0300

Seen: 814 times

Last updated: Jan 04 '16