Ask / Submit
1

[Bug]alarm still has sound even when "No sound" is selected

asked 2016-01-08 02:27:12 +0300

fishegg gravatar image

updated 2016-01-31 12:00:33 +0300

I select silent no sound for clock in an ambience. But it still has sound when triggered . What happened ? I missed something ?

  • Edited:2016.1.9 silent->no sound,added images
  • Updated:2016.1.29 tested on another default ambience "Work", the same result. I set chat ringtone to "No sound", but it still used the default ringtone. It seems there is a bug on default ambiences.
    image descriptionimage description
  • Updated:2016.1.31 Uploaded two images. I'm sorry that the language is Chinese. But I marked on the images. I took them after changed the ringtone and re-applied the ambience.
    image descriptionimage description
edit retag flag offensive close delete

Comments

1

my problem is that whatever i do when the phone is silent it always alatms with the creepy keira black alarm tone. that gives me a stressful wake up every morning. some ideas why this happens to me?

Dragomir ( 2016-01-08 08:55:12 +0300 )edit
2

this is not a bug. it is a feature. :)

tvicol ( 2016-01-08 13:09:39 +0300 )edit
1

If you edited your Ambiance and selected 'No tone' for Clock, than you have to re-enable your ambiance.

Alex ( 2016-01-08 13:19:45 +0300 )edit

@Alex Yeah, what I meant is "no sound". It didn't work.

fishegg ( 2016-01-09 05:48:54 +0300 )edit

@Dragomir try to re-set all actions.

fishegg ( 2016-01-09 05:49:27 +0300 )edit

5 Answers

Sort by » oldest newest most voted
20

answered 2016-01-08 04:50:29 +0300

KaoN gravatar image

I'd wish to keep this 'Bug' since I always set 'Silent' so it won't ring for call but still it could wake me up when the alarm is on.

edit flag offensive delete publish link more

Comments

Sorry for my inappropriate expression. What I meant is "no sound" but not "silent". I seleceted "no sound" but not no sound.

fishegg ( 2016-01-09 05:51:08 +0300 )edit
11

answered 2016-01-08 08:08:56 +0300

Bavarian gravatar image

during night i want sleep -->phone silent. to wake up, the alarm should still ring ;)

edit flag offensive delete publish link more

Comments

Sorry for my inappropriate expression. What I meant is "no sound" but not "silent". I seleceted "no sound" but not no sound.

fishegg ( 2016-01-09 05:51:17 +0300 )edit
1

answered 2016-01-08 12:51:28 +0300

HarhaanJohtaja gravatar image

updated 2016-01-08 12:53:39 +0300

Have you added clock sounds(or that they have no sound?) to the silent ambience in its settings? I think by default it has clock sounds enabled.

edit flag offensive delete publish link more

Comments

Sorry for my inappropriate expression. What I meant is "no sound" but not "silent". I seleceted "no sound" but there still had sound.

fishegg ( 2016-01-09 05:51:58 +0300 )edit
1

answered 2016-01-29 11:52:20 +0300

chemist gravatar image

Changing the ambience sounds while active does not change the system sounds, you need to reactivate the ambience to get the new settings. This is a change since 1.1.9 that ambiences are no more hard settings but only actions that get only applied when you activate an ambience. So if you change the current ambience in settings nothing changes to system settings unless you reapply that ambience.

edit flag offensive delete publish link more

Comments

No, it's not the problem of reactivating. The no sound setting of default ambiences can not work even you reactivate the ambiences many times.

fishegg ( 2016-01-29 14:13:18 +0300 )edit

@fishegg, it does for me on 2.0.1.7.

Alen ( 2016-01-29 14:59:05 +0300 )edit

@fishegg why do your screenshots show unchanged settings then? change to another ambience and then back maybe?

chemist ( 2016-01-29 18:50:23 +0300 )edit

@chemist I took the screenshots after re-activate and re-activate. It didn't help. I can firmly tell you that if you set "No sound" for any kind of ringtone of a default ambience, it would not work. But if you select a song as a ringtone, it works fine. The bug(?) just happens to default ambiences on my Jolla. I tried to re-apply again. And just uploaded two new images.

fishegg ( 2016-01-31 11:35:49 +0300 )edit
0

answered 2016-01-11 10:08:23 +0300

HansA gravatar image

Hi, I can't confirm this bug! I added "Clock" to a ambience and choose "no sound" for it. Than activate it and the alarm only lights up the display and the phone vibrates. My Phone runs 2.0.0.10.

edit flag offensive delete publish link more

Comments

Maybe try it on default ambiences? e.g. "Freedom". As you can see, I set "no sound" on ambience page, but the setting on sounds and feedback page is different.

fishegg ( 2016-01-11 10:38:04 +0300 )edit

You need to reactivate the ambiance for the settings to take effect, if you haven't already done that.

raketti ( 2016-01-11 10:58:21 +0300 )edit

Yes, tried it in default and own ambiences. The settings page shows also "no sound" on my device. Have you tried to deinstall the keira black ambience?

HansA ( 2016-01-11 11:03:40 +0300 )edit

@raketti Yeah,I reactivated the "freedom" ambience after changed the settings, didn't work. But it seems this situation only happened to default ambiences. I tried it on the ambience created by myself, the setings took effect. @HansA I don't have keira black.

fishegg ( 2016-01-13 17:32:54 +0300 )edit

@fishegg, so this could mean that the settings for the pre-installed ambiances are sort of hard coded and can't be changed. Seems like a bad move to me. But if the settings work for your own ambiances, then you could use those. Or create an ambiance with the background from the "Freedom" ambiance, if you like it as a background, then add you own settings. Just a thought, you could try renaming the "Freedom" ambiance and try to see if it then applies the settings - this is a long shot, but easy to try. :)

raketti ( 2016-01-14 06:57:47 +0300 )edit
Login/Signup to Answer

Question tools

Follow
3 followers

Stats

Asked: 2016-01-08 02:27:12 +0300

Seen: 696 times

Last updated: Jan 31 '16