systemctl --user restart pulseaudio.service failed

asked 2016-01-09 18:20:34 +0300

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

updated 2016-01-09 18:23:48 +0300

HH gravatar image

Lost my Jollas audio totally: speakears are "dead" both using earplugs and without. Can't listen music nor hear callers voice. For some reason I can't get pulseaudio.service started. Perhaps thats the reason of the problem? systemctl status pulseaudio.service prints "Loaded: not-found (Reason: No such file or directory) Active: inactive (dead)".

"ps aux |grep pulse" prints nothing.

OS-Reboot wouldnt help. Problem started I used first time Recorder app installed via Jolla store. Any suggestions how to get my Jollas speaker alive again?

edit retag flag offensive close delete


Did you try version --dup then pkcon refresh?

objectifnul ( 2016-01-09 18:54:38 +0300 )edit

I have

$ ls -l /usr/lib/systemd/user/pulseaudio.s*
-rw-r--r-- 1 root root 283 2014-06-18 15:35 /usr/lib/systemd/user/pulseaudio.service
-rw-r--r-- 1 root root 127 2015-05-16 22:37 /usr/lib/systemd/user/pulseaudio.socket
$ rpm -qf /usr/lib/systemd/user/pulseaudio.s*

(Not the newest SW, but the version is probably not the problem here if systemd complains that the file does not exist.)

ugeuder ( 2016-01-10 20:34:20 +0300 )edit

If it is also not starting after reboot, check if pulseaudio configuration has some issues. For this you can try to start pulseaudio by your own without systemd. Run as normal user (nemo) in the shell: /usr/bin/pulseaudio -v -n --file=/etc/pulse/ (in opposite to /bin/systemctl-user start pulseaudio.service as root, this does not daemonize and has a verbose output).

mono ( 2016-01-10 20:46:46 +0300 )edit