We have moved to a new Sailfish OS Forum. Please start new discussions there.

4G data fails connect, workaround [not relevant]

asked 2016-01-14 11:29:49 +0300

koolas gravatar image

updated 2016-01-14 14:16:46 +0300

jiit gravatar image

I'm in Meteor. It is Irish mobile network. I have 4G coverage all over Dublin and phone connects without data.

*Workaround * Set preferred network mode to 2G and wait for data to connect. Start data transfers (app that will send some request). Now go to settings and select preferred mode 4G. Phone will upgrade to 3G and if possible to 4G.

Could this be the default fallback mechanism when 4G data fails? Because now I had to put shortcut to Mobile Network settings and have to joggle. Sometimes I'm too lazy for that and switch to 3G instead, which always works. The difference is huge though: on 3G I get 6Mbit and on 4G I get 64Mbit!

edit retag flag offensive reopen delete

The question has been closed for the following reason "question is not relevant or outdated" by JoHe
close date 2017-09-09 13:26:54.102842



Think this might be the same as my issue here: https://together.jolla.com/question/127837/bug-network-coverage-drops-and-recovers-every-few-seconds/

DrCheeseCake ( 2016-01-31 20:13:22 +0300 )edit

It's related, but here I focus on the problem od 4G data. I clearly see that phone retries to connect for 4G data and keeps failing. My request is to make a change in state machine, so that when 4G fails phone should retry in 3G and not 4G. At the end 3G is better than no data. And then when 3G data is established after a while connection gets upgraded to 4G anyways.

koolas ( 2016-02-01 12:29:53 +0300 )edit

Is there a log I can trace to see what Jolla phone is trying to do?

koolas ( 2016-02-02 19:55:58 +0300 )edit

Maybe it is important to add info on the OS version you are running.

All these new issues seem connected:

There is older that mention similar issue though:

One of the common denominators seem to be 4G.

hope it helps

saturn ( 2016-02-06 15:20:20 +0300 )edit

I see simple solution that is to fallback to 3G if 4G does not connect, and not like now it is, that it keeps retrying 4G connection. At the end 4g is nice to have, but when it doesn't work 3g is better than nothing. Also it hapoens that after some time connection gets upgraded to 4g anyways. Can we at least have a button in easily accessible place eg 'settings shortcut' that would toggle between 3g and 4g?

koolas ( 2016-02-10 12:14:10 +0300 )edit

1 Answer

Sort by » oldest newest most voted

answered 2016-08-10 09:39:50 +0300

tvicol gravatar image

updated 2016-08-11 10:05:53 +0300

This bug is still present in If I initiate a call, data will start over LTE, but if I switch to a wifi hotspot and than back to LTE, data will not start. Jolla, please correct this, as is a PITA to initiate calls every time I want to get LTE data.

edit flag offensive delete publish link more

Question tools



Asked: 2016-01-14 11:29:49 +0300

Seen: 1,145 times

Last updated: Aug 11 '16