Ask / Submit
15

Automatic email check does not update thumbnails last check time [released]

asked 2014-01-09 15:34:02 +0300

mcfrisk gravatar image

updated 2014-03-04 08:52:15 +0300

VDVsx gravatar image

When jolla phone checks for email automatically and new email is available it plays a sound and adds a notification. It does not however update the email client thumbnail icon with the new 'last checked' time. Unread email count seems to be updated correctly but the last checked time not.

edit retag flag offensive reopen delete

The question has been closed for the following reason "released in a software update" by VDVsx
close date 2014-03-31 08:51:49.225585

2 Answers

Sort by » oldest newest most voted
0

answered 2014-01-09 18:27:14 +0300

Mohjive gravatar image

updated 2014-01-15 11:56:48 +0300

If you have more than one account configured with your Jolla, the cover shows the largest time elapsed since last sync with any account.

So if you have multiple accounts this is expected behavior.

EDIT: I've seen the behavior described in the question as well now, so it seems I'm affected by the bug as well. Still, the above applies for bug-free instances.

edit flag offensive delete publish link more

Comments

1

I have only one email account configured. It's a bug and easy to reproduce.

Though I have had multiple accounts setup when trying to get email working in the first place but only one is left in settings.

mcfrisk ( 2014-01-09 18:34:02 +0300 )edit

Then I agree with that there's a bug. :)

Has probably something to do with your old account not being deleted properly (hence the bug).

Mohjive ( 2014-01-09 18:43:05 +0300 )edit
1

Definitely a bug, even with multiple accounts. When both are synchronised simultaneously "just now", the cover will continue to state something completely different (e.g "18 hours ago") and won't refresh until you sync using the cover action.

ziller ( 2014-01-09 21:54:16 +0300 )edit

@Aequanix: no need to down-vote a correct, since I stated that it doesn't apply to when the bug is present, answer especially if it's the only answer and sends it down to negative. Karma is irrelevant, but having -1 on a correct answer may be misleading to other users.

Mohjive ( 2014-01-15 11:19:29 +0300 )edit

@Mohjive: Your "answer" begins with "I don't think it's a bug." Which ist imho opinion just wrong. It is also not an real answer. Comment wourd be appropriate.

Aequanix ( 2014-01-15 11:32:59 +0300 )edit
0

answered 2014-03-17 20:44:09 +0300

VDVsx gravatar image

Fixed in Sailfish 1.0.4.20, Ohijärvi, if you still have issues please comment here.

edit flag offensive delete publish link more

Comments

Just one minor bug remaining for me:

1) Do a manual sync (in my case 1x imap + 1x exchange)

2) Minimize Email-App

3) Lock the phone and wait for a bit

4) After unlocking, both the app cover and the app itself still shows "gerade eben" (just now?) for the last check time. Reopening the Email-app fixes this.

n9uwu ( 2014-03-18 11:24:59 +0300 )edit

Makes no sense to keep updating the UI when screen is off, as for not updating immediately when screen is turned on is a system problem, user level timers are not refreshed immediately, if you wait few seconds will be update no need to open the app, this will be improved at the system level.

VDVsx ( 2014-03-18 13:00:32 +0300 )edit

Question tools

Follow
4 followers

Stats

Asked: 2014-01-09 15:34:02 +0300

Seen: 309 times

Last updated: Mar 17 '14