Ask / Submit
72

[BUG]2.0.1/Taalojärvi auto ignoring incoming call

Tracked by Jolla (In release)

asked 2016-01-28 15:39:16 +0300

atlochowski gravatar image

updated 2016-04-20 10:38:53 +0300

jiit gravatar image

After update to 2.0.1 early access I discovered that my phone randomly ignoring incoming connection after 2 sec of calling. Because of that I missed a lot of call.

edit retag flag offensive close delete

Comments

11

agreed. happens to me too.

late88 ( 2016-01-28 16:51:10 +0300 )edit
4

Second that. Sometimes the display locks up, sometimes I can find the call muted and answer it. Telephone functions have been rock solid for a year now. Problems started immediately after upgrade.

jollakin_on ( 2016-01-31 18:36:20 +0300 )edit
1

I'm not sure if I'm having the same issue, but: Most calls, it seems, come through perfectly fine. There's one person I know of, though, who claimed he called me several times... but there was nothing. No ringing, no missed call notification, nothing in the call logs. This guy has my number stored on his cell phone since ages, so I rule out the possibility that he dialed a wrong number.

How is it with you guys? Do you find the missed calls in the call log? Do you see the LED blinking?

ossi1967 ( 2016-01-31 21:59:27 +0300 )edit
1

@ossi1967 yes, I can see this missed calls in call log. For me it's working likes after 1-2 sec of ringing it's stop ringing but i can still answer the phone call. It looks like press lock button during incoming call.

atlochowski ( 2016-02-01 00:13:42 +0300 )edit

Happens to me, too.

lupastro ( 2016-02-01 10:33:01 +0300 )edit

3 Answers

Sort by » oldest newest most voted
15

answered 2016-05-02 10:31:56 +0300

juiceme gravatar image

Now I have been on 2.0.1.11 for 3 days and I can with some confidence state that this bug has been fixed. I have received 6 phonecalls so that the device has been in my pocket and not once the call has gone to hold state!

Thanks for fixing this bug!

edit flag offensive delete publish link more
1

I can confirm too, I did not have any call auto-ignore either.

William ( 2016-05-02 13:24:37 +0300 )edit
2

answered 2016-02-12 08:59:03 +0300

jollakin_on gravatar image

updated 2016-04-21 20:38:58 +0300

My best bet so far: I set the (nice) flipover-gesture-detection feature to disabled on two devices, and have not had any inadvertent terminations or suspensions for more than a week. Update: now more than two weeks. No proof, of course, but before it affected 4/5 calls. (pkcon install mce-tools) mcetool --set-flipover-gesture-detection=disabled http://reviewjolla.blogspot.fi/2015/09/customizing-sailfish-os-mce-tools-by.html etc.

edit flag offensive delete publish link more

Comments

1

Mikset kerrot se täällä?

tortoisedoc ( 2016-04-08 23:26:07 +0300 )edit

what do you mean by this flipover detection feature? where can I find it in the settings? I would really like to check it by myself.

Eische ( 2016-04-14 22:41:23 +0300 )edit

The setting is available through the command-line based mce-tool or you downgrade to stable.

Looks like it was difficult to solve this issue, but since some hours were are in release and no longer in progress.

https://together.jolla.com/question/131716/flip-to-make-incoming-call-silent-should-be-disabled-when-the-phone-is-standing

Looks like they will also include a button in the UI to turn off the flip-feature, already in release. But if this bug here is fixed, the UI-Button is superfluous and just cluttering the UI with unnessary stuff. Removing such things later again will lead to discussions, so I wouldn't add it, if not required in first place.

hoschi ( 2016-04-15 00:18:57 +0300 )edit

allright, I tried "mcetool --set-flipover-gesture-detection=disabled", lets see if that helps me.

juiceme ( 2016-04-22 06:45:33 +0300 )edit

@juiceme i'm curious on your feedback...

cemoi71 ( 2016-04-22 11:10:09 +0300 )edit
1

answered 2016-04-11 13:54:16 +0300

ExPLIT gravatar image

Is it confirmed, that this bugs happens only, while on 4G (LTE) Network ? Or it affects all Network Modes?

edit flag offensive delete publish link more

Comments

1

It's not confirmed. For me it's happening when I use 2G. I don't use 3G or 4G.

atlochowski ( 2016-04-11 14:59:09 +0300 )edit
2

Happens on all. Using Congstar here, so I'm always on 3G.

hoschi ( 2016-04-11 23:24:22 +0300 )edit
Login/Signup to Answer

Question tools

Follow
26 followers

Stats

Asked: 2016-01-28 15:39:16 +0300

Seen: 6,120 times

Last updated: May 02 '16