Ask / Submit
9

Developer mode fails to activate with "problem on installing jolla-developer-mode" [answered]

asked 2016-03-06 19:46:17 +0300

palikao gravatar image

updated 2016-03-07 21:41:10 +0300

I'm opening again this thread because IMO it is not solved..

Suddenly, after a Sailogram message, an error message appeared "Problem with Jolla Store". Meteo app got reset and I've found that I don't have many repos anymore..

I've tried to enable Developer mode, but my Jolla can't install it because it doesn't find the package jolla-developer-mode.. and I can understand that it is related to its repo.. So.. Maybe that repo has disappeared and so I can't enable repos again without terminal..

I paste the previous thread text, because it is what is happening: "Enabling the developer mode fails with "problem on installing jolla-developer-mode". How can I enable it or get more insides for the reason without resetting the phone? Update: I can install from the jolla store applications, but it says for the jolla-developer-mode app it is not available."

I confirm that I can install apps from Jolla Store, but I can't access some repos, also on Warehouse..

edit retag flag offensive reopen delete

The question has been closed for the following reason "the question is answered, an answer was accepted" by palikao
close date 2016-03-07 00:19:38.481190

Comments

2

Two things to be checked:

  1. Did you install openssh from Openrepos? If yes, remove it.

  2. Execute ssu s in terminal (or in ShellEx if terminal aka fingerterm is not available) If it returns Release: latest instead of Release: 2.0.0.10 you were hit by the "ssu syndrom". To fix it, execute ssu re 2.0.0.10

objectifnul ( 2016-03-06 20:32:37 +0300 )edit

well..

  1. No, I didn't install it

  2. I can't: I don't have terminal installed, and I can't install it.. Just because of what I described before.. I can't enable/install developer mode, just because its repo can't be found!

palikao ( 2016-03-06 20:35:08 +0300 )edit
1

What about ShellEx? (https://openrepos.net/content/acce/shellex)

objectifnul ( 2016-03-06 20:36:20 +0300 )edit

Uhm.. I don't know what it is :) Please, tell me that I don't have to reset my Jolla...

palikao ( 2016-03-06 20:38:07 +0300 )edit
1

No, you shouldn't. Just install ShellEx and execute ssu within it.

objectifnul ( 2016-03-06 20:40:47 +0300 )edit

1 Answer

Sort by » oldest newest most voted
12

answered 2016-03-07 00:18:56 +0300

palikao gravatar image

updated 2016-05-16 23:46:21 +0300

SOLUTION:

  1. Check if openssh from Openrepos is installed. If yes, remove it.

  2. Execute ssu s in Terminal (or in ShellEx if Terminal aka fingerterm is not available). If it returns Release: latest instead of Release: 2.0.0.10, you were hit by the "SSU syndrom". To fix it, execute ssu re 2.0.0.10 -> now you should be able to install developer mode

  3. Check this file: /etc/ssu/ssu.ini. It probably has a section with disabled repositories. Edit the file, removing the whole line "Disabled-repos= .....(repos' names)....."

  4. In ShellEx or Terminal, execute version --dup

  5. Execute then pkcon refresh

  6. Reboot JP

  7. Re-enable each repo inside Warehouse

NB:

Q: What is SSU syndrom? Why does this happen? A system bug? A: Yes an old bug still under investigation. Some users experience it repeatedly but apparently at random. No explanation yet AFAIK.

NB2:

The procedure is applicable also to v2.0.1.7

edit flag offensive delete publish link more

Comments

Yep, the reason for the "ssu release latest" issue is still unknown. Haven't been able to reproduce it or deduct any common aspect in the various reports we have received.

For the above instructions: The file is /etc/ssu/ssu.ini and you should leave 'home' on the disabled-repos line unless you remove that repository from the [repository-urls] section. In general it is not advised to edit the ssu.ini file manually and it would be better to change things using the ssu cli tool.

One reason for the 3rd party repos being disabled is that they are disabled during the OS update preparation, download and install, and if some of those gets disrupted unexpected, it can possibly leave the repositories disabled.

Keto ( 2016-03-07 13:58:15 +0300 )edit

@Keto: please, explain better about ssu.ini.. I've removed the whole line "Disabled-repos=........". Where is "home"? I don't have it under [repository-urls] and I didn't have it after "Disabled-repos="..

About disabling.. I didn't update the OS, my Jolla shipped with 2.0.0.10, so.. mystery!

palikao ( 2016-03-07 19:51:02 +0300 )edit

At least the older versions had an example repository named 'home', that is by default disabled, and should be kept that way unless you know what you are doing :). Might be that it is no longer there in the more recent versions. You can use different ssu commands to configure the repositories (and other things) without manually editing the ssu.ini. ssu lr lists the repositores, ssu er <repo> enables repository, ssu dr <repo> disables repository, etc.

Keto ( 2016-03-07 21:08:20 +0300 )edit

oh, ok! I've followed what @objectifnul suggested. I made a backup of ssu.ini, and I've just checked about "home", but still can't find it.

palikao ( 2016-03-07 21:36:28 +0300 )edit

thanks, step 1 and 2 helped to enable developer mode again. My os version is 2.0.1.7

zonken ( 2016-03-09 22:44:28 +0300 )edit

Question tools

Follow
9 followers

Stats

Asked: 2016-03-06 19:46:17 +0300

Seen: 1,471 times

Last updated: May 16 '16