Ask / Submit
13

Flip to make incoming call silent should be disabled when the phone is "standing"

Tracked by Jolla (In release)

asked 2016-03-16 07:11:45 +0300

fishegg gravatar image

I have experienced that the phone became silent in the pocket when there was an incoming call, possibly caused by "flip to silent" function. The phone should not response when the phone is "standing" e.g. the phone is in the pocket. This function only available when the phone lying on the table is better.

edit retag flag offensive close delete

Comments

2

I confirm... It's very annoying.

Luca ( 2016-03-16 09:45:30 +0300 )edit

Ahh that could be the reason why I am never noticing incoming calls while walking...

Alex ( 2016-03-16 10:16:28 +0300 )edit

There is a patch available that disables the flip to silent at all - openrepos

elastic ( 2016-03-16 12:00:32 +0300 )edit
2

Don't use this patch, there is more proper way to disable this function

mcetool --set-flipover-gesture-detection=disabled

atlochowski ( 2016-03-17 11:25:15 +0300 )edit

Hei,

My twenty cents on it that this is related to this.

LVPVS over.

LVPVS ( 2016-03-17 16:31:51 +0300 )edit

2 Answers

Sort by » oldest newest most voted
5

answered 2016-03-16 14:53:55 +0300

spiiroin gravatar image

updated 2016-04-08 14:15:40 +0300

The flip to silence is meant to be triggered when:

  1. There is incoming call
  2. Display turns on
  3. Orientation sensor reports face up
  4. Orientation sensor reports face down

If the device is in the pocket -> proximity sensor should stop dislay from turning on -> (2) does not happen.

If the display is powered off -> orientation sensor should stay powered down -> (3) and (4) do not happen.

So in theory at least flip-to-silence should not mute calls while the phone is in a pocket / standing up. But there have been bugs caused by proximity and orientation sensor hiccups earlier (ref: https://bugs.nemomobile.org/show_bug.cgi?id=786), so ...

@fishegg and others experiencing this issue:

  1. What sfos version you have in use?
  2. Have you had snoozed-in-pocket alarms? (uses the the same flipover detection logic as silencing calls)
  3. Did you hear ringing tone at all / briefly for a second or so / longer than couple of seconds?
  4. If you heard the ringing tone, was the display already on when taking the phone from pocket?
  5. Was the call ui still visible? Did it indicate muted/ignored call, or was the call already terminated?
  6. If you have some way disabled the flip-to-silence, does that make the problem go away?

Also note: Patches are not needed for disabling flip to silence.

From sfos >= 1.1.7.x you can tell mce not to use orientation sensor - which effectively disables the gesture detection too:

mcetool --set-orientation-sensor-mode=disabled

And from sfos >= 2.0.1.x is possible to disable just the flip-to-silence via:

mcetool --set-flipover-gesture-detection=disabled

EDIT:

Also, if you are comfortable with editing system configuration, more verbose journal log might be useful for hunting down the reason for the problem.

As root, edit /lib/systemd/system/mce.service as follows (check EDIT2):

 [Service]
 Type=notify
-ExecStart=/usr/sbin/mce --systemd
+ExecStart=/usr/sbin/mce --systemd -v
 Restart=always

Then, as root, restart mce:

systemctl daemon-reload
systemctl restart mce

Persistent logs are not strictly required, but might make it more likely that logs from the time when call occurred are still available. Instructions at https://together.jolla.com/question/4842/how-to-enable-more-detailed-and-persistent-logs-on-jolla-device/

EDIT2:

I have now received one debug log. In that particular case it looks like flip-to-silence was not causing the problem. However it might be useful to have one step more verbose logs to verify flipover detection during these muting incidents. So preferred mce.service modification is:

-ExecStart=/usr/sbin/mce --systemd
+ExecStart=/usr/sbin/mce --systemd -v -lmodules/sensor-gestures.c:*

Note: The logs can contain personal information such as phone numbers. You might want to scrub those out before sending them in / submitting somewhere.

EDIT3:

Judging by the logs we have available at the moment, it looks like the flip-to-silence feature is not (at least the sole) cause of the auto-ignore in 2 seconds -issues.

We will anyway add a toggle in the settings application to make it easier for users to disable the feature it it is causing problems.

edit flag offensive delete publish link more

Comments

  • 2.0.1.7
    • no idea
    • yes about a second or less
    • yes
    • yes - alway states ignored call
    • seemed so at first but today I had an ignored call out of the pocket again :-(
elastic ( 2016-03-16 19:27:55 +0300 )edit

Thanks for long anwser.
1. 2.0.1.7
2. have no try
3. Possibly yes. I felt the phone vibrated but couldn't notice the ringtone because of noise of surroundings. But just before I took the phone out from pocket, it stopped.
4. Not sure, maybe yes. I remember the screen displayed "One call is in progress" on lockscreen. (Sorry I don't know the exact words because I am not using English language).
5. The call was ignored. Screen displayed lockscreen.
6. have no try

fishegg ( 2016-03-17 09:21:47 +0300 )edit

@fishegg: Thanks, having the phone show lockscreen instead of call ui -> might be also related to lockscreen activation/deactivation during call ui startup i.e. false positive "swipe to background" instead of "flip to silence". (Note: These extra lockscreen state changes do not happen with alarm ui.)

spiiroin ( 2016-03-17 09:45:04 +0300 )edit

@hoschi It's exactly the same bug

atlochowski ( 2016-03-17 11:29:15 +0300 )edit
0

answered 2016-03-18 09:16:15 +0300

atlochowski gravatar image

@fishegg i have disabled flip to silence couple days ago and it looks like good silution. I already reaported that to Jolla.

edit flag offensive delete publish link more

Comments

Hope Jolla can solve the problem.

fishegg ( 2016-03-21 13:33:50 +0300 )edit
Login/Signup to Answer

Question tools

Follow
6 followers

Stats

Asked: 2016-03-16 07:11:45 +0300

Seen: 1,779 times

Last updated: Apr 08 '16