Ask / Submit
6

Display doesn't turn off automatically

asked 2014-01-10 14:59:10 +0200

MMori gravatar image

updated 2014-11-26 12:48:48 +0200

jiit gravatar image

I have set the display to turn off after 30 seconds but it won't do so automatically. (It does turn off in the lock screen.) I have the latest os update installed and dev mode enabled.

http://www.reddit.com/r/Jolla/comments/1uecb7/screen_not_turning_off/ someone else has the problem too.

This is a problem when you have set the phone to lock itself with no delay. It will also drain the battery. It will never lock itself if the display doesn't get turned off.

Sorry if this is a repost, but I couldn't find a thread about this problem.

edit retag flag offensive close delete

Comments

I had the same problem. One night the phone was in charger and at morning I noticed the screen was on. Reboot helped.

iheilala ( 2014-01-10 15:36:24 +0200 )edit

Thank you for the suggestion, I'll try rebooting.

MMori ( 2014-01-10 15:39:12 +0200 )edit
3

Probably an alien dalvik issue. In this case no reboot is necessary, try

devel-su
systemctl stop aliendalvik.service
RogerCrocker ( 2014-01-10 17:03:04 +0200 )edit

Somewhat a stupid question but would stopping aliendalvik.service mean that the android apps won't work?

MMori ( 2014-01-10 17:19:29 +0200 )edit

It kills the aliendalvik process and all running android applications with it. But it's not permanent, when you restart the applications, aliendalvik will start again automatically. It works for me. Whole procedure is still a bit tedious, but better than rebooting, I guess.

RogerCrocker ( 2014-01-10 18:04:44 +0200 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2014-09-18 07:38:55 +0200

spiiroin gravatar image

The display dimming/blanking depends partially on "ui is locked" state (=when lock screen is shown). This state is shared between several processes and initially lots of issues were caused by various parties getting out of sync with each other. Which then caused too short / too long / no timeout to be used for the automatic blanking.

Most of these issues at least should have been fixed in Jan/Feb 2014 time frame.

edit flag offensive delete publish link more

Comments

Should we mark this question and duplicate (https://together.jolla.com/question/9573/bug-auto-sleep-mode-stop-working/) as "Released in software update"? Seems like nobody reported that issue anymore since January.

molan ( 2014-09-18 08:40:00 +0200 )edit

@caprico: I guess so.

IIRC the main culprit for things to get out of sync was incoming call. After that things felt pretty random, but anything that causes locked state to make on-off-on or off-on-off cycles would have recovered (including things like going to lock screen, toggling silent profile and then going back to home screen etc).

spiiroin ( 2014-09-18 08:56:13 +0200 )edit
Login/Signup to Answer

Question tools

Follow
3 followers

Stats

Asked: 2014-01-10 14:59:10 +0200

Seen: 5,735 times

Last updated: Sep 18 '14