upgrade Qualcomm drivers to more recent level

asked 2016-03-21 18:54:51 +0300

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

updated 2017-08-19 18:11:20 +0300

lpr gravatar image

[CVE-2016-0805] [CVE-2016-0806] [CVE-2016-0819] [CVE-2016-0843] [CVE-2015-0569] [CVE-2015-0570] [CVE-2016-2465] [CVE-2016-2467] [CVE-2016-2468] Oct'16:[CVE-2016-3926] [CVE-2016-3927] Nov'16: [CVE-2016-6725] [CVE-2016-6729] many critical bugs discovered in qualcomm drivers, so an upgrade of Jolla1 (JollaC / aquafish affected too, but different bugs) drivers is needed.

  • cve-2016-5080 asn.1: Objective Systems ASN1C generates code that contains a heap overflow vulnerability
  • Elevation of Privilege Vulnerability in Qualcomm Wi-Fi Driver (ANDROID-25344453), (ANDROID-26754117 access:Remote), (ANDROID-26764809 access:Remote) and (ANDROID-26425765) and [CVE-2014-9902] [additionally (ANDROID-26763920 , 27662174 , 27773913 , 27776888 , 27777501, CVE-2016-3792 severity:High) and 27777162 severity:moderate] (maybe high CVE-2017-0437 -> -0439 and CVE-2016-8419 -> -8421 and CVE-2017-0440 -> -0443 and CVE-2016-8476)
  • Elevation of Privilege Vulnerability in Qualcomm Performance Module (ANDROID-25773204), (ANDROID-25364034)) and (ANDROID-25801197), [CVE-2016-3768]
  • (maybe Qualcomm Tethering controller [CVE-2016-2060])
  • (maybe Elevation of Privilege Vulnerability in Qualcomm Buspm Driver [CVE-2016-2441],[CVE-2016-2442])
  • (maybe Elevation of Privilege Vulnerability in Qualcomm TrustZone [CVE-2016-2431] or [CVE-2016-2432])
  • Remote Denial of Service Vulnerability in Qualcomm Hardware Codec [CVE-2016-2454] (rated:High) [CVE-2016-6758 -61 High]
  • Elevation of Privilege Vulnerability in Qualcomm Video Driver [CVE-2016-2465] (rated:Critical) (additionally ANDROID-27407629 rated:high)
  • Elevation of Privilege Vulnerability in Qualcomm Sound Driver [CVE-2016-2467] (rated:Critical; access:Remote) [and (ANDROID-26876409), (ANDROID-27531992) and [CVE-2016-2068] rated:High], [CVE-2016-6791 High], [CVE-2016-8391 High], [CVE-2016-8392 High]
  • Elevation of Privilege Vulnerability in Qualcomm GPU Driver [CVE-2016-2468] [CVE-2016-2067] [cve-2016-5340 quadrooter] (rated:Critical)
  • Elevation of privilege vulnerability in Qualcomm camera driver [CVE-2016-2501 High] [CVE-2016-6755 High]
  • Denial of service vulnerability in Qualcomm GPS driver [CVE-2016-5341 High]
  • Information disclosure vulnerability in Qualcomm USB driver [CVE-2016-3813 Moderate]
  • Denial of service vulnerability in Qualcomm bootloader [CVE-2016-3850 High][CVE-2014-9798, CVE-2015-8893 Moderate] [CVE-2016-6729 critical]
  • Remote code execution vulnerability in Qualcomm crypto driver [CVE-2016-6725 critical]
  • Elevation of privilege vulnerability in Qualcomm components (Device specific: some may affect Jolla1/C, some not) CVE-2014-9863, CVE-2016-8411 critical, CVE-2014-9794, CVE-2014-9795, CVE-2013-7457, CVE-2014-9781, CVE-2014-9786, CVE-2014-9788, CVE-2014-9779, CVE-2014-9780, CVE-2014-9789, CVE-2014-9793, CVE-2014-9782, CVE-2014-9783, CVE-2014-9785, CVE-2014-9787, CVE-2014-9784, CVE-2014-9777, CVE-2014-9778, CVE-2014-9790, CVE-2014-9792, CVE-2014-9797, CVE-2014-9791, CVE-2014-9796, CVE-2014-9800, CVE-2014-9799, CVE-2014-9801, CVE-2014-9802, CVE-2015-8891, CVE-2015-8888, CVE-2015-8890 High
  • one or more of CVE-2016-8398 CVE-2016-8437 CVE-2016-8438 CVE-2016-8439 CVE-2016-8440 CVE-2016-8441 CVE-2016-8442 CVE-2016-8443 CVE-2016-8459 CVE-2017-0431
  • one or more of CVE-2016-8484 CVE-2016-8486 CVE-2016-8487 CVE-2016-8485 CVE-2016-8488

Using API19 drivers may allow/require linux-kernel upgrade (less likely, you have to use the kernel the driver requires: kernel 3.4 in the case of Galaxy S4 mini featuring Android4.4.2 although this KitKat version normally requires kernel 3.10 [so in principle you are able to release new Android API while sticking to old Linux Kernel] ) and alien-dalvik level-upgrade (more likely NOT required because jolla1 already seems to use API ≥ 17 drivers but provides API16 for aliendalvik), too!

Andoid version available for MSM8930Ax devices [ link ] : 4.4.2 with Android security patch level: 01.07.2017 BUILD DATE: 13.07.2017
x=A (e.g. Jolla1) x=B (e.g. Galaxy S4 mini)

Info about the WLAN host device driver installed on Jolla1: modinfo wlan returns a value vermagic: 3.4.108.20170530.1 SMP (2.1.1.24)

Edit 20160502: topic in next SailfishOS, open source, collaboration meeting 05. May 16 13.30h (UTC) Edit 20160505: meeting @sledges : <sledges> #info Jolla will look at the scope of this task</sledges>

Edit 20160620: there are some changes in SFOS 2.0.2.45. It looks like kernel is updated 3.4.108.20150901 -> 3.4.108.20160401 and modules, too [wlan: sbj-wlan 0.2.6 -> 0.2.6.1 , policy-settings, pulseaudio-modules, preinit-plugin-sbj, jolla-recovery-sbj etc...].
Edit 20160713: But dmesg is still saying wlan: loading driver v3.2.1.74 in 2.0.2.45 as in SFOS2.0.1.7
Edit 20160806: still the same on 2.0.3.14
Edit 20161007: still the same on 2.0.4.14: wlan: loading driver v3.2.1.74/modinfo wlan: vermagic: 3.4.108.20160401.1 SMP / sbj-wlan-0.2.6.1-10.21.14.jolla.armv7hl.rpm
Edit 20161127: 2.0.5.6: still wlan: loading driver v3.2.1.74/modinfo wlan: vermagic: 3.4.108.20161101.1 SMP / sbj-wlan-0.2.6.1-10.22.2.jolla.armv7hl.rpm
Edit 20170320: 2.1.0.9ea: still wlan: loading driver v3.2.1.74/modinfo wlan: vermagic: 3.4.108.20161101.1 SMP / sbj-wlan-0.2.6.1-10.22.2.jolla.armv7hl.rpm
Edit 20170819: 2.1.1.24ea: wlan: loading driver v3.2.1.74/modinfo wlan: vermagic: 3.4.108.20170530.1 SMP / sbj-wlan-0.2.6.1-10.22.11.jolla.armv7hl.rpm

  • [CVE-2014-9781], [CVE-2014-9785], [CVE-2014-9864] [CVE-2014-9865] [CVE-2014-9884] [CVE-2014-9887] [CVE-2014-9894] , [CVE-2014-9787], [CVE-2014-9778], [CVE-2014-9876], [CVE-2016-5340], [CVE-2014-4323], [CVE-2016-8480] are currently marked as "tracked by jolla"

  • [cve-2016-2059 quadrooter], [CVE-2016-2504 quadrooter], [CVE-2016-4008 libtasn1] fixed in Haapajoki(2.0.5)

edit retag flag offensive close delete

Comments

18

Just voted, even though I don't think this will ever happen.

hamlatzis ( 2016-03-21 20:59:01 +0300 )edit

Only way this could happen is if major player in the phone market starts pressuring Qualcomm to update the drivers.

avhakola ( 2016-03-22 23:32:06 +0300 )edit
21

@avhakola the drivers must exist. Galaxy S4 mini is a MSM8930Ax device like jolla1, snapdragon400/Krait300 cores and it has android 4.4 drivers, so they do not have to be developed just for Jolla. Jolla has to convince Qualcomm to give them access to the drivers, but with these bugs, that should work...

lpr ( 2016-03-23 01:52:23 +0300 )edit
8

I hope this happens before I pass out. By the time it happens, 4.4 level will be outdated as well.

Mr.Pancake ( 2016-03-24 11:08:44 +0300 )edit
1

If the drivers already exists (like @lpr says they do) and we haven't seen them on Jolla yet, I doubt we ever will see them.

avhakola ( 2016-03-28 16:32:33 +0300 )edit