Ask / Submit
2

Prevent Jolla from regenerating .desktop files

asked 2014-01-10 20:22:40 +0300

Hariainm gravatar image

Hello! Since i have installed some applications in my phone which i don't want their icons to show up (like the use of Flash Player for android, but i don't want the flash player settings icon, or yandex.store, because i already have other stores and don't use this one) i want to delete the icons. I remove the .desktop files in /usr/share/applications and it works, but if i reboot, the phone itself puts them again :( Is there any way to prevent this? Thanks

edit retag flag offensive close delete

Comments

3 Answers

Sort by » oldest newest most voted
0

answered 2014-01-13 20:12:50 +0300

attah gravatar image

I think it's a good thing from an anti-malware point of view that applications cannot hide that easily. But I do understand wanting to hide some of the eye-sores. Perhaps that could be accomplished with folder support?

edit flag offensive delete publish link more

Comments

of course it is a good thing, but users should have the power to control this. In my N9 this didn't happen, deleted files stay deleted after reboot.

Hariainm ( 2014-01-13 20:57:01 +0300 )edit
0

answered 2014-01-13 22:11:22 +0300

MartinK gravatar image

Maybe don't delete the desktop file and just delete its content ? Depending on how the system checks the desktop file (exists vs size/hash/modification time) it might work.

Or write a script that deletes them and make sure systemd runs it at startup ?

Well, both are serious hacks though...

edit flag offensive delete publish link more
0

answered 2014-02-18 00:41:56 +0300

Edz gravatar image

updated 2014-02-18 00:45:05 +0300

In Fingerterm; (devel-su required) Type in:

 cd /home/nemo/Documents

Create a new folder within 'Documents', call it whatever you want. I called mine 'Misc' Then;

cd /usr/share/applications
mv <filename>.desktop /home/nemo/Documents/Misc

This doesn't physically uninstall the app. It just removes the shortcut to the folder you created in Documents

To restore a shortcut, go to terminal as root;

cd /home/nemo/Documents/Misc
mv <filename> /usr/share/applications

This is working on my Jolla, 100%! (and survives reboot, every time!)

Regards'

edit flag offensive delete publish link more
Login/Signup to Answer

Question tools

Follow
2 followers

Stats

Asked: 2014-01-10 20:22:40 +0300

Seen: 367 times

Last updated: Jan 13 '14