We have moved to a new Sailfish OS Forum. Please start new discussions there.

"My Apps" list still empty (suggestions in other threads didn't help)

asked 2016-06-07 07:23:21 +0300

ploy gravatar image

updated 2016-08-04 15:46:02 +0300

jiit gravatar image

After an update a very long time ago, the "Jolla" app no longer showed any installed apps in the "My Apps" list.

No later update has fixed this. Removing and re-adding the Jolla account has not fixed this. Rebuilding the app registry has not fixed this. Running "pkcon refresh; pkcon update" has not fixed this.

Uninstalling and re-installing an app makes it show up in "My Apps" again, but this is not a workable solution for most apps, as uninstalling an app deletes all of its data.

Any other suggestions on fixing this?

edit retag flag offensive close delete

3 Answers

Sort by » oldest newest most voted

answered 2016-06-10 18:49:02 +0300

palikao gravatar image

updated 2016-06-10 18:54:46 +0300

Just happened to me too! v2.0.1.11

Uhm.. It happened after a almost-full-RAM time.. with many apps running (Store too): then Phone blocked and then alive again, but.. Store has had My Apps list empty. A reboot has solved.

Maybe your phone is still like blocked.

edit flag offensive delete publish link more



All in all tens of reboots since my app list vanished. This didn't fix it for me either.

ploy ( 2016-06-11 04:21:25 +0300 )edit

@ploy I knew that this would have not solved, but.. Maybe, thinkng about causes, will help Jolla in solving!

palikao ( 2016-06-11 08:14:22 +0300 )edit

answered 2016-06-10 21:31:44 +0300

nthn gravatar image

As you didn't specifically mention it, you might have missed it: https://together.jolla.com/question/7988/problem-with-store-unable-to-install/?answer=37218#post-id-37218

That fixed the problem for me last time.

edit flag offensive delete publish link more


Thanks, I indeed missed this post. Unfortunately, this solution hasn't fixed the problem for me either.

ploy ( 2016-06-11 04:29:06 +0300 )edit

answered 2016-10-28 20:57:02 +0300

MrHundert gravatar image

updated 2016-10-30 20:53:40 +0300

Device: JollaC
Im facing a similar problem: "My Apps" in store shows about 15 apps less than installed. They are marked as installed when i browse them in store. Installing apps does still work and reinstalled apps appear in the list. I`ve tried all of the suggested options like rebuilding app registry, removing cache directories, rebuilding rpm-database, re-adding Jolla-Account...

The packages are also listed when i execute "pkcon get-packages --filter installed" so the problem is somehow related to the store app????

Best regards MrHundert

edit flag offensive delete publish link more


I wonder if re-adding your Jolla account is the same as signing out and back in?, worth a try maybe?

Edz ( 2016-10-28 23:35:02 +0300 )edit

What is your device?

coderus ( 2016-10-29 02:52:05 +0300 )edit

@coderus my device is a JollaC;
@fmotl i dont know how to do this "signing out". The only availabe options are updating credentials or deleting whole account. am i missing something?

MrHundert ( 2016-10-30 21:35:15 +0300 )edit

Just in case, remove account & reboot & add account. At least that worked for me when Store lost suddenly all apps.

onion ( 2016-10-31 14:46:47 +0300 )edit
Login/Signup to Answer

Question tools

1 follower


Asked: 2016-06-07 07:23:21 +0300

Seen: 586 times

Last updated: Oct 30 '16