Bug: E-Mail can't handle quotation mark (") within password

asked 2014-01-12 01:40:23 +0300

tad gravatar image

updated 2014-08-13 10:26:18 +0300

jiit gravatar image

trying to fetch mails from an IMAP Server fails whenever the password contains a quotation mark (at least when it is at the end of the password).

this is what messageserver says when trying to fetch mails:

IMAP :  "6" RECV: a004 BAD Missing '"'

workaround: changing the password so that it doesn't contain a ".

edit retag flag offensive close delete

Comments

Well, tbh, it's kinda dumb to use "s in passwords as they might mess code up, but on the other hand, it would still be good to be able to use it anyways.

Bulder ( 2014-01-12 18:33:17 +0300 )edit
1

@Bulder ugh? That's like giving an excuse to not sanitizing user's input before entering them to SQL-database.

Milo ( 2014-01-14 10:20:26 +0300 )edit