Ask / Submit
9

Sailfish SDK on Virtual Box 5.1.0 Needs Additional Configuration [released]

asked 2016-07-24 16:19:28 +0200

r0kk3rz gravatar image

updated 2016-07-24 16:34:21 +0200

Installing the latest Sailfish SDK (Beta-1602) on Linux 64bit with Virtual Box 5.1.0 leaves the Virtual Machines MerSDK and Emulator not connected to the local network due to an error in the default VM configuration.

This problem surfaces as a MerSDK timeout, as the VM starts and runs but never appears on the network for ssh connection.

The fix is to go to Settings > Network > Adapter 1 & 2 > Advanced, and check the Cable Connected checkbox for each VM in Virtual Box Manager.

It would be nice if this was fixed, or put into the Known Issues for anyone who might come across this in the future.

Relevant Devel Mailing List Thread https://lists.sailfishos.org/pipermail/devel/2016-July/007252.html

edit retag flag offensive reopen delete

The question has been closed for the following reason "released in a software update" by r0kk3rz
close date 2016-12-02 11:11:46.355453

Comments

also compiling is incredibly slow compared to earlier versions (especially on win7)

tortoisedoc ( 2016-07-24 17:12:48 +0200 )edit

2 Answers

Sort by » oldest newest most voted
1

answered 2016-12-01 21:49:51 +0200

martyone gravatar image

Fixed in SDK version 1608.

edit flag offensive delete publish link more
0

answered 2016-07-25 20:24:49 +0200

palikao gravatar image

updated 2016-07-28 18:45:17 +0200

I can confirm the same problem on OS X (10.10), except for the Emulator which works, and on Win10 (latest release), with both Mer and Emulator which don't start..

The purposed solution works also on these two systems.

edit flag offensive delete publish link more

Question tools

Follow
2 followers

Stats

Asked: 2016-07-24 16:19:28 +0200

Seen: 492 times

Last updated: Dec 01 '16