Ask / Submit
35

Intex Aqua Fish battery life

asked 2016-07-24 21:22:26 +0200

utkarsh gravatar image

updated 2018-10-08 22:29:20 +0200

The battery is just about okay in the Aqua Fish. I have never used the Jolla 1 but have read a lot about its pretty amazing battery life and as for the Aqua Fish, I get barely enough for a day with moderate usage. The AIDA64 shows all 4 cores at 800MHz and about 1% - 8% processor usage when doing nothing.

I was thinking of under clocking the processor to save some battery life. Is there any way to under clock the processors in Aqua Fish to save battery life? Also any other battery saving tips apart from the obvious like switching off GPS / wifi when not in use and not using android apps.

EDIT I've had the phone for about 2 weeks now and I've found that the battery drains faster than expected. Without even using the android support, the battery life is not good. I've had the battery drain from 100% to 60% in about 7.5 hours with just one app, sailorgram, being used and android support stopped.

Every night the phone loses about 7-9% charge when it's kept on Airplane mode for about 8 hours. The standby time is pathetic as well. I hope there is a way to increase the battery life?

EDIT - 25-07-2017 Its been a year since this post and I haven't seen any improvement in the battery life with any update. Is there any known way to improve battery life for Aqua Fish?

EDIT - 09-10-2018 I have been noticing that when there is no sim in the phone and only wifi is used, alien dalvik turned on and screen off I get about 25mAh drain. With 2 sims but both disabled and everything else same, the lowest drain I have seen is about 100mAh. Is there any reason for that?

edit retag flag offensive close delete

Comments

2

It's 2500 mAh, isnt it?

t0mps0 ( 2016-07-24 22:33:37 +0200 )edit
3

@t0mps0 Yes, it is.

utkarsh ( 2016-07-24 22:39:12 +0200 )edit
1

on my phone i got an improvement by disabling facebook/xmpp accounts, as those lead to a constant cpu usage of contactsd of ~2% and prohibited the cpu to go to sleep mode

till ( 2016-07-25 11:46:01 +0200 )edit

how much time it takes to get charged completely?

shubh340 ( 2016-07-28 14:22:06 +0200 )edit
1

The battery on my Jolla 1 lasts half a day at most (granted, it's been used for almost a year). The Jolla C (Aqua Fish) in comparison has very good battery life, better than I expected. Your usage stats look very good to me. This is a smartphone, not a dumbphone, I don't think you can expect any better.

Giacomo Di Giacomo ( 2016-08-03 15:56:46 +0200 )edit

5 Answers

Sort by » oldest newest most voted
29

answered 2016-07-25 10:21:52 +0200

Armadillo gravatar image

updated 2016-07-27 13:48:26 +0200

jolladiho gravatar image

If you want to load those settings after each reboot automatically, you have to do the following things as root:

  1. Create /etc/rc.local file (e.g. via "vi"):

    #!/bin/sh -
    
    echo ondemand > /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor
    echo 200000 > /sys/devices/system/cpu/cpu0/cpufreq/scaling_min_freq
    
  2. make it executable:

    chmod +x /etc/rc.local
    
  3. Add those lines to the end of /lib/systemd/system/rc-local.service:

    [Install]
    WantedBy=graphical.target
    
  4. enable rc-local.service at boot:

    systemctl enable rc-local.service
    
  5. And finally, if you want to test if it works on boot, reboot:

    reboot
    

    UPDATE: From @vinc_e in the comments: You can also just reload systemd services and only start the single script we activated above:

    systemctl daemon-reload && systemctl restart rc-local.service
    
  6. Check files after reboot. They should look like this:

    [root@Sailfish nemo]# cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor
    ondemand
    [root@Sailfish nemo]# cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_min_freq
    200000
    

jolladiho moved his edit to his answer, sorry.

edit flag offensive delete publish link more

Comments

1

Thanks! Why the change to graphical.target ?

bomo ( 2016-07-25 10:33:10 +0200 )edit
2

Because graphical target is the systemd default target on the Jolla C and multi-user didn't work for me.

Armadillo ( 2016-07-25 10:34:18 +0200 )edit
2

Is the reboot mandatory? A simple systemctl daemon-reload && systemctl restart rc-local.service won't do the job?

vinc_e ( 2016-07-25 11:30:07 +0200 )edit
1

@Armaillo, thanks again! I just wondered, because before you made the edited, I tried it with mutli-user and it worked for me.

bomo ( 2016-07-25 11:33:09 +0200 )edit
2

@bomo: If it works for you, just keep it. But I wanted to have the 100% working version here. :-)

@vinc_e: Sure, but if you want to test the changes you have to reboot. ;-)

Armadillo ( 2016-07-25 11:42:58 +0200 )edit
15

answered 2016-07-24 22:32:57 +0200

jolladiho gravatar image

updated 2016-07-27 13:41:18 +0200

It is the same on JollaC. The phone is configured for "interactive" cpu governor and a minimal frequency of 800 MHz. Maybe this is a bug in the configuration.

If you have developer mode enabled you can check it in a terminal

cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_min_freq

it will answer 800000 (800 MHz)

To change this do the following in the terminal

devel-su
echo ondemand > /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor
echo 200000 > /sys/devices/system/cpu/cpu0/cpufreq/scaling_min_freq
exit

This changes the governor to "ondemand" and the minimal frequency to 200MHz. The interactive gonvernor does not realy use the 200MHz, thats why the change to ondemand is useful. I am testing this just too.

edit: You have to repeat it after every reboot.

edit 160727 after testing, not only me, look comments below: Battery still drains to fast! The CPU cannot enter sleep mode (btw: same behavior on jolla tablet). You can check it for example with android app cpuspy from fdroid repository. The sleep state is always unused.

edit flag offensive delete publish link more

Comments

Could you please break down the commands, telling what each command individually does? I'm pretty new to linux so I don't really know what each command does.

utkarsh ( 2016-07-24 22:42:18 +0200 )edit

Nevermind, got my head around it. Thank you! :P

utkarsh ( 2016-07-24 23:04:22 +0200 )edit
2

short:

cat <filename> (displays the content of a file to console)
devel-su (gives you root permissions, you need your user password)
echo ondemand ... (sets the cpu governor to "ondemand")
echo 200000 ... (sets the minimal possible cpu frequency to 200MHz)
exit (leaves the root mode and you return to user command prompt)

debian refcarddebian reference

jolladiho ( 2016-07-24 23:13:16 +0200 )edit

Since there are 4 cores would I have to do these commands for cpu0, cpu1, cpu2 and cpu3 as well? Self answered, apparently not.

utkarsh ( 2016-07-24 23:22:15 +0200 )edit
4

no, cpu0 is enougth. cpu1-3 are synchronized to cpu0. Exactly: the cpu[1-3]/cpufreq folder is a symlink to cpu0/cpufreq, means they all use the same files.

jolladiho ( 2016-07-25 00:00:18 +0200 )edit
4

answered 2016-09-08 17:07:40 +0200

Satvik Chaudhary gravatar image

install "cpufrequtils" by coderus from Warehouse and run the following command in terminal(developer mode):-

devel-su (your password - invisible typing) cpufreq-set -u 1.27Ghz cpufreq-set -d 200Mhz cpufreq-set -g interactive

more on...http://www.thinkwiki.org/wiki/How_to_use_cpufrequtils#Using_cpufrequtils

edit flag offensive delete publish link more

Comments

Is it possible to configure cpufrequtils in a way that these commands are executed automatically on startup? I really wonder why Jolla does not include these changes to the cpufreq and the cpu governer in one of the SFOS updates. IMHO these settings should be the standard settings, what do you think?

Sailor_John_Doe ( 2016-10-05 23:13:30 +0200 )edit

-> Sailor_John_Doe It seems to me, Snapdragon 212 operates only three governors: powersave, interactive, ondemand. Recommended sets (by QCM) are: G - interactive, Min_Freq - 800.

Asmir ( 2016-10-31 07:53:30 +0200 )edit
2

answered 2018-01-19 20:53:42 +0200

Asmir gravatar image

updated 2018-01-19 20:58:17 +0200

@utkarsh. You can reduce battery drain yourself. It works without any patches and works on Jolla C and Inoi R7 too.

The easiest solution is to change the file "/system/etc/init.qcom.post_boot.sh" in the case for MSM8909:

  • change governor (interactive -> ondemand)
  • change min cpu frequency (800000 -> 200000)

Good luck!

edit flag offensive delete publish link more

Comments

Did you really notice any improvement? I didn't test it thoroughly, but when I did try to mess with governor I remember noticing that overnight my INOI lost about 3% regardless of governor or underclocking.

Some sources (xda, as far as I remember) suggest that ondemand governor doesn't provide any improvement in battery life over the interactive due to "high-frequency bias" of the former (though AFAIK that bias is adjustable).

figgis-diggis ( 2018-01-19 21:49:27 +0200 )edit

@figgis-diggis, power consumption of the phone depends on many factors, such as CPU frequency, signal level of base station, 1 or 2 sims, data transfer, working background apps and others.I know exactly, more frequency is more consumption (according to the physical processes occurring in the transistor switchers). On my Jolla C energy consumption decreased by one third with underclocking frequency.

Asmir ( 2018-01-20 08:00:16 +0200 )edit

I've used that @Armadillo ( https://together.jolla.com/question/139036/intex-aqua-fish-battery-life/?answer=139079#post-id-139079 ) suggestion with rc-local.service, unfortunately it doesn't work. But yours works now ;) Thx a lot ;)

Btw.stopping Android support helps a lot. No battery drain through night ;)

tom.i ( 2018-01-20 12:58:18 +0200 )edit
1

@Asmir, understood, many thanks. Though I'd suggest just altering the interactive governor preferences since ondemand (in default settings, at least) tends to bounce the frequency up and down (as it is seen with AIDA 64 card left on the main screen — even without any input from me the frequency almost never rests at 200 MHz).

For example, in my case it was like:

echo "75 533000:85 800000:85 998400:90 1094400:80" > /sys/devices/system/cpu/cpufreq/interactive/target_loads

(75% for 400 MHz, 85 for 533 MHz and so on).

Of course, it's also necessary to alter the minimum frequency in cpufreq files — well, you already said, what to edit. And I by no means am saying that my target loads are the most reasonable — it's just something off the top of my head.

Interestingly, the default target loads are:

1 800000:85 998400:90 1094400:80

1% of target load clearly means that anything under 800 MHz is out of question. I'm now quite interested why did they do that. Of course 200MHz is not any good when there is interaction, but it would be quite enough when there are background tasks only (like playing music with locked screen). And as if there is an interaction — the interactive governor is quite ok with quickly increasing CPU speed (and not every interaction requires even 800 MHz).

figgis-diggis ( 2018-01-20 21:59:08 +0200 )edit

@figgis-diggis, it's good idea :) I also noticed that MSM8909v2 didn't want to operate at a frequency below 400 MHz (gov. Ondemand).

UPD_01-02-2018: ...but works fine with gov. Interactive and the correctly tuned attribute "target_loads".

@tom.i, glad to help :)

Asmir ( 2018-01-21 06:29:25 +0200 )edit
0

answered 2016-11-22 16:52:01 +0200

joao gravatar image

Not sure about other users experience but I get 2 days out of Intex battery. Right now its after lunch, and I have 44% left, I unpluged it yesterday morning, from a full charge. But I am a moderate user, I usually have 3G data and bluetooh off, wifi on. I make perhaps less than 5 calls a day, I played a bit with the jolla store yesterday and watch 2/3 youtube videos this morning. So to me it's a positive surprise, it last longer than I expected.

edit flag offensive delete publish link more

Comments

Same here, with moderate usage just as a phone (no wlan, no bt) about 2-3days. I was watching YT videos for about 4h and moderate usage another 12h. It looks pretty good to me. 2500mAh is not much but suitable for the device and matching the price.

deloptes ( 2016-11-23 01:25:26 +0200 )edit
1

I basically give up on sailfish OS, as at to-date, the standby time (in aeroplane mode) for my intex aqua fish is a joke - 100% charge on 10pm, 7pm wake up left 90% - OMG while in Aeroplane mode. Update to version 2.0.4.14 still the same things happen. Android service disabled, no mail sync, even apply power save mode on.

choo ( 2016-12-02 02:37:27 +0200 )edit
Login/Signup to Answer

Question tools

Follow
26 followers

Stats

Asked: 2016-07-24 21:22:26 +0200

Seen: 5,942 times

Last updated: Oct 08