Ask / Submit
7

no led light indication while charging in Jolla C (Intex)

asked 2016-07-25 06:20:12 +0200

amitpatel gravatar image

updated 2016-07-25 11:48:12 +0200

jiit gravatar image

upon charging there is no way to see if the phone is charging or not?

edit retag flag offensive close delete

Comments

2

In Jolla ! we had a led indicator which used to blink when charging and used to light up when fully charged. Here in the Intex only the led lights up after the phone is fully charged. There is no way to know whether the phone is charging without unlocking the phone. Request for an early resolution from the team

dillihifi ( 2016-07-25 07:34:24 +0200 )edit
2

It's the contrary, slightly lighten while charging and half-breathing when charged ;)

Sthocs ( 2016-07-25 13:50:02 +0200 )edit

@Sthocs my bad

dillihifi ( 2016-07-26 16:44:52 +0200 )edit
1

I personally don't like the LED flashing when charging. To me it makes more sense for it to be solid while it's charging, and then flash when it's done, as the flashing always draw my eyes to it (which is why I don't like it when it's charging), as a form of movement.

nadir ( 2016-08-08 16:50:22 +0200 )edit

Good because as I said two comments above, that's exactly how it works.

Sthocs ( 2016-08-10 11:54:40 +0200 )edit

2 Answers

Sort by » oldest newest most voted
11

answered 2016-07-25 10:33:09 +0200

updated 2016-08-08 15:07:49 +0200

The "phone is charging" pattern is disabled by default:

[nemo@Sailfish ~]# cat /etc/mce/60-hybris-led-l500d.ini
...
# While charging the battery, blink the led with 500 ms on / 1500 ms off
# period - for maximum of 30 seconds from start of charging. 
#
# Note: By default the charging battern is disabled. To enable, use:
#       mcetool --enable-led-pattern=PatternBatteryCharging

So, if you want to enable it (you need mcetool):

[nemo@Sailfish ~]# mcetool --enable-led-pattern=PatternBatteryCharging

Edit: the actions provided above are not required, the fact that I needed them on my device is probably due to a lot configuration "trials" during my tests.

The led will be on while charging for 30s only, but will not "blink", as by default "led breathing" seems disabled on Jolla C/Intex. To make it "breath", you can do this (assuming you already have enabled the PatternBatteryCharging):

[nemo@Sailfish ~]# mcetool --set-sw-breathing=enabled
[nemo@Sailfish ~]# mcetool --set-sw-breathing-limit=0

NOTE

The fact that the "led breathing" is disabled by default and that the charging pattern is configured to work only for 30s let me think that it is perhaps not a good idea to enable it while we are not sure of why it is disabled. So, you can try it at your own risk, personnaly, I re-disabled it just in case (there is no warranty on the Jolla C). If you want to re-disable the "charging" pattern, here are the steps:

[nemo@Sailfish ~]# mcetool --disable-led-pattern=PatternBatteryCharging

(more details about the led breathing and led patterns: https://together.jolla.com/question/138456/jolla-c-message-led-only-one-colour/)

EDIT>

Regarding the @spiiroin answer, the --set-sw-breathing is set to enabled by default. In this case, the two extra mce actions (--set-sw-breathing/ --set-sw-breathing-limit) are not required.

edit flag offensive delete publish link more
7

answered 2016-08-08 14:05:09 +0200

spiiroin gravatar image

The led configuration is compromise driven by hw limitations:

  • the led has only on/off control - brightness is not adjustable
  • blinking requires the cpu to be kept awake and thus has power consumption impact

And observations from testing various configurations:

  • rapid blinking can be viewed as "too attention demanding"
  • telling apart different slow blinking patterns requires several seconds of observing
  • without help of color coding - like in jolla 1 - differentiating notifications patterns based on charger availability just adds to confusion
  • even without the led, users get visual+audible+tactile feedback on start of charging

In the end we decided to keep the defaults as simple as possible: Solid led = Notification, blinking led = Battery full.

@vinc_e: The breathing should be enabled by default and the limit should not apply for charging pattern, so I'm wondering why you would have needed those "extra" mcetool invocations in addition to just enabling the pattern...

edit flag offensive delete publish link more

Comments

Perhaps the mcetool --set-sw-breathing(-limit)=enabled(0) action was required in my case because of the many tries I performed before finding the right configuration. I probably disabled it thinking it was its original state (I didn't find a kinf of --sw-breathing-status option on mce). Also, as in led.c source I red that the only the MCE_LED_PATTERN_BATTERY_FULL and MCE_LED_PATTERN_CSD_BREATHING always blink. So, I supposed that the "PatternBatteryCharging" one didn't have the same threatment. Thank you a lot for all the details, it really help!

vinc_e ( 2016-08-08 15:01:42 +0200 )edit
1

@vinc_e: Running mcetool without options shows value for the most of the settings, e.g.

mcetool | grep -i breath
Led breathing:                       enabled
Led breathing battery limit:         101 (%)

Also, you can check the contents of /var/lib/mce/builtin-gconf.values file - which is where mce keeps the values that have been changed from the defaults configured in /etc/mce/*.conf files. And there is "mcetool --reset-settings" option for restoring all/some settings to back default state.

spiiroin ( 2016-08-08 15:18:00 +0200 )edit
1

Great! Thanks a lot! I totally missed the "no option" stuff for mce

shame

vinc_e ( 2016-08-08 15:34:54 +0200 )edit

@spiiroin - your answer is justified. The only thing missing from Jolla 1 is color LED indicator for various notification. I have seen blinking LED upon full charging, and that's nice feature.

amitpatel ( 2016-08-08 18:10:56 +0200 )edit
Login/Signup to Answer

Question tools

Follow
4 followers

Stats

Asked: 2016-07-25 06:20:12 +0200

Seen: 659 times

Last updated: Aug 08 '16