Ask / Submit
5

Alarm Clock / Ringtone is silent

asked 2016-08-01 08:45:51 +0200

Apooo gravatar image

I have tried everything. Changing the ambience and making sure the sound is not muted. Sometimes randomly the sound will start to work again, but then in same instant alarm clock and ringtone sound is muted again without any warning. Headphones work fine at all times.

This is very frustrating as alarm clock cannot be trusted at all.

Are there any terminal commands I could use to solve this issue?

2.0.1.11 Taalojärvi

edit retag flag offensive close delete

Comments

1

Are you using a Jolla 1? If so, does the speaker work at all (like when playing something with the media player) when ringing is not working? There is a hardware fault which leads to a non working speaker in the Jolla 1, as seen e.g. in this TJC thread

Apparently pressing / hitting the right spot in the speaker area solved the issue for some.

seiichiro0185 ( 2016-08-01 08:55:33 +0200 )edit

Stupid question, really, but have you checked the current volume setting? The volume rocker could pull down the volume to a minimum by accident.

If you've already tried then just ignore the above, ok. :)

vattuvarg ( 2016-08-06 18:42:42 +0200 )edit
2

Pulling the volume down to ZERO with any ambience does not and should not affect the alarm, at least on my device it doesn't. Try it.

Edz ( 2016-08-06 18:47:37 +0200 )edit

4 Answers

Sort by » oldest newest most voted
1

answered 2016-08-06 18:09:34 +0200

Sakke gravatar image

updated 2016-08-06 18:39:04 +0200

vattuvarg gravatar image

I have noticed this same issue. You may know the sound when you unlock your phone. When this thing happens, however, there isn't this sound so you can test it every time you unlock your phone. I am using Sailfish 2.0.2.x Aurajoki, and this problem occurs every now and then. I think there's some correlation when you listen to music/something similar since it occurs to me more often after I have listened to music etc.

My advice is that you have to reboot the phone or at least reboot UI/lipstick from the Sailfish Utilities. Before Sailfish Aurajoki I only had this same problem in the very early times of Sailfish (like in 2014) so I think there's maybe a some kind of bug in the software.

edit flag offensive delete publish link more

Comments

1

Fixed a typo for clarity, that's all. Welcome to TJC, btw. :)

vattuvarg ( 2016-08-06 18:40:11 +0200 )edit

Yes thank you vattuvarg. I was writing that on my Jolla :D so there could have been more errors than just this one.

Sakke ( 2016-08-07 22:15:25 +0200 )edit

I fixed the typo with my Jolla C... ;)

vattuvarg ( 2016-08-07 22:31:29 +0200 )edit
1

answered 2016-08-11 07:56:10 +0200

FOMBE gravatar image

same problem still after 4months of working every morning. SF 2.0.3.14

only thing that I can think of for how to reproduce, are only guesses so far but.( ~5pm) I used hotspot from jolla pulley, quick switches. I turned hotspot off after use. (~8pm) battery was close to dry something around 6- 8 %. then I used charger to charge it back to lets say 80-90%. checked alarms from preset alarms for morning.

So this morning luckily I woke up, wondered why hasnt alarm sounded. checked time and noticed passed alarm 35minutes ago. seconds later alarm screen popped up without sound or vibration. I even tried to set volume levels of high but only reboot solved problem.

sorry for poor english but I had to write in a hurry. hopefully I can test to reproduce this later or someone else perhaps.

maybe this major bug has nothing to do with this setup but who knows..

cheers FOMBE

edit flag offensive delete publish link more
0

answered 2016-08-01 10:21:59 +0200

Apooo gravatar image

Jolla 1.

Yes it seems that the speaker is not working at all when the muting is happening. No music. During the calls it seems to work fine.

I wonder if there is still support/maintenance available for jolla? I live in Finland.

edit flag offensive delete publish link more

Comments

I assume that you can speak Finnish, but I'll be still going with English. I'm living in Finland too, and I think DNA (kauppa) is still the place where you can send your Jolla phone to for maintenance. Of course I can't say this for sure, but since you live in Finland it's not a big thing to ask DNA or go to DNA shop.

Sakke ( 2016-08-07 22:14:08 +0200 )edit
0

answered 2019-01-29 13:42:41 +0200

updated 2019-01-29 23:08:52 +0200

I had the same problem suddenly with SFOS 3.0.0.8 on my Jolla 1 as well. Only restart has helped. This is a serious problem. I have to rely on the alarm clock (as many others do as well) for work and some reoccurring reminders. Unfortunately I can hint something which has triggered this behaviour. Except that I haven't restarted for quite a while.

The same problem is described here

I changed that into an answer to gain some more attention as it may has bothered others without highlighting it here as it can be solved with a restart. Despite a restart is too late in case you overslept like I did.

edit flag offensive delete publish link more

Comments

see also: alarm-goes-off-but-without-sound, systemctl --user restart ngfd help me...

A.Maretzek ( 2019-01-29 20:05:40 +0200 )edit
1

@A.Maretzek: This daemon is the root for silent alarms and calls? Its unaltered for 9 month now, but the problem has occurred before and after. Seems not solved yet, in case the last modifications have targeted this problem. Maybe somebody should dig into that focusing this issue.

Vieno ( 2019-01-29 22:50:09 +0200 )edit

root cause.. Can't tell. I think that it happened with SF3 too, not sure though. A workaround is to go to the phone app and operate the pulley menu. If it doesn't vibrate, then for sure your morning alarm will be silent!

A.Maretzek ( 2019-01-30 01:58:09 +0200 )edit

...systemctl --user restart ngfd helped me...

A.Maretzek ( 2019-01-30 02:03:10 +0200 )edit
Login/Signup to Answer

Question tools

Follow
2 followers

Stats

Asked: 2016-08-01 08:45:51 +0200

Seen: 658 times

Last updated: Jan 29