Ask / Submit
4

Cannot enable mobile data from ISP Sonera in Jolla C

asked 2016-08-10 19:23:07 +0300

veksu gravatar image

updated 2016-08-12 16:06:01 +0300

JoHe gravatar image

Mobile network -> Internet is in Disables -state and I'm not able to activate that. Also in Events -view mobile data switch is in disabled state. Sonera SIM used. Data access point settings looks fine and also MMS access point settings look according to service provider spec.

  • Stop/restart Ofono -> No change
  • Reboot -> No change
  • Factory reset -> no change
  • Other service provider SIM -> Mobile data works (limited connection label though)
  • Sonera SIM in Nokia Lumia -> Mobile data works

Now, any ideas what next?

edit retag flag offensive close delete

Comments

I temporarily experienced the same this morning with the same service provider. Luckily a restart helped. The APN is simply "internet" for me.

William ( 2016-08-11 09:28:04 +0300 )edit

I had the same, I was cleaning/deleting config files, starting stoping ofono, removing sim card/ rebooting etc. - no result. Than whan you have no internet connection and try to do something on interenet at the top there choose box (left/right) to use data mobile or use wifi. Than when I clicked mobile data it shows some problems with data mobile but than it comes back to work. I will add that I had same as you that enabling data mobile were greyed out in settings and on event view.

Kurossa ( 2016-08-11 14:48:35 +0300 )edit

Very interesting indeed! Oh Sonera, what have you done? ;-) Remember to ask for refund from ISP Telia Sonera!

JoHe ( 2016-08-12 16:04:20 +0300 )edit

Think I had to change the Access Point Name to "online.telia.se" to get mine working (located under the setting: Data access point). Probably not the solution for you but might be worth a try.

//j

jesperC ( 2016-08-12 16:25:00 +0300 )edit

3 Answers

Sort by » oldest newest most voted
1

answered 2016-08-12 17:46:14 +0300

veksu gravatar image

All right. Root cause according to Sonera is that I had an old subscription type and while it had mobile data included, for some reason it refused to work. New SIM card nor other tricks did not help either.

But now, I can hardly believe my eyes but mobile data says "Connected" and browser is alive again. Solution was to eat humble pie and change my subscription to other, slightly more costly type.

edit flag offensive delete publish link more

Comments

1

You should definitely ask for compensation. Earlier, Sonera has paid back mobile broadband fees (for the whole year!) because of their malfunctioning network.

It would be very interesting to get their official technical explanation about their problem.

Edit: I am definitely not a customer of Sonera.

JoHe ( 2016-08-12 19:31:52 +0300 )edit
0

answered 2016-08-10 19:36:15 +0300

jpjolla gravatar image

http://talk.maemo.org/showthread.php?p=1512217#post1512217

Change APN. Llink above has discussion about it

edit flag offensive delete publish link more

Comments

1

Link suggest ' APN name from "Internet" to "Sonera Internet" ' but this doesn't work in this case. It will reset to previous APN. Maybe because there is a space between 2 worlds. So SoneraInternet is fine but Sonera Internet not. Even tried stopping ofono and editing gprs file but no luck.

veksu ( 2016-08-10 23:30:09 +0300 )edit
2

Now, it seems that there is something wrong on the service provider side. Sonera is investigating the issue atm.

Edit: Possibly issue with SIM card and Sonera will send new one. They 1st suspected that my subscription doesn't include mobile data but after deeper look confirmed that Mobile data is in place. In meanwhile more expensive subscription were offered. Let see if new SIM card resolves this case.

veksu ( 2016-08-11 09:40:55 +0300 )edit

It does sound a bit like this issue: https://together.jolla.com/question/141101/disabled-mobile-network-at-sailfish-20248-aurajoki/

What version of Sailfish OS are you on?

Jozz ( 2016-08-12 17:36:24 +0300 )edit
0

answered 2017-05-30 17:45:39 +0300

ehakkarainen gravatar image

Same problem here - a brand new Telia (ex. Sonera) 4G SIM does NOT work 4G in Intex AquaFish (that's converted to Jolla C via the script/Guide provided) - the same SIM works 4G fine in Jolla1

edit flag offensive delete publish link more

Comments

Intex Aqua Fish supports 2300\1800\850 frequencies, Bands 3,5 (FDD) and 40 (TDD) but Telia https://en.wikipedia.org/wiki/List_of_LTE_networks_in_Europe So it looks like LTE from Telia can't work with Intex antenna. You have converted only software to Jolla C not antenna. It's Jolla C only in the software layer, hardware is still Intex.

atlochowski ( 2017-05-30 18:37:29 +0300 )edit

@atlochowski jollac _is_ intex hw?

tortoisedoc ( 2017-05-30 19:52:10 +0300 )edit

no. intex has different antennas. there is many threads on tmo and tjc where coderus mention that.

atlochowski ( 2017-05-30 20:13:14 +0300 )edit

Thought so too :( - gotta find me an app that can force only 3G - at least Saunalahti 3G mobile data worked before SIM change

ehakkarainen ( 2017-06-01 14:46:43 +0300 )edit

@ehakkarainen there is a patch for that but works only with SailfishOS 2.0.5, you should ask coderus is he has plans for update this patch https://openrepos.net/content/coderusofono/patch-more-network-modes

atlochowski ( 2017-06-01 19:30:40 +0300 )edit
Login/Signup to Answer

Question tools

Follow
2 followers

Stats

Asked: 2016-08-10 19:23:07 +0300

Seen: 495 times

Last updated: May 30